1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[Fix] Wifi continually disconnecting and reconnecting with smart connect

Discussion in 'Asuswrt-Merlin' started by ryannathans, Apr 7, 2020.

  1. ryannathans

    ryannathans Regular Contributor

    Joined:
    Nov 25, 2016
    Messages:
    65
    Hi all

    When running on 384.13 I had great success with my network, everything was nice and stable. Since then, I've had some horrific instability on portable devices and only in some locations - ironically locations with strong signal.

    I think I've finally found the cause - the Smart Connect seems to work differently now.

    All I've done to fix it is increase the "dwell time" (10 min) and "window time" (2 min) so that my device will get auto-balanced less often when I'm in areas with equal-ish coverage of multiple bands. So far the connection has been far more usable.

    Oddly my chromecast doesn't work reliably since 384.13 either unless I disable MU-MIMO (or possibly Universal Beamforming, not certain) but that's a problem for another day :cool:
     
  2. Vexira

    Vexira Part of the Furniture

    Joined:
    Jan 20, 2017
    Messages:
    2,117
    Location:
    Australia
    What firmware version are you running may I ask?
     
  3. ryannathans

    ryannathans Regular Contributor

    Joined:
    Nov 25, 2016
    Messages:
    65
    Latest, 384.16 on RT-AC5300
     
  4. Vexira

    Vexira Part of the Furniture

    Joined:
    Jan 20, 2017
    Messages:
    2,117
    Location:
    Australia
    Which router are you using?

    There is a guide here or it's been suggested, that disabling my mimo and beam forwarding as well as airtime fairness has helped people
     
  5. ryannathans

    ryannathans Regular Contributor

    Joined:
    Nov 25, 2016
    Messages:
    65
    I'm using the RT-AC5300

    I never enabled fairness. Beamforming and mu-mimo are off. Next step will be testing the problem devices on a guest network so there's no smart connect to confirm all dropouts cease.
     
  6. Vexira

    Vexira Part of the Furniture

    Joined:
    Jan 20, 2017
    Messages:
    2,117
    Location:
    Australia
    Also run said insider to see if the channels In use are experiencing interference, just incase, it might be the issue.
     
  7. maus73

    maus73 New Around Here

    Joined:
    Apr 10, 2020
    Messages:
    7
    for me disabling smart connect and then setting a control channel for 2.4g and 5g wireless rather than setting to auto fixes it. with either smart connect or control channel set to auto devices get disconnected and have to be forced to reconnect or by rebooting the router.
     
    ryannathans likes this.
  8. ryannathans

    ryannathans Regular Contributor

    Joined:
    Nov 25, 2016
    Messages:
    65
    I'll try disabling smart connect and manually picking the control channel. Perhaps I'll be able to re-enable MU-MIMO - or maybe that's a separate problem...
     
  9. maus73

    maus73 New Around Here

    Joined:
    Apr 10, 2020
    Messages:
    7

    For reference, all of these options remain enabled in my setup for both 2.4g and 5g :-

    Multi-User MIMO
    Explicit Beamforming
    Universal Beamforming

    good luck.