R7800 Wan port stuck at 100M/Full

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

andronikus

New Around Here
Hi All,

I have Verizon FIOS (250M down, I-211M-L), recently I was running speed tests and couldn't figure out why my results were always slow and between 60-80 mbps.

Network is FIOS->R7800 => raspberrypi/pihole || tp-link AV2000 (powerline)->windows 10 desktop || hue || netgear arlo station

I assumed the slow speeds were because of the powerline. I reset to factory defaults and reconfigured.

Same slow results.

I then updated the firmware to VOXEL's (.82SF) and reset to factory defaults.

Same slow results.

Then I grabbed a windows laptop with ethernet and connected directly to the router. Reran speed tests.

Same slow results.

Then I connected directly to the modem with the laptop and re-ran the speed tests.

300 down/300+ up.

Then I swapped patch cables from modem->router. Reran tests with laptop using another patch cable (all cables cat6)

Same slow results.

Then I swapped the patch cables on the modem and directly connected the laptop

300 down/300+ up.

Then I changed the "internet bandwidth" on the QOS page to 250/250 (I want to define my internet bandwidth) and reran the test with the laptop directly connected via lan

Same slow results.

Finally, after looking around the control panel, I realized the "Show statistics" page has the WAN port status as "100M/Full".

I've tried multiple patch cables. The only thing I can think of is to put a switch between the modem and the router.

Do I need a new router?
 

L&LD

Part of the Furniture
@andronikus welcome to the forums.

I'm not sure which control panel shows you the WAN port status as "100M/Full"?

Is that equipment capable of 1GbE port connections?

If it is, a switch is an easy test. You may want to test with a different brand (but high quality) Cat5e cables too (the cables or the switch may cost the same in the end to fix this issue).

What firmware are you running on the R7800? You may want to check out the @Voxel firmware fork for your router instead. Along with the addons by @kamoj, @HELLO_wORLD, and the great contributions by @R. Gerrits and others too.

Be sure to read all instructions on how to get the firmware properly installed and pay particular attention to 'resets' (you do not want to do that while using Voxel firmware, I believe, there is a specific method/sequence to do it though).

Voxel - Custom firmware build for R7800 v. 1.0.2.82SF & v. 1.0.2.82.1SF | SmallNetBuilder Forums (snbforums.com)

Kamoj - Kamoj Add-on Beta testing | SmallNetBuilder Forums (snbforums.com)
 

HELLO_wORLD

Very Senior Member
First, as @L&LD is suggesting, it is a good idea to check the link speed 100M or 1000M from the laptop.

That being said, if you reach 300M+ in the speedtest, it is almost certain to be 1000M.

From a terminal on the R7800, you can run this command to check the link information:
ethtool ethwan

You can force the link speed to 1000M with the same tool.
More information here: https://phoenixnap.com/kb/ethtool-command-change-speed-duplex-ethernet-card-linux
 

kamoj

Very Senior Member
It would be very informative to know which firmware you use!
Tips:
Don't use the QoS of the R7800.
Once you get you full speed, you can experiment with this option.
 

andronikus

New Around Here
I've attached a screenshot of the router info page. Running Voxel V1.0.2.82SF. Previously I was running Netgears .52/.53 firmware version.

I've now added the switch between the router and the modem. It will not connect to the switch at 1gbps. I've tried multiple cables and ports from router->switch :(

I've also attached my QOS settings.
 

Attachments

  • r7800.PNG
    r7800.PNG
    32.7 KB · Views: 32
  • qos.PNG
    qos.PNG
    26.9 KB · Views: 33

HELLO_wORLD

Very Senior Member
I've attached a screenshot of the router info page. Running Voxel V1.0.2.82SF. Previously I was running Netgears .52/.53 firmware version.

I've now added the switch between the router and the modem. It will not connect to the switch at 1gbps. I've tried multiple cables and ports from router->switch :(

I've also attached my QOS settings.
The QOS settings will do nothing about the WAN link speed.

Have you tried ethtool from a terminal (telnet) to force link to 1000M/FULL?
 

RMinNJ

Regular Contributor
Try a third cable between to the r7800 Wan? Somehow it's negotiating 100? My 7800 was very particular what cable it liked from the Wan to my modem.
 

andronikus

New Around Here
The QOS settings will do nothing about the WAN link speed.

Have you tried ethtool from a terminal (telnet) to force link to 1000M/FULL?
I have not tried that. Not sure how to do it.


One final test: I unplugged the router and connected it directly my windows 10 pc (desktop) using the WAN port and several patch cables (2 cat 5e, 1 cat6).

All were at 100mbps.

I looked at the wan port and I don't see any damage or bent pins.

EDIT:

ran ethtool via telnet- router is currently running cat5e directly to fios modem.


Code:
[email protected]:/$ ethtool ethwan
Settings for ethwan:
        Supported ports: [ ]
        Supported link modes:   Not reported
        Supported pause frame use: No
        Supports auto-negotiation: No
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        MDI-X: Unknown
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x00000000 (0)

        Link detected: yes
 
Last edited:

HELLO_wORLD

Very Senior Member

andronikus

New Around Here
The problem is it doesn't explain why I can't get any throughput over 90mbps through the router on a wired connection.

When I connect directly to the modem I get well over 250mbps.

Also, the statistics page is still showing the wan link as 100M/Full. I don't understand why it would be wrong when the other lan ports are showing it correctly?
 

HELLO_wORLD

Very Senior Member
Have you tried the speedtest directly from the router?

Have you tried with QOS disabled?

What do you have active on your router (traffic monitor,etc...)?

And you confirm that web GUI tells 100M for WAN at the same time ethtool tells 1000M on ethwan?
 

andronikus

New Around Here
Have you tried the speedtest directly from the router?

Have you tried with QOS disabled?

What do you have active on your router (traffic monitor,etc...)?

And you confirm that web GUI tells 100M for WAN at the same time ethtool tells 1000M on ethwan?


1. Yes, here they are from dslreports

Laptop->router->modem ~ Linkspeed 1gbps (https://www.dslreports.com/speedtest/67265478)

Laptop-> modem (same cable) ~ linkspeed 1gbps (https://www.dslreports.com/speedtest/67265507)

2. Pretty sure this is disabled, I screenshot the section in a previous post.

3. On the ports: raspberry pi, hue bridge, netgear arlo station, powerline av2000.

4. Yes, the gui is reporting 100m linkspeed, and the ethwan was showing 1000


The only other test I could try is to disable wifi and disconnect all the ports except the test machine. Let me give that a try.
 

HELLO_wORLD

Very Senior Member
Ok, there is a speedtest from within the router itself on the web GUI. You tried [laptop]<—LAN—>[R7800]<—WAN—>[MODEM], but not within the R7800.

The purpose is to eliminate the hypothesis that the bottleneck is in between LAN and WAN routing in the router.

Maybe another test with trying: R7800 in bridge mode.
 

andronikus

New Around Here
Results attached. I'll try the access point when I get a chance.

Maybe its time to start looking for a replacement? I was thinking a ubiquiti USG + 8 port unifi switch + AC accesspoint lite?
 

Attachments

  • internet speed test.PNG
    internet speed test.PNG
    25.5 KB · Views: 16

RMinNJ

Regular Contributor
Maybe its on its way out.. My statistics page shows 1000Full. It most certainly explains why you're under 100Mbit through the router. Such an odd problem though.

Ubiquiti may be a good ecosystem to get into .,.the USG line is starting to get a bit older though. The dream machine gets good review but there is no wifi 6.
 

andronikus

New Around Here
Update - I gave up on additional troubleshooting, after changing to access point and reconnecting the wan, still getting 100m. I went looking for another R7800 but I couldn't find one from a first-party seller.

I ended up buying a Unifi Dream Machine. I was concerned about the earlier firmware issues but mine has been solid. I also grabbed a unfi switch 8 lite. I'm keeping the R7800 for emergencies if something happens to the UDM.

Sometimes I wonder if connecting all those wired devices to the router causes the premature death (instead of using a switch)? I haven't had a router last me more than 5 years.

Thanks all for the help.
 

RMinNJ

Regular Contributor
Let us know how the dream machine is for wifi range compared to the 7800. Take it your getting your full 300Mbit speed now.
 

andronikus

New Around Here
Range seems about the same.

As far as speedtest goes, I dont have the laptop available to test from windows, but I ran this from my pihole:


Code:
[email protected]:~ $ speedtest-cli
Retrieving speedtest.net configuration...
Testing from Verizon Fios (XXX.XX.XX.XXX)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by amazon (......) [6.21 km]: 14.843 ms
Testing download speed................................................................................
Download: 307.82 Mbit/s
Testing upload speed................................................................................................
Upload: 292.11 Mbit/s
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top