Roaming Assistant with Aimesh doesn't work

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Laxarus

Occasional Visitor
Hi all,
I have read a number of posts about roaming assistant with similar problems without a resolution. Apparently this feature was not working correctly for the Asus routers.
I have 3 Lyra MAP-AC2200 nodes with RT-AC5300 as main for my aimesh setup. (All use wired backhaul)
I am mostly satisfied with my setup except this feature. I am having problem with this especially with the stationary devices.

When you restart your system;
first your main router goes online then nodes follow.
The wifi devices connect to first SSID they see. So, they automatically connect the main router's SSID instead of the nearest node.
So far, it is normal. But then when the nodes go online, they refuse to switch to the SSID of the node. They are literally side by side but the device stays on the router's SSID.
If I restart the device manually, only then they connect to the nearest node.
To solve this issue, I have enabled Roaming Assistant but I didn't see any improvement.

Details:
Only 2.4ghz
Smart Connect disabled
Roaming Assistant set to -68dbm
fixed channel 11
20 mhz bandwidth

see here for the details:
1603069002473.png


192.168.1.66 and 192.168.1.68 stayed connected for that duration.

Anyone found a solution for this?
Or this is one of the things that we have to live with it?
 

Smokey613

Senior Member
RA works great on my setup listed in my signature. 2.4g is set to -62 and 5g is set to -70
 

MarkyPancake

Senior Member
The problem I've got with the Roaming Assistant is every time I enable it expecting the specified devices to remain connected to the router and not roam to the node, they continue to roam onto the node.
 

Laxarus

Occasional Visitor
RA works great on my setup listed in my signature. 2.4g is set to -62 and 5g is set to -70
Well, as you can see from screenshot. Mine doesn't seem to work correctly.
Roaming Assistant is set to -68dbm but there are two devices which are still connected for a long time with lower than -68dbm. So, the router doesn't disconnect them forcibly.

Question: Where is the problem?

These two devices are not old and one of them supports 802.11 b/g and the other supports 802.11 b/g/n. Is there any other setting that I can play with on the router side?
 

Smokey613

Senior Member
It is my understanding the the router can only “suggest” to the client that it needs to change to a different WIFI network and that is ultimately up to the client if it attempts to change.
 

Laxarus

Occasional Visitor
It is my understanding the the router can only “suggest” to the client that it needs to change to a different WIFI network and that is ultimately up to the client if it attempts to change.
Hmm, so the client is behaving like a sticky ex and doesn't want to let go.
 

tekrich

Regular Contributor
Do a test.

Set the values to -40, which should ditch clients quicker. And go from there.
 

CaptnDanLKW

Regular Contributor
Check a few things...
1) SSH to router and make sure roamastd is running.
2) Do you see anything in the system log? (i.e. you see anything about roamassit kicking in and knocking the clients off? (I dont THINK so since your connect time from the wireless log screenshot is 8/34/62 Hours +/-)
3) Do you use anything special like Wireless MAC filter / Roaming Black list? I could imagine they could override RA.
 

thiggins

Mr. Easy
Staff member
Devices decide when and where to roam. APs/routers have a few methods they can use, including forcing a device to disconnect, to attempt to move devices. But some devices don't respond.

For good roaming, you don't want to have too much signal overlap among nodes. Most devices start roam scans based on the signal level they detect, typically around -70 dBm. If a device never sees that level, it won't even try to roam.

For more info see my series on roaming, starting here:
 

Laxarus

Occasional Visitor
Devices decide when and where to roam. APs/routers have a few methods they can use, including forcing a device to disconnect, to attempt to move devices. But some devices don't respond.

For good roaming, you don't want to have too much signal overlap among nodes. Most devices start roam scans based on the signal level they detect, typically around -70 dBm. If a device never sees that level, it won't even try to roam.

For more info see my series on roaming, starting here:
Thanks for the details and the article. It was very informative.
It is true that there are overlaps with my setup.
I can play with the signal strength of the main router in the webui. Question: Does lowering the wifi strength also lowers the signal strenght of the nodes or it is just for the router itself?

1603986775685.png

If it was possible to fix some stationary devices (like smart home devices) to only connect to a user specified node, it would solve most of the issue (Then what happens if that node is not available?). However, it would totally destroy the minimal setup policy. There is no point to use mesh system if you are going to manually arrange each and everything.
The problem however remains that minimal setup is not working as intended with thousands of different devices using different configurations.

From what I've read so far, there is no easy fix to this problem.
 

thiggins

Mr. Easy
Staff member
I'm not an AiMesh user. But I'd imagine the Tx power adjustment applies only to the device you are logged in on, not all nodes.

Device roaming management is not easy to do. It gets better with newer devices that support 11k and especially 11v. Sometimes this can be added to laptops and smartphones via firmware upgrade. "Smart home" devices, especially dumber ones like switches, locks and even some network cameras tend to be less upgradeable.
 

rlucho

New Around Here
How can i link clients to a node? I don't see that option...

Runnning 2 AX11000 in AiMesh mode (wired backhaul), with FW Beta 386.40947.

My HP printer (2.4Ghz) keeps connected to the main router even when the node is by its side, also my Laptop (5Ghz-2 and wifi 6) and my Phone when im in the 2nd floor...
 

OzarkEdge

Part of the Furniture
How can i link clients to a node? I don't see that option...

Runnning 2 AX11000 in AiMesh mode (wired backhaul), with FW Beta 386.40947.

My HP printer (2.4Ghz) keeps connected to the main router even when the node is by its side, also my Laptop (5Ghz-2 and wifi 6) and my Phone when im in the 2nd floor...
Have you tried raising (less negative) the Roaming Assistant RSSI thresholds?

Have you tried putting more space between the printer and the node?

The printer might see two very strong 2.4 signals and prefer the one less overpowering and/or less distorted/better received by not being too close.

OE
 

SandmanXX

Occasional Visitor
In the Aimesh node menu, get the list of nodes, click a node, then that should show you a list of clients attached at that time.
Screenshot 2020-11-21 111626.jpg

The curly link is to attach the client to that node, and the other is a refresh to connect. This only works on wireless clients, you won't see these options on a wired client of that node.
 

rlucho

New Around Here
In the Aimesh node menu, get the list of nodes, click a node, then that should show you a list of clients attached at that time.
View attachment 27832

The curly link is to attach the client to that node, and the other is a refresh to connect. This only works on wireless clients, you won't see these options on a wired client of that node.
Thanks! Done!

P.D: Just had to reboot the router/system from Web GUI because the main router had no internet connection but the node was working perfectly... The main router didn't allow devices to connect and showed internet connection as Disconnected in the web GUI... Rebooted and everything working again, im using the latest BETA.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top