router.asus.com vs 192.168.50.1

tomasm

New Around Here
I'm trying to access router.asus.com on my desktop PC and get:
"Unable to connect. An error occurred during a connection to router.asus.com. "
I can only access the settings using 192.168.50.1 and I'm super curious why router.asus.com isn't working when it was working fine within the last few weeks. I tried 3 different browsers. I can access router.asus.com on my phone so there's something that's changed on my PC and I can't find what it is and it's bugging me.
I haven't made any changes on my PC for a long time, BUT I did install a new modem yesterday. I don't see how that could have caused the problem. Maybe it did??
 

PRSXFENG

Occasional Visitor
I also have that problem, what I noticed is that my browser changes the url above to https instead of http

So my guess is that browsers are more pushy about connecting over unsecured http I suppose?
Just my guess, unsure if it's the actual cause
 

bbunge

Part of the Furniture
Firefox does have a feature that blocks http if enabled. If the browser uses DoH turn that off as well.
 

tomasm

New Around Here
Ok, so this is a browser problem after all.

Yes, in Firefox the url is automatically changed to https. Can't get rid of the "s".
In Chrome, if entered as https://router.asus.com/ then: "This site can’t be reached". Entered without the "s" then it works.

In Firefox I have HTTPS-Only Mode disabled. But I do have Enable DNS over HTTPS turned on and I'm going to leave that alone (and turning it off doesn't fix the problem anyway).

This is a new router and I definitely accessed the settings page using the url in Firefox within the last two weeks. Maybe a Firefox update caused the problem Since this is a browser related issue I'm a little less annoyed now. Thanks.
 

andyross

Occasional Visitor
Just noticed the same problem with Firefox. Probably something with FF 104. Even 192.168.50.1 does not work. I have to use Edge.
 

Justinh

Regular Contributor
Sooo, if a different IP address works, then doesn't that mean the original IP address is the wrong address and you could expect it to not work? How can you have two diff network addresses for the admin page?
 

tomasm

New Around Here
Sooo, if a different IP address works, then doesn't that mean the original IP address is the wrong address and you could expect it to not work? How can you have two diff network addresses for the admin page?
Sounds like maybe depends on the model. 192.168.1.1 doesn't work for me on an RT-AX55. Only 192.168.50.1
 

PRSXFENG

Occasional Visitor
192.168.1.1 is probably after manually changing it

Asus seems to use 192.168.50.1 by default

But folks like to have it on more common subnet like 192.168.1.X or 192.168.0.X

I manually changed my RT-AX53U from .50 to .1
 

andyross

Occasional Visitor
I have an AC68U, and haven't made any changes from factory. It is using 192.168.1.1. I've had it nearly 5 years, and looking at my saved firmware downloads, it was major version 382 back then. I have never factory reset since the initial setup, so maybe it has held onto the 'old' address if newer firmware normally defaults to 50.1.
 

L&LD

Part of the Furniture
If it's never been reset, then it won't change those settings (of course).
 

andyross

Occasional Visitor
In a side question: If newer firmware/models default to 50.1, is the local network still 1.1? Why be on a different subnet?
 

andyross

Occasional Visitor
So it sounds like newer routers/firmware will default to 192.168.50.x on a fresh setup, maybe after one of the major version updates? Otherwise, if you specify something in the LAN settings, it obviously uses that.
To be honest, I don't remember if I had manually forced mine to 1.x or not, but as noted, that was 4 or so years ago.
 

andyross

Occasional Visitor
I don't know if the just released 104.0.2 has any fix, but this was posted in the bugzilla entry:
This bug is caused by https://hg.mozilla.org/integration/autoland/rev/c68760840d71a54f3ffea60824e245decce580da which added asus.com to the preloaded HSTS list. That means the load will always attempt to use HTTPS.
@RyanVM - presumably it's asus that requested to be included in the pinned list? ( Through https://hstspreload.org/? )
What should we do now? This is breaking their own clients' experience.

They also wanted me to try »router.asus.com:8443, but that also fails. I know there is a setting where you can enable HTTPS for local access. Does that make a difference as far as the bug? I'm not sure if I want to try it right now, just to be safe.
 

ColinTaylor

Part of the Furniture
So it sounds like newer routers/firmware will default to 192.168.50.x on a fresh setup, maybe after one of the major version updates? Otherwise, if you specify something in the LAN settings, it obviously uses that.
To be honest, I don't remember if I had manually forced mine to 1.x or not, but as noted, that was 4 or so years ago.
After a factory reset the router pulls the default LAN address from the CFE. Older routers like the RT-AC68U used 192.168.1.1, but newer models default to 192.168.50.1. So it varies by model not firmware.
 

andyross

Occasional Visitor
If you want, you can disable the 'forced' HTTPS list with this setting. I decided to leave mine alone as the direct IP works fine and the list probably provides some extra security.
I think you can disable the preload list by setting network.stricttransportsecurity.preloadlist=false in about:config
 

andyross

Occasional Visitor
In the bugzilla thread, they noted they received a response from Asus:
Thank you for details. We have managed to reproduce on some router models.
Here in Nordic office we cannot directly offer solution to such issue, We have passed this on to our HQ to resolve.
Solution/action plan unfortunately will be delayd due to Mid-Autum festival.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top