What's new

Wired speeds are good but Wifi speeds are not on my ASUS router

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Redinade

New Around Here
Hi first post here in hopes to fix this issue.

I have recently got 500 down and 500 up. Wired speeds and the speeds in my ASUS AX58U router are fine.

The Wifi speeds however are only getting as high as 250. 300 if I'm lucky and this is all when I'm right next to the router with my phone or laptop. Both my phone and laptop are capable of 500 too.

I've tried lots of things Ive seen online already such as channel changing with the Wifi analyser app and reboots and checking cables. (all of hem are Cat6)

Context, I used to have 250 down and 25 up before and Wifi speeds then were consistently 250 down on all devices. Now I'm only getting 200 consistently when I have 500 available.

My ASUS AX58U is running the merlin software too most recent version. I'm sure it is a setting somewhere that is keeping the best speeds from coming out. Would a Factory reset do anything?

Any advice please? Thank you

Here are my settings :
 

Attachments

  • Screenshot 2024-01-20 180912.jpg
    Screenshot 2024-01-20 180912.jpg
    79.2 KB · Views: 27
  • Screenshot 2024-01-20 180934.jpg
    Screenshot 2024-01-20 180934.jpg
    92 KB · Views: 27
Look at the client's Tx/Rx speeds under System Log - Wireless Log.
More than happy to be told Im wrong on this but just seems weird on a speedtest Im not getting my advertised speeds when im right next to the router, all be it less than wired as Wifi would be less I understand.
 
Leave Wireless Mode on Auto, for highest performance.

Use a fixed Control Channel (test them all).

Disable Universal Beamforming.

Reboot after any changes, verify the new options selected 'stick'.
 
Leave Wireless Mode on Auto, for highest performance.

Use a fixed Control Channel (test them all).

Disable Universal Beamforming.

Reboot after any changes, verify the new options selected 'stick'.
Ill have a check on all the channels later tonight. And thanks Ill change wireless mode to that too. ill update later on if it worked or not.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top