1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT-AC68, IP not updating in DDNS, using mobile hotspot & Openvpn

Discussion in 'ASUS Wireless' started by sceptre, Nov 16, 2019.

  1. sceptre

    sceptre New Around Here

    Joined:
    Nov 16, 2019
    Messages:
    1
    Using an Asus Rt-AC68p router with latest Asuswrt-Merlin installed. I have a mobile hotspot (At&t) connected to its USB port and USB activated in the router. My computer is connected to the router and an internet connection is successful with this arraignment and my computer has a reported public IP address. I have previously set up DDNS in the router and configured OpenVpn as well when the router was connected to the local ISP (wired connection) and the OpenVpn connection worked at that time. When I tried to transition to using the mobile hotspot as the internet source the DDNS apparently is not able to continue to update to keep OpenVpn working. So I am unable to connect remotely. I have tried port forwarding the 1194 port and I have activated DMZ for the router, but it still doesn't work. There is msg on the router about the router having a private IP address and it suggests doing the port forwarding but it doesn't work. I found several mentions of resolving a double NAT situation and I found a couple of references to scripts that might be related to this problem, but although I could possibly get the scripts loaded on the router I'm no good at writing them. It seems to me there is way (script?) for the router to obtain the IP address and to continue to check it and make sure DDNS and the Openvpn are kept updated with the correct IP. I suspect someone has already solved this problem but I could not find it anywhere in my searches. If you can help me understand how to accomplish this or point me to the solution, it will greatly appreciated.
     
  2. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,690
    Do you use asuscomm DDNS with Lets Encrypt? That's broken, fixed with newest 81351 firmware but have to wait for Merlin.
     
  3. Adamm

    Adamm Part of the Furniture

    Joined:
    Mar 26, 2013
    Messages:
    2,337
    Not sure how AT&T does things, but assuming you are using a mobile connection there's a good chance you are using Carrier-grade NAT in which case you won't be able to connect to the router remotely as you share the same IP address with potentially hundreds of other customers.



    Edit; Quick google search shows this is the case.