Solved RT-AX56U 5Ghz Wi-Fi not visible for several devices

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

adzie

Occasional Visitor
Hello Expert,

I have strange phenomenon on my devices, suddenly 5Ghz is not visible for several devices that capable of using 5Ghz Wi-Fi such as my iphone x, my HP Probook, macbook air.

however some devices like iphone SE and my android box can see it.

below is the composition:
1. Android Box (Can connect and see 5 Ghz signal)
2. Iphone SE (Can connect and see 5 Ghz signal)
3. Iphone X (Cannot connect and see 5 Ghz signal)
4. HP Probook 430 (Cannot connect and see 5 Ghz signal)
5. MacBook Air (Cannot connect and see 5 Ghz signal)

i put my 5Ghz setting on Auto Channel and strangely it is always picking channel 36/80, could it be product defect? from the devices that can connected to 5Ghz it is working fine.

I was doing several actions below but still not helped

1. 30/30/30
2. re-flash the Merlin firmware and then restore to factory default by checking the thick box for initializing all settings
3. turn off, then turn ON the 5 Ghz radio and I did this perhaps hundreds of time
4. disable AX mode

I haven't done NVRAM reset yet and will try to do it later. any other steps that I can tried before I send back this to the store and get the
replacement?

I did check Wireless MAC filter and I can confirm is not enabled.

I'm using AsusWRT Merlin 381.1_2 FW. below is the syslog from my router and as I'm aware there no error messages.
also attached my 5 Ghz radio status

thank you in advance for the advice

Line 3621: Feb 22 23:09:59 kernel: device eth6 left promiscuous mode
Line 3622: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered disabled state
Line 3628: Feb 22 23:09:59 kernel: device eth6 entered promiscuous mode
Line 3629: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered listening state
Line 3630: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered listening state
Line 3636: Feb 22 23:10:01 kernel: br0: port 6(eth6) entered learning state
Line 3661: Feb 22 23:10:03 kernel: br0: port 6(eth6) entered forwarding state
Line 3696: Feb 22 23:11:12 kernel: device eth6 left promiscuous mode
Line 3697: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered disabled state
Line 3702: Feb 22 23:11:12 kernel: device eth6 entered promiscuous mode
Line 3703: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered listening state
Line 3704: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered listening state
Line 3709: Feb 22 23:11:14 kernel: br0: port 6(eth6) entered learning state
Line 3710: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3711: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3712: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3714: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(486): eth6: Disassoc 6C:21:A2:9C:XX:XX, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Line 3715: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(486): eth6: Disassoc 6C:21:A2:9C:XX:XX, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Line 3716: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: disassociated
Line 3717: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: disassociated
Line 3730: Feb 22 23:11:16 kernel: br0: port 6(eth6) entered forwarding state
Line 3736: Feb 22 23:11:17 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3737: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3738: Feb 22 23:11:17 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3740: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX RADIUS: starting accounting session 73051CD5E2DE4A8A
Line 3741: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX WPA: pairwise key handshake completed (RSN)
Line 3900: Feb 22 23:13:04 kernel: device eth6 left promiscuous mode
Line 3901: Feb 22 23:13:04 kernel: br0: port 6(eth6) entered disabled state
Line 3907: Feb 22 23:13:05 kernel: device eth6 entered promiscuous mode
Line 3908: Feb 22 23:13:05 kernel: br0: port 6(eth6) entered listening state
Line 3909: Feb 22 23:13:05 kernel: br0: port 6(eth6) entered listening state
Line 3912: Feb 22 23:13:05 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 6C:21:A2:9C:XX:XX, status: 0, reason: Class 3 frame received from nonassociated station (7)
Line 3914: Feb 22 23:13:07 kernel: br0: port 6(eth6) entered learning state
Line 3915: Feb 22 23:13:08 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3916: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3917: Feb 22 23:13:08 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3919: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX RADIUS: starting accounting session CBEC7628F3A8B5B7
Line 3920: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX WPA: pairwise key handshake completed (RSN)
Line 3925: Feb 22 23:13:09 acsd: eth6: Selecting 5g band ACS policy
Line 3929: Feb 22 23:13:09 kernel: br0: port 6(eth6) entered forwarding state
Line 3952: Feb 22 23:13:11 acsd: eth6: selected channel spec: 0xe02a (36/80)
Line 3953: Feb 22 23:13:11 acsd: eth6: Adjusted channel spec: 0xe02a (36/80)
Line 3954: Feb 22 23:13:11 acsd: eth6: selected channel spec: 0xe02a (36/80)
 

Attachments

  • 1.jpg
    1.jpg
    62.4 KB · Views: 13
  • 2.jpg
    2.jpg
    64.5 KB · Views: 12
  • 3.jpg
    3.jpg
    74.2 KB · Views: 12
  • 4.jpg
    4.jpg
    50.8 KB · Views: 11
  • 1614048094259.png
    1614048094259.png
    375.5 KB · Views: 11
Last edited:

ATLga

Senior Member
Hello Expert,

I have strange phenomenon on my devices, suddenly 5Ghz is not visible for several devices that capable of using 5Ghz Wi-Fi such as my iphone x, my HP Probook, macbook air.

however some devices like iphone SE my android box can see it.

i put my 5Ghz setting on Auto Channel and strangely it is always picking channel 36/80, could it be product defect? from the devices that can connected to 5Ghz it is working fine.

I was doing several actions below but still not helped

1. 30/30/30
2. re-flash the Merlin firmware and then restore to factory default by checking the thick box for initializing all settings
3. turn off, then turn ON the 5 Ghz radio and I did this perhaps hundreds of time

I haven't done NVRAM reset yet and will try to do it later. any other steps that I can tried before I send back this to the store and get the
replacement?

I did check Wireless MAC filter and I can confirm is not enabled.

I'm using AsusWRT Merlin 381.1_2 FW. below is the syslog from my router and as I'm aware there no error messages.

thank you in advance for the advice

Line 3621: Feb 22 23:09:59 kernel: device eth6 left promiscuous mode
Line 3622: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered disabled state
Line 3628: Feb 22 23:09:59 kernel: device eth6 entered promiscuous mode
Line 3629: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered listening state
Line 3630: Feb 22 23:09:59 kernel: br0: port 6(eth6) entered listening state
Line 3636: Feb 22 23:10:01 kernel: br0: port 6(eth6) entered learning state
Line 3661: Feb 22 23:10:03 kernel: br0: port 6(eth6) entered forwarding state
Line 3696: Feb 22 23:11:12 kernel: device eth6 left promiscuous mode
Line 3697: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered disabled state
Line 3702: Feb 22 23:11:12 kernel: device eth6 entered promiscuous mode
Line 3703: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered listening state
Line 3704: Feb 22 23:11:12 kernel: br0: port 6(eth6) entered listening state
Line 3709: Feb 22 23:11:14 kernel: br0: port 6(eth6) entered learning state
Line 3710: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3711: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3712: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3714: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(486): eth6: Disassoc 6C:21:A2:9C:XX:XX, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Line 3715: Feb 22 23:11:15 wlceventd: wlceventd_proc_event(486): eth6: Disassoc 6C:21:A2:9C:XX:XX, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Line 3716: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: disassociated
Line 3717: Feb 22 23:11:15 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: disassociated
Line 3730: Feb 22 23:11:16 kernel: br0: port 6(eth6) entered forwarding state
Line 3736: Feb 22 23:11:17 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3737: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3738: Feb 22 23:11:17 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3740: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX RADIUS: starting accounting session 73051CD5E2DE4A8A
Line 3741: Feb 22 23:11:17 hostapd: eth6: STA 6C:21:A2:9C:XX:XX WPA: pairwise key handshake completed (RSN)
Line 3900: Feb 22 23:13:04 kernel: device eth6 left promiscuous mode
Line 3901: Feb 22 23:13:04 kernel: br0: port 6(eth6) entered disabled state
Line 3907: Feb 22 23:13:05 kernel: device eth6 entered promiscuous mode
Line 3908: Feb 22 23:13:05 kernel: br0: port 6(eth6) entered listening state
Line 3909: Feb 22 23:13:05 kernel: br0: port 6(eth6) entered listening state
Line 3912: Feb 22 23:13:05 wlceventd: wlceventd_proc_event(469): eth6: Deauth_ind 6C:21:A2:9C:XX:XX, status: 0, reason: Class 3 frame received from nonassociated station (7)
Line 3914: Feb 22 23:13:07 kernel: br0: port 6(eth6) entered learning state
Line 3915: Feb 22 23:13:08 wlceventd: wlceventd_proc_event(505): eth6: Auth 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3916: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX IEEE 802.11: associated
Line 3917: Feb 22 23:13:08 wlceventd: wlceventd_proc_event(534): eth6: Assoc 6C:21:A2:9C:XX:XX, status: Successful (0)
Line 3919: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX RADIUS: starting accounting session CBEC7628F3A8B5B7
Line 3920: Feb 22 23:13:08 hostapd: eth6: STA 6C:21:A2:9C:XX:XX WPA: pairwise key handshake completed (RSN)
Line 3925: Feb 22 23:13:09 acsd: eth6: Selecting 5g band ACS policy
Line 3929: Feb 22 23:13:09 kernel: br0: port 6(eth6) entered forwarding state
Line 3952: Feb 22 23:13:11 acsd: eth6: selected channel spec: 0xe02a (36/80)
Line 3953: Feb 22 23:13:11 acsd: eth6: Adjusted channel spec: 0xe02a (36/80)
Line 3954: Feb 22 23:13:11 acsd: eth6: selected channel spec: 0xe02a (36/80)
Are you hiding ssid
Post screenshot of 5ghz GUI page
 

adzie

Occasional Visitor
Are you hiding ssid
Post screenshot of 5ghz GUI page
SSID not hide or deactivated, I snapshot my 5 Ghz settings.
 

Attachments

  • 1.jpg
    1.jpg
    62.4 KB · Views: 11
  • 2.jpg
    2.jpg
    64.5 KB · Views: 11

ATLga

Senior Member
You say Not Visible for devices that can use 5ghz in your first paragraph and then say for the devices that can connect to 5 ghz it works fine. Conflicting statements.


“I have strange phenomenon on my devices, suddenly 5Ghz is not visible for several devices that capable of using 5Ghz Wi-Fi such as my iphone x, my HP Probook, macbook air.

however some devices like iphone SE and my android box can see it.

i put my 5Ghz setting on Auto Channel and strangely it is always picking channel 36/80, could it be product defect? from the devices that can connected to 5Ghz it is working fine.”
 

adzie

Occasional Visitor
is there an auto in the droodown
yes I tried to set it as AUTO but my iphone X cannot pick up the wifi while iphone SE can... below is the snapshot from my router after I turned OFF AX and also snapshot from my iphone x and se
 

Attachments

  • 1614047051563.png
    1614047051563.png
    360.5 KB · Views: 6
  • 1614047375031.png
    1614047375031.png
    376.4 KB · Views: 6
  • 1614047656951.png
    1614047656951.png
    106.1 KB · Views: 6
  • 1614047675694.png
    1614047675694.png
    172.9 KB · Views: 6

adzie

Occasional Visitor
You say Not Visible for devices that can use 5ghz in your first paragraph and then say for the devices that can connect to 5 ghz it works fine. Conflicting statements.


“I have strange phenomenon on my devices, suddenly 5Ghz is not visible for several devices that capable of using 5Ghz Wi-Fi such as my iphone x, my HP Probook, macbook air.

however some devices like iphone SE and my android box can see it.

i put my 5Ghz setting on Auto Channel and strangely it is always picking channel 36/80, could it be product defect? from the devices that can connected to 5Ghz it is working fine.”
yes I have several devices that have capability for 5Ghz below is the explanations. so it is strange in the exact same location
some device can see it and some devices cannot and Wireless MAC filter is not activated in my router.

1. Android Box (Can connect and see 5 Ghz signal)
2. Iphone SE (Can connect and see 5 Ghz signal)
3. Iphone X (Cannot connect and see 5 Ghz signal)
4. HP Probook 430 (Cannot connect and see 5 Ghz signal)
5. MacBook Air (Cannot connect and see 5 Ghz signal)
 

adzie

Occasional Visitor
Last suggestion for the evening, set your channel to 157 from auto. Reboot then check clients
wow.. how come it works o_O... now I can see my 5Ghz from all the devices .. does it mean channels 36 is congested? why when it set to auto my router is always picking channel 36...

somehow it works now thanks a lot for the suggestion Bro...
 

Attachments

  • 1614048395821.png
    1614048395821.png
    141.4 KB · Views: 7

ATLga

Senior Member
yes I have several devices that have capability for 5Ghz below is the explanations. so it is strange in the exact same location
some device can see it and some devices cannot and Wireless MAC filter is not activated in my router.

1. Android Box (Can connect and see 5 Ghz signal)
2. Iphone SE (Can connect and see 5 Ghz signal)
3. Iphone X (Cannot connect and see 5 Ghz signal)
4. HP Probook 430 (Cannot connect and see 5 Ghz signal)
5. MacBook Air (Cannot connect and see 5 Ghz signal)
The three clients that can’t see or connect - have they always had this issue or just started. If so, what changed on the router, firmware, settings, or client settings

never mind, solved
 

ATLga

Senior Member
wow.. how come it works o_O... now I can see my 5Ghz from all the devices .. does it mean channels 36 is congested? why when it set to auto my router is always picking channel 36...

somehow it works now thanks a lot for the suggestion Bro...
Honestly not sure. It’s usually best no smart connect and set channels manually. Some clients don’t play well if the router is changing channels. 2.4 ghz ch 1 6 or 11. 5 ghz IMO ch 157. 36 is usually good, might be the auto throwing it off. Yiu could try a manual set of 36 and see if they see that. Personally I’d leave it on 157.

regarding congestion, from your iPhone WiFi shots I don’t see any other WiFi so doesn’t look congested. Could be other things going on though and the clients just don’t like the ch.
 

adzie

Occasional Visitor
Honestly not sure. It’s usually best no smart connect and set channels manually. Some clients don’t play well if the router is changing channels. 2.4 ghz ch 1 6 or 11. 5 ghz IMO ch 157. 36 is usually good, might be the auto throwing it off. Yiu could try a manual set of 36 and see if they see that. Personally I’d leave it on 157.

regarding congestion, from your iPhone WiFi shots I don’t see any other WiFi so doesn’t look congested. Could be other things going on though and the clients just don’t like the ch.
I did manually set to 36 earlier and its not working either. I remember last week I was trying playing around with extats (https://github.com/corgan2222/extstats) and how stupid I'm test the script on RT-AX56U while it is already mentioned for AX-88U...

but I did remove all the scripts including the python entware packages.. didn't having any issue until I reboot the router yesterday, after I reboot then this behavior is started, but I did not expecting the damage would be like this...

anyway thanks tho really appreciate your advice and suggestion.
 

ATLga

Senior Member
I did manually set to 36 earlier and its not working either. I remember last week I was trying playing around with extats (https://github.com/corgan2222/extstats) and how stupid I'm test the script on RT-AX56U while it is already mentioned for AX-88U...

but I did remove all the scripts including the python entware packages.. didn't having any issue until I reboot the router yesterday, after I reboot then this behavior is started, but I did not expecting the damage would be like this...

anyway thanks tho really appreciate your advice and suggestion.
Well as far as post #12 goes, that's what changed. Not sure how all that affected anything though if you did this in post #1 -

"2. re-flash the Merlin firmware and then restore to factory default by checking the thick box for initializing all settings"

Unless of course you restored/reloaded old backed-up settings afterwards. Regardless, sounds like all is running ok now. Good luck
 

adzie

Occasional Visitor
Well as far as post #12 goes, that's what changed. Not sure how all that affected anything though if you did this in post #1 -

"2. re-flash the Merlin firmware and then restore to factory default by checking the thick box for initializing all settings"

Unless of course you restored/reloaded old backed-up settings afterwards. Regardless, sounds like all is running ok now. Good luck
you know what, I tried to put the channel back to auto and now the device that earlier cannot see 5Ghz signal like my iphone x now still normal and able to see the wifi signal... strange right
 

J.I

Occasional Visitor
I have devices in my house from Europe and USA for 5G to work with all of them I had to change 5G channel from auto to something that is available in USA and Europe for me is channel 36. Otherwise my european devises could not see 5G
 

adzie

Occasional Visitor
I have devices in my house from Europe and USA for 5G to work with all of them I had to change 5G channel from auto to something that is available in USA and Europe for me is channel 36. Otherwise my european devises could not see 5G
I see, so it is depends on the standardization of the devices is also matters.. anyway thanks for the information
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top