What's new

RT-AX86U Pro (merlin firmware: 388.1_0) as default aimesh & RT-AC68U as aimesh node

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Hi. I bought a new RT-AX86U Pro router as a replacement for the RT-AC68U.
To begin with, I updated the firmware in RT-AX86U Pro to the merlin firmware: 388.1_0 and configured everything. In RT-AC68U I also updated the merlin firmware: 386.10_0. Currently I would like to use the RT-AC68U as an Aimesh node. Unfortunately, no matter what I do, the RT-AX86U Pro doesn't detect the RT-AC68U as an aimesh node.
I've tried different ways and nothing changes. I also changed the firmware in RT-AC68U to the latest original Asus: 300438651255 and it is also unchanged. I can't connect RT-AC68U as Aimesh node.

On RT-AX86U Pro with Merlin firmware: 388.1_0 I set everything up and everything works fine. I really don't want to go back to the original Asus latest firmware and reconfigure everything to see if aimesh will work.

Does anyone have an idea what the problem could be. Does the RT-AX86U Pro running Merlin: 388.1_0 support Aimesh without any issues?

Does anyone have any experience on this topic?
Even though Rmerlin cannot touch the aimesh stuff as it is closed source, I think its pretty common knowledge for some reason its very hard to add nodes when running merlin. If you connect with a cable, after 2-3 trys it will usually go. If your wanting to do it via wifi.. Install stock firmware on everything, create the aimesh network, Then update the main to merlin..
I understand that there is no way to connect Aimesh with installed Merlin software?

I need to restore the original asus firmware. Then make Aimash connection between RT-AX86U Pro and RT-AC68U, then update "Merlin firmware" for RT-AX86U Pro. Will the Aimesh connection be preserved for sure?

It's a bit weird for me. Since Aimesh is closed source and Merlin is not interfering with it in any way, why are there any problems?

I understand that in this case I will have to configure everything again on the original Asus firmware and after updating to the Merlin firmware the configuration should be without problems ;)
I understand that there is no way to connect Aimesh with installed Merlin software?

There is a way, but often not as described by Asus in official AiMesh setup instructions. Read the information above.

Since Aimesh is closed source and Merlin is not interfering with it in any way, why are there any problems?

It is closed source, but obviously something is interfering with it. Since we can't see AiMesh code - we don't know what it is. It can be as simple as expected firmware version mismatch and it's inconsistent between different router models. Maybe AiMesh is looking for something missing in Asuswrt-Merlin firmware. There were reports for WPS issues - AiMesh uses WPS for initial setup. I was getting consistently better Wi-Fi on Asuswrt release versions (many different models and currently on RT-AX86U) - may be Broadcom drivers related, also closed source. We had fixes coming few times from Asus. For added complexity often Asuswrt releases are different than GPL used for Asuswrt-Merlin. Replacing only visible parts of a machine may alter the operation.

and after updating to the Merlin firmware

Currently available Asuswrt is newer than what Asuswrt-Merlin 388.1 is based on. Some may disagree, but I see it as downgrading.
Last edited:
Hi Greeno, as you have already read, I'm in the same situation as you wanting to use my "old" AC68U as MESH device and the new AX86U Pro as master device.
I will follow the thread hoping for a different solution than the one proposed.
You guys try this:

- AX86U with WPS Enabled, both radios Enabled, 2.4GHz Ch.6, 5GHz Ch.36, Smart Connect Disabled
- AC68U on latest stock 386_51255* firmware, reset to factory defaults, turned off
- connect AX86U LAN port 1 (not 2.5GbE, normal Gigabit) to AC68U WAN port
- do WPS hard reset on AC68U as it is connected (see Asus hard reset instructions), wait for the power LED
- hit Add AiMesh Node in AiMesh menu of AX86U quickly and wait
- if it fails - try again, it may take few attempts, but eventually works
- when it adds successfully - turn AC68U off, disconnect the wire, move it some distance away and power it back on

- make sure AiMesh is working before you change your main router Wi-Fi settings to your liking
- keep Backhaul Mode to Auto even if you use Ethernet backhaul
- AC68U doesn't support Smart Connect - keep it Disabled
- AC68U may not support some of the 5GHz channels available on AX86U, make sure you set what's supported
- you can disable WPS on AX86U

Unfortunately, if AiMesh fails for some reason - the magic above again.

* - if it doesn't work with 386_51255, try again with previous 386_49703 firmware.
Last edited:
I've had several nodes connected to my main router, using Merlin and without any issues whatsoever. Make sure you reset the node to default settings. Connect the node wan directly via ethernet cable to main router lan. Tips above also can definitely help. I have not been able to do this wirelessly.
Thanks for the advice, I'll keep fighting. If I can come up with something meaningful, I'll write about it. regards
I tried the tips you wrote about. Currently I can search for RT-AC68U as AiMesh node. I connect the RT-AC68U with an ethernet cable to the WAN port, and the RT-AX86U-PRO to one of the lan ports, and it does not matter if it is port 1 or 2-4. Unfortunately, every attempt to connect the RT-AC68U as an Aimesh node ends with a message about unable to connect (each attempt to 90-93%) and looks like this:
RT-AC68U (Mac Address)
The AiMesh node RT-AC68U (mac address) could not be added to the AiMesh system due to the following reasons. Please check and try again.

Another person is setting up AiMesh. Please wait 1 minute and try again.
During installation, the distance between the router and the AiMesh node should not exceed 3 meters. Make sure the AiMesh node is turned on.
The AiMesh node firmware has been updated to support AiMesh.
Verify that the AiMesh node has been reset to default settings.

To find the next available AiMesh node, click "Search".

Changing the WIFI connection parameters to the following also does not change anything in the subject:

AX86U WPS enabled,
channel 6 2.4GHz,
5GHz channel 36,
Smart link disabled.

I tried different firmwares:
ASUS WRT: 300438651255, 300438649703, 300438648262.
Merlin firmware: 386.10_0, 386.9_0.

It doesn't change anything.

Is there anyone on the forum who has an RT-AX86U-PRO with Merlin: 388.1_0 firmware installed and was able to connect the RT-AC68U or another router as an AiMesh node?

I think I have one more test to check, i.e. restoring the original asus wrt firmware on the RT-AX86U-PRO and checking the possibility of connection. Unfortunately, I don't have much free time lately, so it's probably not going to happen soon.
1) Disconnect all ETH cables from the node
2) Reset the node: a) turn the node off; b) press and hold WPS button; c) turn node on; d) wait until the power led starts flashing (around 25 seconds on my nodes); e) release the WPS button; f) wait for the node to boot up
3) Connect your desktop / laptop / tablet / etc to the router either wirelessly or wired
4) In your browser, navigate to either router.asus.com or your router's IP address. You should be accessing you router's GUI, not your node's then
5) Disable WAN/Internet
6) Connected an ETH cable to one of the LAN ports of the router and to the WAN port of the node
7) In the router's GUI, start the Add AiMesh Node and wait for it to complete. It may finish fine before reaching 100% and display a success message. It happened to me more than once to think it was an error as it finished earlier than I expected. So, be sure before you assume it failed.
8) Enable WAN/Internet

Thanks to a member on our site but there are more if you search.
I did everything according to your list. The only difference was that I didn't include #5 (Disable WAN/Internet).
However, today I found some time and checked with WAN/Internet off as well and it doesn't change anything in my case.
In total, I tried about 20 or more attempts to connect the Aimesh node, and none were successful (several attempts, each with different "firmware" versions for the RT-AC68U).

I have to try to upload the original latest asus-WRT firmware for RT-AX86U Pro and check, because I can't think of anything else.
Your routers are few generations apart and this is perhaps the main issue here.

RT-AC68U -> RT-AC86U -> RT-AX86U -> RT-AX86U Pro
Supportive forumers.

I finally managed to solve the problem of connecting the RT-AC68U as an aimesh node to the RT-AX86U Pro.
In principle, the problem turned out to be trivial, but it's a pity that it is not written anywhere, I did not find it in any thread about Aimesh.
It turns out that in order to connect the Aimesh node, a DHCP server must be running on the router, and I don't use it on the router. Otherwise, any attempt to connect the node will fail.

Due to the fact that I do not use the router's DHCP server, I solved the problem by running it but in the range of one IP address. Even if you connect the Aimesh node to a router with the router's dhcp enabled and then turn it off, the Aimesh node will not connect without the router's dhcp server enabled every time it restarts or the address lease expires.

Unfortunately, my path to success was quite winding. I restored the RT-AX86U Pro to the original, latest Asus WRT firmware, and while disabling the dhcp server, I noticed the router system's remark about an Aimesh connection problem with the DHCP server disabled. Once I was able to connect the RT-AC68U as an aimesh node to the RT-AX86U Pro with the DHCP server enabled, I went back to the latest Merlin firmware for the RT-AX86U Pro and restored the settings from the previously saved config file and reconnected the RT-AC68U as the aimesh node to RT-AX86u Pro.

I have to say that it works very well, the WIFI propagation is now much better throughout the apartment.

One thing I am wondering now. I currently have several network devices that I no longer need when using Aimesh. I am considering selling these devices along with the RT-AC68U (which is a good price despite its age) and buying a newer ASUS router to use as the Aimesh Node. New routers have newer radios, which will certainly propagate the WIFI signal even better.
I will get about $120 for the devices sold. Can you recommend me an asus router at this price that is worth buying and using as an Aimesh Node?
a DHCP server must be running on the router

Well... thanks for wasting our time. You ware modifying the default configuration every single time and on every firmware without saying a word about it and without paying attention to the GUI messages.



Can you recommend me an asus router...

Last edited:
Can you tell me where I wrote that I change the default configuration every time and on every firmware!
I didn't do or write anything like that!

The setup of the RT-AX86U Pro was the same from the start. The RT-AX86U Pro was set up before I started trying to connect the RT-AC68U as an Aimesh node.

The only thing I changed many times was the firmware in RT-AC68U and wrote about it.

Did you write somewhere that the Aimesh Router must have an HDCP server running?
Can you explain to me your annoyance and why you consider your posts wasted. However, your posts helped me a lot with the setup.

I respect every post, every person and thank you for your time.

Let's respect each other!
Last edited:
I believe @Tech9 is simply pointing out that you didn’t mention that you had disabled the routers DHCP server. This is not the default configuration. Many of us would assume (I know, assume can be dangerous) that you had left anything you hadn’t mentioned at it’s default setting - in this case the DHCP server.
I was tracking down a rogue dhcp server on my network recently, and saw the warning about AiMesh and disablig DHCP numerous times...
I will get about $120 for the devices sold. Can you recommend me an asus router at this price that is worth buying and using as an Aimesh Node?

Go to the Asus website and checkout what they have on sale. For a little bit more you can get another AX router.
Thanks for all the tips, the important thing is that I managed to achieve my goal.

I know that Asus wrote a warning about this in the GUI, because thanks to this I was able to solve the problem.

I will write again that I did not disable DHCP in the RT-AX86U PRO once during the Aimesh installation,
so I did not have the opportunity to read this message before!

The RT-AX86U PRO router was fully configured and I did not use DHCP in the router.

Only now I have enabled the dhcp server in the RT-AX86U PRO router in the range of one IP address for the Aimesh node.

As for replacing RT-AC68U as Aimesh Node, I'm considering: RT-AX55 or RT-AX58U
However, I don't know if it's a good choice?

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!