[Solved] AC5300 completely ghosting me after firmware update - bricked?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Harnor88

New Around Here
My AC5300 has been a delicate flower ever since it "lost" one of its 5 GHz bands some years back. I accepted it and thought let's not mess with it (after reading about similar experiences online).

It's been doing its job well enough since then, as long as I didn't try to log into it.

Today I thought well I really should update my firmware, and let's just say it didn't go down well.

Powering it off and back on after the update, the router is now ghosting me completely. Not detectable through ethernet cable, no Wi-Fi networks showing, even with LEDs showing that both 2.4 GHz and 5 GHz are active.

So, of course I held down the reset button for 15 seconds. Nothing. Held it down for 30 seconds. Nothing.
Turned it off completely, unplugged power and all ethernet cables, waited 5 minutes, rebooted - nothing.
I've tried restarting and power cycling multiple times.

Power signal sometimes flashes after I try to reset, but it's mostly stable (white). As I said, 2.4 & 5 GHz LEDs are stable.
Internet LED stays on for a minute then turns off for a minute, then back on etc.

What can I do here? Is it bricked?
How am I supposed to fix something I can't even interact with?

*pulling out what's left of my hair*
 

AndreiV

Very Senior Member
ASUS RECOVERY TOOL

You'll need to download firmware to repair with, try an older revision for your router.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top