vpnmgr - Manage and update VPN Client configurations for NordVPN and PIA

Which VPN provider do you use?


  • Total voters
    91

Jack Yaz

Part of the Furniture
Any PIA users willing to test v2? This is a one-way upgrade, to go back to stable will need a reinstall. Post if interested!
 

DHLarson

Occasional Visitor
very weird. Can you upload and pm a copy of your syslog so i can take a look at anything that might have tripped it? next time it happens, can you run:
Code:
ls -la /tmp/menuTree.js
so we can check when it was last modified please?
OK - so menu not present today. Will send syslog via PM as discussed. Here's the command log:

[email protected]:/tmp/home/root# ls -la /tmp/menuTree.js
ls: /tmp/menuTree.js: No such file or directory
[email protected]:/tmp/home/root# nvpnmgr startup
nvpnmgr: Sleeping for 30s before running startup routine
nvpnmgr: Mounting nvpnmgr WebUI page as user1.asp
[email protected]:/tmp/home/root# ls -la /tmp/menuTree.js
-rw-rw-r-- 1 xxxxx root 21594 Jul 16 12:13 /tmp/menuTree.js

Menu tab now present.
 

Kingp1n

Very Senior Member
Any PIA users willing to test v2? This is a one-way upgrade, to go back to stable will need a reinstall. Post if interested!
I use PIA ...let me know what you would like for me to test.
 

Macros999

New Around Here
Hi Jack Yaz

Yust have to congratulate you on an awesome set of tools. Discovered nvpnmgr, Yazfi and the others 2 days ago, absolutely crazy useful!

Everything working 100% with absolutely no issues.
 

abracadabra11

Occasional Visitor
Recently installed NordVPN Manager. Really neat tool, but I can't seem to get the VPN to start. When I select On for Service State under the VPN Client tab, the page refreshes but cycles back to Off. System Log shows the following error:
ovpn-client1[7407]: Options error: You must define CA file (--ca) or CA path (--capath)

Do I need to configure something other than the user/pw to connect?

Running Merlin 384.18 on RTAC68U with Skynet, Diversion, JRQoS, and NordVPNManager.

Thanks!
 

Jack Yaz

Part of the Furniture
Recently installed NordVPN Manager. Really neat tool, but I can't seem to get the VPN to start. When I select On for Service State under the VPN Client tab, the page refreshes but cycles back to Off. System Log shows the following error:
ovpn-client1[7407]: Options error: You must define CA file (--ca) or CA path (--capath)

Do I need to configure something other than the user/pw to connect?

Running Merlin 384.18 on RTAC68U with Skynet, Diversion, JRQoS, and NordVPNManager.

Thanks!
Did you manually change any of the settings for the vpn client? Can you send a screenshot (blank out username)
 

abracadabra11

Occasional Visitor
Ok, it sounds like the certificate might not have been extracted. What do you see for:
Code:
ls -la /jffs/openvpn
drwx------ 2 username root 0 Jul 18 09:51 .
drwxr-xr-x 11 username root 0 Jul 18 11:32

switched router admin name with 'username' for post
 

Jack Yaz

Part of the Furniture
drwx------ 2 username root 0 Jul 18 09:51 .
drwxr-xr-x 11 username root 0 Jul 18 11:32

switched router admin name with 'username' for post
That's weird, the ca and key files aren't there

Which server are you using? If you "search" for a new one do the files get populated?
 

abracadabra11

Occasional Visitor
That's weird, the ca and key files aren't there

Which server are you using? If you "search" for a new one do the files get populated?
I was using the Los Angeles server for two VPNs managed by NordVPNManager. I removed the second VPN and it connected now. Perhaps it was because two clients were configured for same geographical area?
 

Jack Yaz

Part of the Furniture
I was using the Los Angeles server for two VPNs managed by NordVPNManager. I removed the second VPN and it connected now. Perhaps it was because two clients were configured for same geographical area?
it shouldn't have errored in that way!
 

abracadabra11

Occasional Visitor
Are there known speed issues associated with using RTAC68U OpenVPN?
When I send my traffic through the NordVPN router connection, I'm getting around 15Mbps/10Mbps. When I send my traffic through the OpenVPN client on my computer, I'm getting around 136Mbps/10Mbps.

Ensured same servers were being used for both VPN connection and Speedtest.net download.
 

abracadabra11

Occasional Visitor
Are there known speed issues associated with using RTAC68U OpenVPN?
When I send my traffic through the NordVPN router connection, I'm getting around 15Mbps/10Mbps. When I send my traffic through the OpenVPN client on my computer, I'm getting around 136Mbps/10Mbps.

Ensured same servers were being used for both VPN connection and Speedtest.net download.
Found a separate thread covering this that notes that the problem appears to be a hardware limitation of the RTAC68U. Link below for anyone interested.

https://www.snbforums.com/threads/asus-rt-ac68u-nordvpn-speed.61512/
 

slidermike

Regular Contributor

Jack Yaz

Part of the Furniture
v2.0.0 is now available
Changelog:
Code:
NEW: Rename from nvpnmgr to vpnmgr as we intend to support various VPN providers
NEW: Add support for PIA VPNs (Private Internet Access)
While every effort has been made to test upgrading, I would be naive to assume I've caught everything. Please post here if you run into any problems!
 

NoobuserAdvanced

Occasional Visitor
2.png
Pic.2 This one i will have :cool:
1.png

Pic.1

Hello i just wondering why this setup not have this setup Pic.2
Today you have this setup Pic.1 i will have Pic.2 every time the router change VPN i have this setup Pic.1
Maybe i think wrong please help me with my answer
/NUA
 

Jack Yaz

Part of the Furniture
View attachment 24894Pic.2 This one i will have :cool:View attachment 24893
Pic.1

Hello i just wondering why this setup not have this setup Pic.2
Today you have this setup Pic.1 i will have Pic.2 every time the router change VPN i have this setup Pic.1
Maybe i think wrong please help me with my answer
/NUA
NordVPN and PIA don't support compression (at least, importing the vpn files sets it to None/Disabled)
 

NoobuserAdvanced

Occasional Visitor
NordVPN and PIA don't support compression (at least, importing the vpn files sets it to None/Disabled)
ok! so i must disable it? Thanks /Jack Yaz
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top