What's new

Zen xt12 rescue mode not working - help needed

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
zEN pro xt12 failed during firmware upgrade. I tried the firmware restoration utility : https://www.asus.com/support/FAQ/1030652/

I changed the ip address in TPC TCP/IP V4 to and other ip s such, with subnet to and used the upgrade utility with the firmware image but I keep getting message searching for ip address and then connecting to wireless device. The router is in rescure mode with white led on the top flashing

Have it bricked it. Can someone help anything I do try to recover.
Disable your PC's Wi-Fi adapter.

Run a continuous ping from your PC to the router to confirm the Ethernet cable connection. So on Windows that would be:
ping -t


  • ping.JPG
    45 KB · Views: 17
first theis recovery tool searches for ip address and then wireless ip address and then says router not in recovery mode. bUt it is in recovery mode. a white lite constantly flashing


  • utilitty.JPG
    88.2 KB · Views: 16
Leave the continuous ping running, try WPS hard reset, Rescue Mode after and when you see a ping response try the default LAN IP again. What is suggested above is getting to mini CFE Web server. Some browsers restrict http access, try different one. Leave the recovery tool alone for now.
tried the above. Default ip adrress of or provide page not dispalayed , no connection ( on opera, ie explorer, chrome and firefox). Pinging with no probs
Be sure you're using 'incognito' mode (or equivalent, for the browser you're using).

Reboot your computer. Clear the cache of each browser before you try connecting. Be sure you close the windows fully, and are not just minimizing them.

Hope you are not really using ie explorer. If you are, try Edge, instead.
Possibly . As auto firmware update was on.

When the router starts it displays mostly green lights good few times and one or two times white red and keeps having green lights. It does not coonect via lan connection to another router or to the PC. No lan port when on. Butlan port blinking in rescue mode occurs and ping goes through.

I tried sevral times the above. Nothing else is openeing up in the browsers ( in incognito mode). Does it look like irreperable?. would be the routers IP so try using with default gateway

View attachment 54367
Still cannot open the webpage with router default address. I can ping But not

Neither the recovery tool is able to search the IP address

Are there any other recovery tools that I could give a try
Default on XT12 is

View attachment 54371
That is the default LAN address when the router is working normally. I don't know about the XT12 but with other Asus routers that have as the default LAN address their recovery IP is still the old address. This seems to be borne out by the OP being able to ping but not
But what was he setting to get this response?
When getting a response from I assume he was using which he mentioned first or which is stated in the FAQ he was following.

I wonder as he was also getting a response at
In that case you had asked him to set his PC to be so he was pinging himself. But still no response from
I've not read full post just parts so here as just some handy little cmd lines to help locate a missing device IP if all else fails

Passive, probing
> arp -a
see what IP's is broadcasting on your iface net..
next run
> netstat -a
> netstat -aof | findstr :8443 <== or whatever you may have changed the GUI default access port number to..
Search by default port number maybe of help to spot what IP your router maybe sitting on.

> ipconfig /flushdns
$ ipconfig /release & /renew

It could be a previous cached session page in browser so go back to your last know IP reload that page up again then "ctrl + F5" to clear out any cached page or go incognito as above.. Try for http://<ip>:80 | http:<ip>:8443 | https://<ip>:8443

Also ipv6 https://[ffee:abcd:ffee::1]:8443 <== If you have ipv6 enabled this maybe a way back in but you need to look for the ipv6 addy for that device 1st.

also can search by local domain i forget what they are now.. like https://asusrouter.com:8443 is one I think...


Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!