What's new

ASUSWRT 386 RC2 public beta with full functions AiMesh 2.0

LimJK

Senior Member
Did you try that the clients on the guest network get an IP address? Because for the normal clients I don't have any problems.
Ginny,
From my limited understanding, WiFi Guest Client across all AiMesh Node that need to be isolated, are certainly not the same as normal clients in the Primary Network. May be your managed switch filters important information needed for ASUS to support WiFi Guest across AiMesh nodes; which is a new feature in AiMesh 2.0.
 

LimJK

Senior Member
Thank you LimJK for your quick reply. :)
So I think I need to go over an unmanaged switch. However I have multicast for IP-TV and therefore I enabled IGMP snooping. The other settings are on default e.g. disabled. I still hope there is a config possible that the port where the AiMesh node is connected to works. I don't know if some VLAN's must be defined, but I'm not so familiar with that.
Ginny,
May be you should consider to use the feedback GUI with all logs enable and point them to the discussion here. I have other issue myself and I sent feed back with logs, they were very helpful (for my case :) ).
PS: It took about 6 hours for the whole process for the logs to be collected and sent ... I did it just before I go to bed
 

Neil62

Senior Member
There is defiantly more instability with the 5GHZ band from nodes connecting to main (wireless), I am using a fixed channel, 157, a bandwidth of 80MHZ fixed and a wireless mode of N/AC mixed. The RX/TX rates are bouncing all over the place, where I have noticed the 2GHZ band remains allot more stable. The current 384 release has a lot more stable 5GHZ band connection from nodes to main. I have no disconnection of nodes though in this current RC release. The 5GHZ signal strength, seems to deteriorate over time, i.e., the longer the Main router and nodes are up with this current RC release, which results in slower WIFI speeds.

@ASUSWRT_2020 in the wireless log, can you please use/include, an AUTO REFRESH option, as per Merlins firmware, rather than having to 'click' on the refresh button continuously, that’s a ridiculous option with the current RC firmware and current stable release.

Additional, can you aslo include a "LOG LEVEL SETTING", in the "General Log" again as per Merlins firmware?

Time for change and some advancement in the standard ASUS firmware...please

As a suggestion of course.
 
Last edited:

LimJK

Senior Member
There is defiantly more instability with the 5GHZ band from nodes connecting to main (wireless), I am using a fixed channel, 157, a bandwidth of 80MHZ fixed and a wireless mode of N/AC mixed. The RX/TX rates are all over the place, where I have noticed the 2GHZ band remains allot more stable. The current 384 release has a lot more stable 5GHZ band connection from nodes to main. I have no disconnection of nodes though in this current RC release. The 5GHZ signal strength seems to deteriorate the longer the Main router and nodes are up.


@ASUSWRT_2020 in the wireless log, can you please use/include, an AUTO REFRESH option, as per Merlins firmware, rather than having to click on the refresh button continuously, that’s ridiculous.
Neil62,
If there is any comfort, Tonight (about 5 hours later), when my family goes to sleep, I am going to unplug my backhaul Ethernet cable from both my AiMesh nodes to see what happen and report back here if I get the same problem. If there is problem I will send feedback and with all logs to Asus while all at home is asleep.
 

Neil62

Senior Member
Neil62,
If there is any comfort, Tonight (about 5 hours later), when my family goes to sleep, I am going to unplug my backhaul Ethernet cable from both my AiMesh nodes to see what happen and report back here if I get the same problem. If there is problem I will send feedback and with all logs to Asus while all at home is asleep.
Thank you..will be nteresting to see what you find out. Signal strength and speed just seems to drop off, the longer the AiMesh is up, using a Wireless backhaul. I might mention as well that ISP speed remains consistent. So I know the problem is not related to ISP provider, I have confirmed that using a ethernet connection directly into the ISP router.
 
Last edited:

LimJK

Senior Member
Thank you..will be nteresting to see what you find out. Signal strength and speed just seems to drop off, the longer the AiMesh is up, using a Wireless backhaul. I might mention as well that ISP speed remains consistent. So I know the problem is not related to ISP provider, I have confirmed that using a ethernet connection directly into the ISP router.
Neil62,

I unplugged the Backhaul Ethernet Cable from both my AiMesh Nodes.

I observed that backhaul switched to “Wireless” immediately and I let it run for about 2 hours
  • AiMesh Network is Stable shown in AiMesh 2.0 UI (Based on connection icon: Wireless connection with great signal quality)
  • I use WiFi Explorer on my Mac where the spectrum shows both 2.4GHz (Ch 1, 20MHz) and 5.0GHz (Ch 36, 80MHz), signal strength, bandwidth all look normal on AiMesh Router and both AiMesh Nodes
Background of my physical layout:

AiMesh Router RT-AX88U (Living Room)
—> LnkSysLGS108 Gigabit Switch
—> AiMesh Node RT-AC86U (Study Room: Across 1 Brick wall)
—> AiMesh Node RT-AC86U (Master Bedroom: Across 3 Brick/Concrete walls)

Wireless Backhaul signal strength: This information can only be found in the Wireless log; for 2.4GHz Band and 5.0GHz Band (Noticed signal strength is significantly weaker in the Master Bedroom that is furthest away)

Screenshot 2020-09-14 at 21.51.10.png


Screenshot 2020-09-14 at 21.51.33.png


Speed
  • My regular speed with Wired Backhaul connection with my MacBookPro over Ethernet is about 950 mbps for both download and upload
  • For Wireless Backhaul experiment, with my MacBookPro over Wireless AC connected to (I checked BSSID)
⁃ AiMesh Router: about 400 mbps​
⁃ AiMesh Node (Study Room): about 100 mbps​
⁃ AiMesh Node (Master Bedroom): about 25 mbps​

PS:
  • I left all NVRAM values to Firmware default values, especially WiFi related NVRAM settings, I must admit that I do not know enough.
  • Year of Manufacture
⁃ My RT-AX88U -> 2019​
⁃ Both RT-AC86U -> 2020​

Sorry, it seems to be working in my environment, I have to plug back the cable to enjoy my full speed.
 
Last edited:

Everbrave

New Around Here
Neil62,

I unplugged the Backhaul Ethernet Cable from both my AiMesh Nodes.

I observed that backhaul switched to “Wireless” immediately and I let it run for about 2 hours
  • AiMesh Network is Stable shown in AiMesh 2.0 UI (Based on connection icon: Wireless connection with great signal quality)
  • I use WiFi Explorer on my Mac where it shows both 2.4GHz and 5.0GHz spectrum, signal strength, bandwidth all look normal on AiMesh Router and both AiMesh Nodes
Background of my physical layout:

AiMesh Router RT-AX88U (Living Room)
—> LnkSysLGS108 Gigabit Switch
—> AiMesh Node RT-AC86U (Study Room: Across 1 Brick wall)
—> AiMesh Node RT-AC86U (Master Bedroom: Across 3 Brick/Concrete walls)

Wireless Backhaul signal strength: This information can only be found in the Wireless log; for 2.4GHz Band and 5.0GHz Band (Noticed signal strength is significantly weaker in the Master Bedroom that is furthest away)

View attachment 26210

View attachment 26211

Speed
  • My regular speed with Wired Backhaul connection with my MacBookPro over Ethernet is about 950 mbps for both download and upload
  • For Wireless Backhaul experiment, with my MacBookPro over Wireless AC connected to (I checked BSSID)
⁃ AiMesh Router: about 400 mbps​
⁃ AiMesh Node (Study Room): about 100 mbps​
⁃ AiMesh Node (Master Bedroom): about 25 mbps​

PS:
  • I left all NVRAM values to Firmware default values, especially WiFi related NVRAM settings, I must admit that I do not know enough.
  • Year of Manufacture
⁃ My RT-AX88U -> 2019​
⁃ Both RT-AC86U -> 2020​

Sorry, it seems to be working in my environment, I have to plug back the cable to enjoy my full speed.
What was the PHY rate with wireless Backhaul?
thanks
 

LimJK

Senior Member
What was the PHY rate with wireless Backhaul?
thanks
Everbrave,

The screenshots of the Wireless Log shows all the details of the Wireless Backhaul connection for both 2.4GHz and 5.0GHz band. I blank off my MacAddress of my AiMesh Nodes but I annotated it.
Speed that I showed, I thought should give us some indication of the throughput.

Sorry, I do not understand your question ... if you can give me a screen shot of what you are looking for, from which screen, that would help me understand your question :)
 

Everbrave

New Around Here
Everbrave,

The screenshots of the Wireless Log shows all the details of the Wireless Backhaul connection for both 2.4GHz and 5.0GHz band. I blank off my MacAddress of my AiMesh Nodes but I annotated it.
Speed that I showed, I thought should give us some indication of the throughput.

Sorry, I do not understand your question ... if you can give me a screen shot of what you are looking for, from which screen, that would help me understand your question :)
Now I see them, sorry! The Tx and Rx rates are very low; I have 1441.2 Mbps for both, increase some time but never below that!
 

prosperot

Occasional Visitor
Lots of reboots on the 5 version of RC2 on my AX88U (using an AC68U as aiMesh node). Version 4 was much more stable. Log is showing no reason for the reboot. It 'just' happens. And it happens at least 5 times per day (if not more that I am unaware of).

Log example of a reboot today at 19:06:03
Code:
Sep 14 19:06:01 kernel: wfd_unregisterdevice Successfully unregistered ifidx 1 wfd_idx 1
Sep 14 19:06:01 kernel: ^[[0;33;41m[ERROR vlan] vlanIoctl ,652: Failed to delete VLAN device wds1.0.1.501^[[0m
Sep 14 19:06:01 kernel: ^[[0;33;41m[ERROR vlan] vlanIoctl ,652: Failed to delete VLAN device wds1.0.1.0^[[0m
Sep 14 19:06:03 wlceventd: wlceventd_proc_event(486): wds0.0.1: Disassoc AC:9E:17:80:C4:D9, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Sep 14 19:06:03 wlceventd: wlceventd_proc_event(486): eth6: Disassoc AC:9E:17:80:C4:D9, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Sep 14 19:06:03 kernel: wfd_unregisterdevice Successfully unregistered ifidx 2 wfd_idx 0
Sep 14 19:06:03 kernel: ^[[0;33;41m[ERROR vlan] vlanIoctl ,652: Failed to delete VLAN device wds0.0.1.501^[[0m
Sep 14 19:06:03 kernel: ^[[0;33;41m[ERROR vlan] vlanIoctl ,652: Failed to delete VLAN device wds0.0.1.0^[[0m
Sep 14 19:06:03 wlceventd: wlceventd_proc_event(505): eth7: Auth AC:9E:17:80:C4:DC, status: Successful (0)
Sep 14 19:06:03 wlceventd: wlceventd_proc_event(534): eth7: Assoc AC:9E:17:80:C4:DC, status: Successful (0)
Sep 14 19:06:03 kernel: wfd_registerdevice Successfully registered dev wds1.0.1 ifidx 1 wfd_idx 1
Sep 14 19:06:03 kernel: Register interface [wds1.0.1]  MAC: 24:4b:fe:0b:aa:4c
Sep 14 19:06:03 kernel: netdev path : wds1.0.1.0 -> wds1.0.1
Sep 14 19:06:03 kernel: BCMVLAN : wds1.0.1 mode was set to RG
Sep 14 19:06:03 kernel: netdev path : wds1.0.1.501 -> wds1.0.1
Sep 14 19:06:03 kernel: BCMVLAN : wds1.0.1 mode was set to RG
May  5 07:05:07 kernel: klogd started: BusyBox v1.24.1 (2020-09-11 01:30:58 CST)
May  5 07:05:07 kernel: Linux version 4.1.51 ([email protected]) (gcc version 5.5.0 (Buildroot 2017.11.1) ) #4 SMP PREEMPT Fri Sep 11 02:42:45 CST 2020
May  5 07:05:07 kernel: CPU: AArch64 Processor [420f1000] revision 0
May  5 07:05:07 kernel: Kernel command line: coherent_pool=4M cpuidle_sysfs_switch pci=pcie_bus_safe rootwait
May  5 07:05:07 kernel: Virtual kernel memory layout:
May  5 07:05:07 kernel:     vmalloc : 0xffffff8000000000 - 0xffffffbdffff0000   (   247 GB)
May  5 07:05:07 kernel:     vmemmap : 0xffffffbe00000000 - 0xffffffbfc0000000   (     7 GB maximum)
May  5 07:05:07 kernel:               0xffffffbe00000000 - 0xffffffbe00e00000   (    14 MB actual)
May  5 07:05:07 kernel:     fixed   : 0xffffffbffabfd000 - 0xffffffbffac00000   (    12 KB)
May  5 07:05:07 kernel:     PCI I/O : 0xffffffbffae00000 - 0xffffffbffbe00000   (    16 MB)
May  5 07:05:07 kernel:     modules : 0xffffffbffc000000 - 0xffffffc000000000   (    64 MB)
May  5 07:05:07 kernel:     memory  : 0xffffffc000000000 - 0xffffffc040000000   (  1024 MB)
May  5 07:05:07 kernel:       .init : 0xffffffc0006b6000 - 0xffffffc0006ee000   (   224 KB)
May  5 07:05:07 kernel:       .text : 0xffffffc000080000 - 0xffffffc0006b51f4   (  6357 KB)
May  5 07:05:07 kernel:       .data : 0xffffffc0006ef000 - 0xffffffc0007b9400   (   809 KB)
May  5 07:05:07 kernel: init_timers: timer_function_timeout virt addr 0xffffffc000708e48
 

livefeed

Regular Contributor
Thank you for mentioning a managed switch - as I posted before I have two nodes that will not upgrade past 9177 and work they are hard wired. The two that will not updated are connected to the switch I just can’t figure out what needs to be switched on in the config for the switch to add these nodes to the AiMesh.
 

banger

Regular Contributor
Is it normal that the clients with fixed IP address doesn't show up on the aiMesh client list?
I would expect them to appear since they are connected to the mesh.
Some do some dont. I have two DSL-N55U connected to AC68U by ethernet both static IP and they keep disappearing and re-appearing in AIMesh client list.
 

ginny

Occasional Visitor
Ginny,
From my limited understanding, WiFi Guest Client across all AiMesh Node that need to be isolated, are certainly not the same as normal clients in the Primary Network. May be your managed switch filters important information needed for ASUS to support WiFi Guest across AiMesh nodes; which is a new feature in AiMesh 2.0.
Hi LimJK
I made another test over a Netgear GS105PE switch where I had only IGMP snooping enabled and the other settings on the factory default. Everything worked as expected, so guest clients got an IP Address and where isolated from my Intranet.

However I need more than 5 Ports in the living room with all multimedia devices attached. Therefore i made an easy solution by installing another LAN cable from the LAN Port of the router exclusively to the node.

Maybe somebody will find out what must be configured within a managed router that we can have
Ethernet Backhaul Mode enabled under the AiMesh SystemSettings Tab. When I enabled this, the node formerly over the switch became isolated.

Now everything works as expected and all my system work in Tri-Band mode and serves WiFi 6.

Thank you all for your great help
 

Neil62

Senior Member
Neil62,

I unplugged the Backhaul Ethernet Cable from both my AiMesh Nodes.

I observed that backhaul switched to “Wireless” immediately and I let it run for about 2 hours
  • AiMesh Network is Stable shown in AiMesh 2.0 UI (Based on connection icon: Wireless connection with great signal quality)
  • I use WiFi Explorer on my Mac where the spectrum shows both 2.4GHz (Ch 1, 20MHz) and 5.0GHz (Ch 36, 80MHz), signal strength, bandwidth all look normal on AiMesh Router and both AiMesh Nodes
Background of my physical layout:

AiMesh Router RT-AX88U (Living Room)
—> LnkSysLGS108 Gigabit Switch
—> AiMesh Node RT-AC86U (Study Room: Across 1 Brick wall)
—> AiMesh Node RT-AC86U (Master Bedroom: Across 3 Brick/Concrete walls)

Wireless Backhaul signal strength: This information can only be found in the Wireless log; for 2.4GHz Band and 5.0GHz Band (Noticed signal strength is significantly weaker in the Master Bedroom that is furthest away)

View attachment 26210

View attachment 26211

Speed
  • My regular speed with Wired Backhaul connection with my MacBookPro over Ethernet is about 950 mbps for both download and upload
  • For Wireless Backhaul experiment, with my MacBookPro over Wireless AC connected to (I checked BSSID)
⁃ AiMesh Router: about 400 mbps​
⁃ AiMesh Node (Study Room): about 100 mbps​
⁃ AiMesh Node (Master Bedroom): about 25 mbps​

PS:
  • I left all NVRAM values to Firmware default values, especially WiFi related NVRAM settings, I must admit that I do not know enough.
  • Year of Manufacture
⁃ My RT-AX88U -> 2019​
⁃ Both RT-AC86U -> 2020​

Sorry, it seems to be working in my environment, I have to plug back the cable to enjoy my full speed.
Thank you very much, for taking the time to do that...
 

Neil62

Senior Member
@ASUSWRT_2020
There is also still a problem with ALL the transmit and receive rates going to 0 under "Network" option, from within the Aimesh menu, it includes nodes as well.

The only option I have found to fix this, is to reboot the main router and nodes. By using the new "System Reboot" option under "System Settings", that reboots the nodes in conjunction with the main router. Which worked without a hitch today.

1600142478183.png
 
Last edited:

LimJK

Senior Member
@ASUSWRT_2020
There is also still a problem with ALL the transmit and receive rates going to 0 under "Network" option, from within the Aimesh menu, it includes nodes as well.

The only option I have found to fix this, is to reboot the main router and nodes.

View attachment 26229
Neil62,
I have the same for both my RT-AC86U AiMesh Node(s) where all the transmit and Receive Rate all shows "0"
  • Backhaul
    • Ethernet
  • Fronthaul
    • Ethernet
    • Wireless - 2.4GHz
    • Wireless - 5.0GHz
I will send Feedback with Logs to Asus and pointing them to this post. Hopefully, it can help them catch and resolve this bug that exists for a while from the first RC2.
 

LimJK

Senior Member
Change logs:
1. Add important patches for AiMesh backhaul and there are two FAQs for ethernet backhaul
What is Ethernet Backhaul Mode/connection priority in AiMesh system and how to set up in different scenarios?
Channer,

I think there is a FAQ Bug in the first link of the first post of this thread, under Change log item (1) , in the second "Where to find this feature?"
Code:
Where to find this feature?
ASUSWRT GUI(Web) -> AiMesh System Settings -> AiMesh RE management - Connection Priority
Should be
Code:
ASUSWRT GUI(Web) -> Topology -> Select the AiMesh Node -> AiMesh Management (Tab) -> Connection Priority
 

Neil62

Senior Member
Neil62,
I have the same for both my RT-AC86U AiMesh Node(s) where all the transmit and Receive Rate all shows "0"
  • Backhaul
    • Ethernet
  • Fronthaul
    • Ethernet
    • Wireless - 2.4GHz
    • Wireless - 5.0GHz
I will send Feedback with Logs to Asus and pointing them to this post. Hopefully, it can help them catch and resolve this bug that exists for a while from the first RC2.
Thanks again, at least I am not only one with this problem....
 

jass

Regular Contributor
Have been running a AX88U testsetup for 31 days now. The ax88 on 386.39485 and the two AC66U AP's on latest stock. All wireless (both radios) on the ax88 is disabled, so the only wifi comes from the two AP's.

It's a very basic setup with aproximately 30 devices overall (wired and wireless). I use limiters to share the bandwith (192.168.0.*) equal to everyone. It seemed to work very well for a while, but now I'm experiencing up to the double of what I've set the limiters to be... Limiters set 20 mb down 10 up, and I'm seeing almost 40 down... Limiters have not been working as it should for a year+ now... Since this is a test setup it's been set to 20 mb down and 10 up on a 1000/1000 fiber line.

The GUI seems periodically sluggish. I'm not 100% sure but I also have a feeling that internet periodically pauses for a few seconds.

AiProtection seems to update signatures but still do not register any hits in the GUI. Also been the case for almost a year now...

Also I'm still seeing the cosmetic bug in traffic monitor where there is a misplaced "WAN" in chrome see pic. It also apply to Edge but not exactly the same place.

I would also come with a feature request. When you set up a box in plain AP mode, it would be nice and helpful to be able to deactivate the Lan ports. I'm servicing several "dorm houses" which is set up with AP's and wifi only. The problem arises when limiters and QoS has'nt been working as it should for quite a while know, and the students choose to connect directly to AP's with a cable and "steal" all available bandwith...

@ASUSWRT_2020 I really hope all of this old bugs soon will be fixed in the new coming 386 branch.

My apology in advance if these bugs already been reported earlier in this thread...
 

Attachments

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top