What's new

AX86U on 3004.388.4 doesn't let set Wi-Fi channel after AX92U on is added as an AiMesh node using ethernet backhaul

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello everyone! After buying a new Wi-Fi 6 enabled cellphone, I discovered that it won't connect to the primary Wi-Fi 6 5GHz network (AX86U running on Merlin 3004.388.4 firmware) due to it using Channel 153. When I tried to manually set a different channel, there was just a blank menu with no options for this setting. I thought that it could be due to my going through various firmware updates without restoring factory settings, so I did that. The correct menu settings uppeared, but only before I added my second router (AX92U running on ASUS firmware) as an AiMesh node using ethernet backhaul, that's when the wrong functioning returned.

Not only it doesn't preserve the manually set channel that had been selected before the adding of the node, but it reverts back to automatic selection.

Please have a look at the screenshots with and without the AX92U as an AiMesh node.


  • Screenshot_20230923_095704_Chrome.jpg
    31.2 KB · Views: 54
  • Screenshot_20230923_095538_Chrome.jpg
    38.2 KB · Views: 60
Welcome to the forums @hard1k.

Those screenshots are too small to read.

What you're seeing are the limitations of using different hardware with different capabilities, together, via AiMesh.
Hello @L&LD, thank you for your reply, it was actually my guess too, just wanted to confirm that there is nothing I can do about it without changing hardware or discarding the AiMesh at all.
Please find attached better screenshots.


  • No node.png
    No node.png
    194.6 KB · Views: 47
  • With node.png
    With node.png
    111 KB · Views: 49
Something is not right. I recommend you go back to Asus factory firmware. Hard reset and reconfigure the AX86U after switching firmware. Also, use the Dual Band SmartConnect, set the 2.4 GHz to 20 MHz on auto channel and the 5 GHz to 20,40,80,160 MHz auto channel with DFS enabled. Then add the AiMesh node. If you do not need the 160 MHz just use 80 MHz but leave the rest of the settings alone.

If it works then go back to Merlin firmware and manually use the same settings after a factory reset.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!