Diversion is not working with asuswrt-rtn18u (DNS SETTINGS)

rooli

New Around Here
Hello guys.
I have an RT-N18U router with the latest 386.3 firmware.
With previous versions adblocking was working fine, but after a couple of weeks the router always died, I had to reflash.
This time the firmware is working fine, it is only a couple of days old and I can't get Diversion working.
I have installed everything, in amtm it seems everything is ok, but I have no adblocking, interestingly youtube adblocking is working just fine.

Maybe it can be some DNS settings I'm missing.
In LAN settings the DNS Filter is on and set to router / Custom DNS settings are empty.
In WAN settings the WAN DNS Setting the first DNS address is set to my internal IP address 192.168.0.1 / the second address is empty. ( Automatically connect to DHS server is OFF )
As I'm using static IPs for my devices I have set the DNS address on my devices the 192.168.0.1.
I have no idea what is wrong and how to find the problem.
I have tried to just use empty fields in WAN DNS Settings, but nothing happened.

If you have any idea, then thank you very much in advance.
 

ColinTaylor

Part of the Furniture
RMerlin doesn't make firmware for the RT-N18U. You'll probably have to seek support from whoever created that firmware.

In WAN settings the WAN DNS Setting the first DNS address is set to my internal IP address 192.168.0.1 / the second address is empty. ( Automatically connect to DHS server is OFF )
This is wrong. WAN DNS should be set to automatic or an external server like 8.8.8.8.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top