• ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dave14305

Part of the Furniture
I was wondering if Diversion has some built-in rules that make it only accept requests from its own subnet? Or maybe MerlinWRT still has some firewall rules active even though I disabled the Firewall in the GUI?

I'd be happy for any hints where to look or what to check.
Merlin configures dnsmasq to only listen on the LAN interface br0, as well as any pptp interface. If you want what is technically the WAN port to listen for DNS traffic, you need to add a interface=eth0 or interface=vlan2 to /jffs/configs/dnsmasq.conf.add, depending on your WAN interface name. But then you might also need a no-dhcp-interface=eth0 (or vlan2) to avoid DHCP conflicts on the other subnet.

I’m not sure that’s a great idea overall, but that’s what you can test. It technically has nothing to do with Diversion, so you might get better advice from your own thread that the few remaining non-Diversion users will also see. ;)
 
Last edited:
  • Like
Reactions: a5m

Tom Dooley

New Around Here
Merlin configures dnsmasq to only listen on the LAN interface br0, as well as any pptp interface. If you want what is technically the WAN port to listen for DNS traffic, you need to add a interface=eth0 or interface=vlan2 to /jffs/configs/dnsmasq.conf, depending on your WAN interface name. But then you might also need a no-dhcp-interface=eth0 (or vlan2) to avoid DHCP conflicts on the other subnet.

Thank you very much! Your suggestion was spot on.

I added the file /jffs/configs/dnsmasq.conf.add with the following contents:

interface=eth0
no-dhcp-interface=eth0

I don't get any warnings from the 10.0.0.x Router concerning DHCP conflicts, so I think it's done. Thank you again.
 

Diamond67

Senior Member
My Entware usb flash drive died last night. :mad:

Any tips for getting Diversion (and Skynet, connMon, scMerlin, and uiDivStats) up and running in no time (two days...) as they used to be?

I have rather fresh set of Diversion backup (Key-files) in my mailbox. How do I use them in a proper way?
edit:
Code:
!  Found Diversion Standard local backup
     from Jun 04 2020 02:10:01 in /jffs/addons/diversion/

 1. Install from local backup in /jffs/addons/diversion/
 2. New installation

 Enter your selection [1-2 e=Exit] 1

Nice! :)

I just connected an old Kingston 16 GB to my router and I am going to format it with Format disk of amtm (fd) right now. I'll be back after reboot. :rolleyes:

edit: Why is the label of the usb flash drive limited to 11 characters when you use the Format disk of amtm? My previous label was called "ASUS_ENTWARE". That is 12 characters and I cannot use it now.

one more edit: Formatted the stick with my Puppy Linux, all 12 characters allowed.

Had to uninstall Skynet with
Code:
sh /jffs/scripts/firewall uninstall
and reinstall it.

All seems to work OK now. Case closed.
 
Last edited:

Sptz

Occasional Visitor
Has anyone found a way to unblock Disqus? I've whitelisted disqus.com and disquscdn.com and still no "disqus comment sections" load, Diversion also noted that these weren't present in blacklist.
 

bluzfanmr1

Senior Member
Has anyone found a way to unblock Disqus? I've whitelisted disqus.com and disquscdn.com and still no "disqus comment sections" load, Diversion also noted that these weren't present in blacklist.

I think this is what worked for me. I whitelisted:

Code:
realtime.services.disqus.com
 

Sonyrolfy

Regular Contributor
Couple of days ago i clicked YT block and its working great!! Sure once a while one slips through :) If you can make this work for Tubi and Pluto TV, it would be great, i really cant stand that commercial "safe drivers save 40 percent." anymore. Just kidding. Tnx!
 

Skillz

Occasional Visitor
Hi, just started using Diversion a couple of days ago and I noticed something when I was testing my Android phone. By design Diversion removes the DNS servers at the DHCP options page, but by doing so, Android sets the primary DNS to the router, but the secondary to google's DNS. DNS works in a Round-Robin way, so there's no guarantee that the router's DNS will be used. When I set the router's IP in the dns field of the dhcp options, Android does only set the router's ip for DNS. Any chance you can set the router's ip in both the dhcp dns fields instead of blanking them?
 

Asad Ali

Very Senior Member
Hi, just started using Diversion a couple of days ago and I noticed something when I was testing my Android phone. By design Diversion removes the DNS servers at the DHCP options page, but by doing so, Android sets the primary DNS to the router, but the secondary to google's DNS. DNS works in a Round-Robin way, so there's no guarantee that the router's DNS will be used. When I set the router's IP in the dns field of the dhcp options, Android does only set the router's ip for DNS. Any chance you can set the router's ip in both the dhcp dns fields instead of blanking them?

LAN->DNSFilter
Enable DNS-based Filtering
Set "Global Filter Mode" to Router
Apply
 
  • Like
Reactions: a5m

Skillz

Occasional Visitor
LAN->DNSFilter
Enable DNS-based Filtering
Set "Global Filter Mode" to Router
Apply
Tyvm :)

I guess that's another way to solve it, but not everyone will be on this forum or notice the wrong dns configuration on Android. Is there a technical reason for not setting the router ip in the dns fields?
 

Asad Ali

Very Senior Member
Tyvm :)

I guess that's another way to solve it, but not everyone will be on this forum or notice the wrong dns configuration on Android. Is there a technical reason for not setting the router ip in the dns fields?

I don't have an Android device so I'm not sure how its DNS implementation works but you can try this.

Under LAN->DHCP Server
Keep both the DNS fields blank but enable "Advertise router's IP in addition to user-specified DNS"

Also if you keep both the DNS fields blank it'll use the router's IP by default.
 
  • Like
Reactions: a5m

Skillz

Occasional Visitor
I don't have an Android device so I'm not sure how its DNS implementation works but you can try this.

Under LAN->DHCP Server
Keep both the DNS fields blank but enable "Advertise router's IP in addition to user-specified DNS"

Also if you keep both the DNS fields blank it'll use the router's IP by default.
- Advertise router's IP doesn't make a difference, second DNS is still google dns on Android (sigh...)
- And yeah I know, but there seems to be a difference by leaving the fields blank or setting the router ip, at least for Android.
When I fill in both fields on the router the google's dns is not set on the Phone (I know...it's stupid)
 

Asad Ali

Very Senior Member
- Advertise router's IP doesn't make a difference, second DNS is still google dns on Android (sigh...)
- And yeah I know, but there seems to be a difference by leaving the fields blank or setting the router ip, at least for Android.
When I fill in both fields the google's dns is not set on the Phone (I know...it's stupid)

Then probably your Android device is using hardcoded Google DNS (I know most Android devices prefer Google DNS by default) and I don't think it's something due to the router and the only thing you can do to bypass that hardcoded DNS is to use DNSFILTER.
 
  • Like
Reactions: a5m

Skillz

Occasional Visitor
Then probably your Android device is using hardcoded Google DNS (I know most Android devices prefer Google DNS by default) and I don't think it's something due to the router and the only thing you can do to bypass that hardcoded DNS is to use DNSFILTER.
You'd be right if google's dns would still show up with both dhcp dns fields filled (router's ip). In that case android does only set the router ip for dns. Dnsfilter works, but why not hard set router's ip in the dhcp dns? If there's a technical limitation I understand, but if not, it would solve the android dns issue for everyone?
 

Asad Ali

Very Senior Member
but why not hard set router's ip in the dhcp DNS? If there's a technical limitation I understand, but if not, it would solve the android dns issue for everyone?

As I said in my last reply the router already does that if you leave the DHCP DNS fields empty. Why your Android device is not respecting the settings is something I can't tell you without further troubleshooting.
 

L&LD

Part of the Furniture
You will need to reboot at least the device and maybe the router, to make sure the settings take effect too.
 

Skillz

Occasional Visitor
As I said in my last reply the router already does that if you leave the DHCP DNS fields empty. Why your Android device is not respecting the settings is something I can't tell you without further troubleshooting.
I get what you're saying, something seems wrong on Android and hopefully on my Android device alone. But if not, all other Android users will also have the 2nd dns server pointing to google, which will lead to adblocking not working (because of round-robin) and alot of confusion why ads are still appearing on android devices. Hopefully some other Android users can do a quick test?

1 check your current wifi dns settings on your android device, is the secondary dns google's dns?
2 fill out both dns fields (your router ip) in the router dhcp server tab, hit apply, wait until done
3 on your android device, disable wifi and enable wifi again, check your dns settings on your android device, you should now only see the router dns ip.
- now revert the changes you made in step 2, or restart Diversion.

edit: I'll perform some restarts on my devices, just to be sure.

update: same issue after restarting router/phone
 
Last edited:

dave14305

Part of the Furniture
I get what you're saying, something seems wrong on Android and hopefully on my Android device alone. But if not, all other Android users will also have the 2nd dns server pointing to google, which will lead to adblocking not working (because of round-robin) and alot of confusion why ads are still appearing on android devices. Hopefully some other Android users can do a quick test?

1 check your current wifi dns settings on your android device, is the secondary dns google's dns?
2 fill out both dns fields (your router ip) in the router dhcp server tab, hit apply, wait until done
3 on your android device, disable wifi and enable wifi again, check your dns settings on your android device, you should now only see the router dns ip.
- now revert the changes you made in step 2, or restart Diversion.

edit: I'll perform some restarts on my devices, just to be sure.
"Advertise router's IP in addition to user-specified DNS" only is activated if either of the DNS server fields are populated ("...in addition to user-specified DNS"). So DNSFilter is probably the best option.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top