What's new

Diversion's handling of prefixed domain definitions in hostsfiles (www., etc)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor

I was updating some hosts on a tablet for DNS66 and tried to make sure it works because it was giving me out weird "permission denied" errors for some reason (pointing to the filter lists as a local content URL that Mixplorer provides because I use a custom file specifically to block some hardcoded DNS requests of the tablet's model), perhaps too big of a hostsfile or CRLF mismatch, permissions actually can't be the problem becuase they're exactly the same as the old hosts file that's been working fine (checked in adb shell ls -al and Mixplorer), but now StevenBlack's unified standard one downloaded from github (it's below 5 MiB) doesn't make an error and it seemed to work but there's some bit that happened.

I randomly tried one host "clck.ru", entering into the old Firefox 88.0 Google's search bar, but it made a "www.clck.ru" request as seen on my router's Diversion, it shouldn't have reached diversion because DNS66 is suppose to block it.
But then, Diversion didn't block it either ... I can see there's no www.clck.ru defined in the blocklist, only clck.ru. I think some time back I think I saw an option to duplicate all hosts without www. or was it ipv6, but that didn't work out for me as it messed up the hostsfile a bit ( I have a complicated custom one in addition)

Couldn't Diversion just handle www and other prefixes automatically, or rather treat hosts that are provided with an asterix *.clck.ru without having to duplicate everything in the hostsfile it self?

Another bit I also wanted to ask separately for Asus routers and Asuswrt-Merlin's FW in general is that, blocking WAN access to a specific static lease LAN client does NOT block DNS requests from going out to WAN, because I got a reply back with an IP as seen in DNSMASQ logs, but the device still doesn't have any connectivity and as far as the device is concernet there's no WAN, what's up with that?!?!


Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!