Lower Network Speed on RT-AC86U with 386.1

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

shelleyevans

Regular Contributor
I have been running a Merlin-powered network for a few years-- my main router is RT-AC86U, with two nodes, RT-AC68U and RT-AC66U_B1. I have gigabit internet (Docsis 3.1 modem) to the house, rated at 1200/35, but typically running at about 900/50, when I measure at the modem. In spite of those numbers, I have learned the hard way that QoS is hugely important to me-- without it enabled my VOIP and business video meetings are terrible. I use adaptive QoS with manual bandwidth settings, usually most stable when I set it at 650/35.

When I first set up the network several years ago, I ran a router with two extenders (one ethernet and one moca-ethernet), but found that maintaining that network was difficult for me, especially when someone in my family complained about slow speeds or devices getting stuck on the wrong node. So, when Merlin's beta for Aimesh 2.0 dropped, I installed it. Thrilling!!! The mesh seemed, for the first time, to be rock-solid, and so easy to administer. I installed the release and found it to be even better-- nodes adding without difficulty, my IoT devices not getting lost on reboots. The GUI seems to work really well. But I noticed that my speeds have dropped somewhat dramatically, from the usual 900/50 to 600/50 on average, but sometimes even less.

Spent the weekend troubleshooting-- thanks to all who helped me get better at the clean install process, which I have now used half a dozen times! I am definitely getting 900/50 at the modem, but as soon as I add the RT-AC86U router, my download speeds drop to 600-700, and when I add the nodes, download speeds drop further, to 400-600. I am not running ANYTHING except Merlin firmware, and QoS. I tried going back to 384.19 and confirmed that the speeds don't drop, but really don't want to go back to a non-mesh network, which had other problems (IoT devices) that this software seems to solve. So after a long weekend of wrestling with this, I'm accepting the lower speeds and setting my bandwidth limits at 500/35, which seems to work pretty well-- we'll see over the next week or so. But the whole process has left me with some questions:

1. Why would this firmware cause such a big speed drop? I gather from much reading that NAT acceleration is automatically disabled when you enable QoS, but may not have been disabled in the earlier firmwares. Is that the explanation? And, if so, is there any way to turn it back on?

2. When I use the "Internet Speed" tab on QoS, what speed is actually getting measured? Directly from the router to the internet? or from the computer that is running the test?

3. Some folks seem to be saying that DSLreports/speedtest no longer "works", but it's the best way I have found to measure buffer bloat, which is what I care most about. Can I trust those numbers?

Thanks in advance.
 

NoKlu

New Around Here
First you will get a speed drop via the mesh, s you have part of the bandwidth being used as control and connection between the nodes. But what seems odd i your first drop from 900 to 600. Is that with wired clients?
The tab on the QOS should be measuring the speed from the router to wan to help with your setup. The NAT acceleration can be a big difference, but I can't speak directly to your situation as QOS isn't necessary for me, my voip is wired and problem free don't do a lot of zoom etc , and streaming 4k to my tv's etc around the house is great. So haven't found a need for QOS.
 

MarkyPancake

Senior Member
I'm surprised you need QoS with that down/up speed. For comparison, we've got a 200/20 service with an AC86U router and AC68U node, both on 384.19, and no issues for any devices streaming video and music, online multiplayer gaming, and two home working devices on video calls throughout day, all happening at the same time. I tried QoS for a while during the first lockdown in 2020 and our home network performed worse than without it.
 

L&LD

Part of the Furniture
1. The firmware is not causing speed drops. Your configuration or settings are.

2. When using both the Asus and spdMerlin speedtest (by @Jack Yaz) the router is the source. You are bypassing the computer used to access the router.

3. DSLReports doesn't work as it used to for me or my customers either. At least, not with a 1Gbps symmetrical up/down ISP Fibre connection.


Unless your network really needs all client devices to have the highest throughput, I don't see this as an issue. (I don't have 1Gbps service for the peak speeds, I have it for the 1ms to 5ms unloaded/loaded latency I can achieve).

Have you tried FlexQoS?


Is your network worse with QoS off after a fresh reset of all routers and using the recommended defaults?

Best Practice Update/Setup Router/AiMesh Node(s) 2021

M&M Config https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573

L&LD | SmallNetBuilder Forums
 

shelleyevans

Regular Contributor
@NoKlu, yes, that's with wired clients. And I was kind of startled by it myself. As I said, I first tested right at the modem, then at the router with no nodes attached, the most "vanilla" set up I could get. Went from 900DL connected directly to the modem to 600DL when I connected to the router. When I downgraded to 384.19, the speed at the router went back up again. So there is definitely something at play.

@MarkyPancake, I haven't tried running without QoS because on DSLReports my bufferbloat always gets much better when I have QoS enabled, and I (perhaps placebo effect) always connect that with better VOIP and video conference performance. In any case, the speeds dropped even before I enabled QoS...

@L&LD, ya, my router speed was worse even with QoS off, after the fresh reset, without any nodes attached. Next weekend, when I can kick my family off the network again, I will very carefully do your recommended defaults, and see if that makes a difference-- I kind of don't think it will, since when I downgraded to 384.19 the speeds went back up without me changing any of the default settings.

By "I don't see this an as issue" I take it you are saying, "don't worry, this isn't a problem..." which I was hoping somebody might say, especially somebody with your experience. It was a surprising drop, but if it doesn't indicate any other problems I don't really mind. Like you, I have the 1Gps service for low latency (although I don't get anywhere near 1ms to 5 ms!)-- when my VOIP was bad, after fixing everything else I could, including installing FreshJR script, I kept upping my bandwidth until it got more stable. In your experience, does QoS improve VOIP and video calls, even with high bandwidth, or is that just my imagination?

THANK you for clarifying about the Asus speedtest. Good to know how it works!
 

shelleyevans

Regular Contributor
Okay, some updates. First: :oops:. I discovered that my problem is not the firmware at all. No surprise to everyone here, I'm sure. After too many days troubleshooting, I started looking at my modem, which was incredibly "dirty" for lack of a better word-- power out of recommended specs, lots of uncorrectables. I cleaned up my outside cable connections, got the modem behaving more reliably, and presto, my speeds are also reliably in the range that they should be. I DID end up implementing QoS, because after running for a few days without it, I have had too many tiny freezes and almost drops in my Zoom calls. We'll see how it goes. But I do have one last question:

It appears that my router based speed test will NOT read download speeds higher than about 500 mbps. This seems to be true also of the fast.com speediest L&LD recommended in another thread. When I use the browser based Ookla speedtest, and the Xfinity speediest, they always report speeds in the range that I expect. Is this a known issue? I am not going to do any more investigating-- L&LD said something super helpful about speed tests in another thread-- basically, if ANY speed test gives you the speed that you are expecting, then you are getting that speed-- but I'm curious. I loved the idea that there was a built in speed test that measures speed from the router, and am a little disappointed not to be able to use it.
 

MarkyPancake

Senior Member
For the provider I'm with, someone has built a special speed checker that tests the speed between the provider and their kit, as you have to use their hub to connect to their service, however they do provide a modem mode option, so you can set it to be a modem only and then use your own router.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top