Merlin 388.1 GT-AX6000 NTP time won't synchronize?

Silarous

New Around Here
I completed the update today from 386.7_2 to 388.1 and had a issue that once I entered my Mullvad OpenVPN settings the VPN server refused to connect. Looking into it, for some reason my system time got set for Sat, May 5th 2018. I tried everything I could think of to fix the NTP settings and could not get it to update. I ended up doing a factory reset and spent the day entering all my settings in again from scratch. It was working great, system time was correct and I thought I was good to go until it happened again. My VPN disconnected and my system time is back to the same date. What can I do to get the system time corrected?

1670202813876.png


1670202850293.png


1670202890149.png
 

ColinTaylor

Part of the Furniture
It was working great, system time was correct and I thought I was good to go until it happened again. My VPN disconnected and my system time is back to the same date.
The system time doesn't just go back to 5th May spontaneously. Your router must have rebooted. Go back in the log to just prior to the start of the latest 5th May entries and try to determine why the router rebooted.


What can I do to get the system time corrected?
Relying solely on pool.ntp.org as a time source can cause problems like you're seeing. Add time.google.com as a secondary server.
 

Silarous

New Around Here
The system time doesn't just go back to 5th May spontaneously. Your router must have rebooted. Go back in the log to just prior to the start of the latest 5th May entries and try to determine why the router rebooted.



Relying solely on pool.ntp.org as a time source can cause problems like you're seeing. Add time.google.com as a secondary server.

I actually tried entering a 2nd NTP server before I did the factory reset. The problem remains no matter which NTP server I enter.

1670205011127.png



I attached the log from the time that it switched the date.
 

Attachments

  • log.txt
    20.1 KB · Views: 18

Silarous

New Around Here
It could be a DNS issue. Try entering an IP address for the secondary server: 216.239.35.0
Thank you. DNS is exactly what it was. Time corrected as soon as I entered that IP. I currently have two PiHole's setup for DNS, one of them for redundancy. Am I missing anything with the settings? Currently set the way they were on the last firmware. No other devices on the network appear to have DNS issues.

1670207368832.png


1670207412644.png


1670207434533.png
 

ColinTaylor

Part of the Furniture
I don't have that version of the firmware so I don't know what the default setting is for the WAN DNS. Make sure it's set to use your ISP's servers (this used to be called "Connect to DNS Server automatically").
 

Silarous

New Around Here
I don't have that version of the firmware so I don't know what the default setting is for the WAN DNS. Make sure it's set to use your ISP's servers (this used to be called "Connect to DNS Server automatically").
I enabled the WAN DNS to "Get the DNS IP from your ISP automatically" and put "time.google.com" as the secondary NTP server. Missing the WAN DNS setting may have been the issue. Seems to be working fine now. I greatly appreciate the help! If you have a bitcoin address, I'd love to buy you a drink for your time. Thanks again!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top