1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

no internet with OpenVPN server

Discussion in 'Asuswrt-Merlin' started by IronJeff, Jun 13, 2018.

  1. IronJeff

    IronJeff New Around Here

    Joined:
    Jun 13, 2018
    Messages:
    2
    I'm running 384.5 on an ASUS RT-AC87U, and I've setup an OpenVPN server. I setup some very basic ad-blocking rules for dnsmasq, and the OpenVPN server is set with "client will use VPN to access" "Internet Only".

    In the Advanced settings, I have "advertise DNS to clients" set to "yes". Whenever a client connects to the VPN server, it is not able to resolve any IP addresses.

    If I set "client will use VPN to access" "both", then DNS resolution works fine. It's a workaround, but I don't really want to enable outside access to my LAN, even through VPN, at this time.

    Any ideas on how to get this working?
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    27,410
    Location:
    Canada
    That's because your router is configured as your LAN's DNS server. If you set your clients to only have access to the Internet, they can't talk to your router's DNS server.
     
  4. IronJeff

    IronJeff New Around Here

    Joined:
    Jun 13, 2018
    Messages:
    2
    Oh, that makes perfect sense. But I had it configured as internet-only in older versions of merlin, and it worked fine. I guess that “bug” was fixed?
     
  5. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    27,410
    Location:
    Canada
    WAN-only and LAN-only were a bit quirky indeed in the past, so it's possible it was working tho it shouldn't have. Disable the DNS setting, and let your clients use their existing DNS servers instead.
     
    amplatfus likes this.
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!