Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Problem using router as master browser

Discussion in 'Asuswrt-Merlin' started by Rille_lkp, Jan 7, 2013.

  1. Rille_lkp

    Rille_lkp New Around Here

    Jan 7, 2013
    Just installed this firmware (23b) to get the option to use my router as master browser but i'm having some problems with my PCs running linux.
    From my Windows PCs i can browse WORKGROUP and i see all PCs (including linux machines) and access them.
    On my linux PCs i can however not browse WORKGROUP. If i try from my HTPCs running OpenELEC (linux+XBMC) i just get an "operation not permitted" while i can access SMB://HOSTNAME. I then tried installing Ubuntu and when i try to open WORKGROUP there it asks for username/password which i believe is what's causing the problem for my HTPCs.
    Any ideas why linux machines can't browse WORKGROUP and asks for password?

    Also tried browsing the network from my Android phone and tablet which are also unable to browse WORKGROUP.
    Last edited: Jan 7, 2013
  2. Rille_lkp

    Rille_lkp New Around Here

    Jan 7, 2013
    Checked some logs..

    var/log.samba is filled with:
    [2013/01/08 18:31:53, 0] nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351)
    Unable to find the Domain Master Browser name WORKGROUP<1b> for the workgroup WORKGROUP.
    Unable to sync browse lists in this workgroup.

    var/log/nmbd.log is filled with:
    [2013/01/07 01:57:00, 0] nmbd/nmbd_incomingdgrams.c:process_get_backup_list_request(702)
    process_get_backup_list_request: Invalid name type 0 - should be 0x1b or 0x1d.

    From Ubuntu running smbtree gives absolutly nothing.

    From Ubuntu running smbtree -d4 gives:
    [email protected]:/home/rickard# smbtree -d4
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
    Processing section "[global]"
    doing parameter workgroup = WORKGROUP
    doing parameter server string = %h server (Samba, Ubuntu)
    doing parameter dns proxy = no
    doing parameter log file = /var/log/samba/log.%m
    doing parameter max log size = 1000
    doing parameter syslog = 0
    doing parameter panic action = /usr/share/samba/panic-action %d
    doing parameter encrypt passwords = true
    doing parameter passdb backend = tdbsam
    doing parameter obey pam restrictions = yes
    doing parameter unix password sync = yes
    doing parameter passwd program = /usr/bin/passwd %u
    doing parameter passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    doing parameter pam password change = yes
    doing parameter map to guest = bad user
    doing parameter usershare allow guests = yes
    pm_process() returned Yes
    added interface eth0 ip=fe80::be5f:f4ff:fe74:f7c4%eth0 bcast=fe80::ffff:ffff:ffff:ffff%eth0 netmask=ffff:ffff:ffff:ffff::
    added interface eth0 ip= bcast= netmask=
    Enter root's password:
    Connecting to host=
    Connecting to at port 445
    Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
    failed tcon_X with NT_STATUS_ACCESS_DENIED
    nmb packet from header: id=27713 opcode=Query(0) response=Yes
    header: flags: bcast=No rec_avail=No rec_des=No trunc=No auth=Yes
    header: rcode=0 qdcount=0 ancount=1 nscount=0 arcount=0
    answers: nmb_name=*<00> rr_type=33 rr_class=1 ttl=0
    answers 0 char ...__MSBROWSE__. hex 0501025F5F4D5342524F5753455F5F02
    answers 10 char ...WORKGROUP hex 01E400574F524B47524F555020202020
    answers 20 char .d.WORKGROUP hex 20201D6400574F524B47524F55502020
    answers 30 char .d.WORKGROUP hex 202020201B6400574F524B47524F5550
    answers 40 char ...WORKGRO hex 2020202020201EE400574F524B47524F
    answers 50 char UP ........ hex 555020202020202000E4000000000000
    answers 60 char ................ hex 00000000000000000000000000000000
    answers 70 char ................ hex 00000000000000000000000000000000
    answers 80 char ......... hex 000000000000000000
  3. Rille_lkp

    Rille_lkp New Around Here

    Jan 7, 2013
    Found a solution to the problem, adding these lines to the clients smb.conf helps:
    lanman auth = yes
    client lanman auth = yes
    client plaintext auth = yes

    Is there anything i can change on the router so that adding these lines is not needed?

    To clarify, this is not a problem accessing computers in the workgroup. It's a problem accessing WORKGROUP.
  4. joegreat

    joegreat Very Senior Member

    Jan 9, 2013
    Vienna, Austria

    You can use "Custom config files" (details on Merlin's wiki page) to add things into the smb.conf of the router.

    With kind regards
    Joe :cool:

    PS.: Had the same problem and fixed it by changing the Windows Clients and the router smb.conf (is an XOR sulution, but just in case, both options are there). ;)
  5. YasharF

    YasharF Occasional Visitor

    May 17, 2014
    FYI, in case if you are having the "Unable to find the Domain Master Browser name xxxx<1b>" issue: it looks like that I have been able to fix it on my router by forcing Samba to be Master Browser through the UI. Look for the option under "USB Application - Network Place(Samba) Share / Cloud Disk"

Share This Page