YazFi Question about Yazfi and Ping

Chewie420

Regular Contributor
Hello I have setup a wireless subnet in Yazfi for my IoT devices. I gave the IP of 192.168.24.0/24. I have One Way and Two way set to No.

When I ping my August smart lock (192.168.24.8) from my PC (192.168.5.100) I get a reply. When I ping all of IPs on 192.168.24.0/24 I don't get a reply as I expected.

I am just wonder why I am able to ping that one device and what have done wrong that it is allowed to reply.
 

bennor

Very Senior Member
Do any of your other IoT devices on the YazFi guest wifi reply back with a ping when trying to ping each one individually by their IP address? Are you using VPN on/with YazFi? Are you trying to use YazFi on a AiMesh node? May want to post a screen shot of the YazFi settings to help others review your settings. Also the router, merlin firmware version and YazFi version info may also help others with their diagnosis.

On my IoT devices that are on YazFi I get a "Destination port unreachable." when trying to ping them from the main LAN space. In my case I have YazFi options; Two way to guest and One way to guest set to No, and Client isolation set to Yes.

Other troubleshooting steps to try.
If using YazFi Guest Wifi #1, disable that in YazFi, since Asus likes to use Guest #1 (on some routers) for AiMesh (if I remember right), move IoT devices to YazFi Guest #2 and or YazFi Guest #3.
Reboot the router, the IoT device(s) and test again.
Uninstall YazFi, reboot the router, reinstall YazFi.
Change the YazFi IP address ranges to different values/range and test again.
 

Chewie420

Regular Contributor
HI thanks so much for taking the time to reply. Sorry I should have given more information.

I am using an Asus RT-AX88U router with Merlin 386.3.2.
I have Yazfi set to use VPN for 2 of my Wireless networks but I also have 2 I want to go through my LAN.

I found it strange that I was only able to get a reply from that one device when trying to ping devices on the 192.168.24.0/24 from 192.168.5.100.

Turning Client Isolation on seems to block the ping now.

I guess I am confused as to what One and Two way traffic to guest is. I thought if I had those set to no no traffic would so from 192.168.5.100 to 192.168.23.8.

I thought if I had two way traffic set to no that would be the same as isolating the client as long as it doesn't isolate from all devices even the ones on the same subnet.

I did want the devices on the 192.168.24.0/24 subnet to be able to talk to each other but not other devices on my network.
 

bennor

Very Senior Member
The YazFi explanation of what One Way and Two Way do:
wl01_TWOWAYTOGUEST
Should LAN/Guest Network traffic have unrestricted access to each other? (true/false) Cannot be enabled if _ONEWAYTOGUEST is enabled

wl01_ONEWAYTOGUEST
Should LAN be able to initiate connections to Guest Network clients (but not the opposite)? (true/false) Cannot be enabled if _TWOWAYTOGUEST is enabled

When I disable (set to No) Client Isolation in YazFi I still get a "Destination port unreachable" when trying to ping my IoT devices on YazFi. Could be something specific to that one IoT device if no other devices respond to pings on the YazFi guest network(s).
 

Chewie420

Regular Contributor
Couple other issues I am noticing with Yazfi when I ssh into router and go into amtm and choose Yazfi and to display config file it only shows 2 of my 4 networks in the config file.

I was trying to edit some device names and I only seem to be able to do the ones connected to LAN and wireless not any of my devices connected to guest networks.
 

Chewie420

Regular Contributor
The YazFi explanation of what One Way and Two Way do:


When I disable (set to No) Client Isolation in YazFi I still get a "Destination port unreachable" when trying to ping my IoT devices on YazFi. Could be something specific to that one IoT device if no other devices respond to pings on the YazFi guest network(s).
Does client isolation mean that the clevice can't talk to other devices on the same guest network?
 

bennor

Very Senior Member
Couple other issues I am noticing with Yazfi when I ssh into router and go into amtm and choose Yazfi and to display config file it only shows 2 of my 4 networks in the config file.

I was trying to edit some device names and I only seem to be able to do the ones connected to LAN and wireless not any of my devices connected to guest networks.
May want to uninstall YazFi, then reinstall it as a troubleshooting step.

My YazFi config file via SSH YazFi interface and viewing/editing with Nano has two sets of entries, one for 2.4GHz networks and one for 5GHz networks with three sub entries for each (guest network 1, guest network 2, guest network 3). I scroll down (in Nano) to see them all.

Where are you editing the device names? If one has previously set static IP addresses for their IoT devices using the Merlin > LAN > DHCP Server > Manual Assignment section one may want to remove those entries. YazFi does not use the manual assigned IP address entries one creates through the Merlin interface DHCP Server page. If one wants to use manually assigned IP addresses for their YazFi clients, its possible but requires using SSH to create the entries. See the YazFi Wiki entry on setting up manual assignments: https://github.com/jackyaz/YazFi/wi...e-and-ARP-records#a-note-on-dhcp-reservations
 

bennor

Very Senior Member
Does client isolation mean that the clevice can't talk to other devices on the same guest network?
Yes, when it's set to Yes. From the YazFi Github page...

wl01_CLIENTISOLATION​

Should Guest Network radio prevent clients from talking to each other? (true/false)
Note: if you use the YazFi GUI page in the Merlin interface (Guest Network > YazFi) you can mouse over most of the text name and click it, you will get a short explanation of what the option does. When mousing over the mouse cursor should change to a "?" meaning you can click it to get some info. Example clicking on the Client Isolation text:

yazficlientisolationtext.jpg
 

Chewie420

Regular Contributor
Thanks seems a reinstall has resolved a lot of issues. I just wanted to know where Yazfi is pulling the host names from. I disabled Yazfi so my devices would show in Networking Map and renamed them to how I wanted. I then enable Yazfi but it keeps the old name and some are unknown. Was trying to locate what device that is but I have too many devices I think. It is making things confusing.
 

bennor

Very Senior Member
The Network Map won't show the YazFi clients. You can view the YazFi clients either through the System Log > Wireless Log tab. Or using the YazFi command line interface option #2. Or using SSH and issuing the command; "cat /var/lib/misc/dnsmasq.leases". Or on the Guest Network > YazFi tab in the "Connected Guests (click to expand/collapse)" section.

What I have, on Windows, is a "BAT" file used in conjunction with Putty. It issues the "cat /var/lib/misc/dnsmasq.leases" command so I can quickly view the connected IoT devices on YazFi in addition to the rest of the main LAN clients. Example of that bat file:
Code:
plink.exe -batch -ssh -l <loginname> -pw <password> <routerIPAddress> cat /var/lib/misc/dnsmasq.leases

PAUSE
As previously indicated YazFi does not use the manually assigned IP addresses and names that one creates using the DHCP Server manual assign section. As previously indicated one can manually assign IP address and names for YazFi clients using SSH. See here: https://github.com/jackyaz/YazFi/wi...e-and-ARP-records#a-note-on-dhcp-reservations Or see my post here: https://www.snbforums.com/threads/y...inc-ssid-vpn-client.45924/page-32#post-473403
 
Last edited:

Chewie420

Regular Contributor
The Network Map won't show the YazFi clients. You can view the YazFi clients either through the System Log > Wireless Log tab. Or using the YazFi command line interface option #2. Or using SSH and issuing the command; "cat /var/lib/misc/dnsmasq.leases". Or on the Guest Network > YazFi tab in the "Connected Guests (click to expand/collapse)" section.

What I have, on Windows, is a "BAT" file used in conjunction with Putty. It issues the "cat /var/lib/misc/dnsmasq.leases" command so I can quickly view the connected IoT devices on YazFi in addition to the rest of the main LAN clients. Example of that bat file:
Code:
plink.exe -batch -ssh -l <loginname> -pw <password> <routerIPAddress> cat /var/lib/misc/dnsmasq.leases

PAUSE
As previously indicated YazFi does not use the manually assigned IP addresses and names that one creates using the DHCP Server manual assign section. As previously indicated one can manually assign IP address and names for YazFi clients using SSH. See here: https://github.com/jackyaz/YazFi/wi...e-and-ARP-records#a-note-on-dhcp-reservations Or see my post here: https://www.snbforums.com/threads/y...inc-ssid-vpn-client.45924/page-32#post-473403
Sorry but how do I edit cat /var/lib/misc/dnsmasq.leases when I browse on the share I created /var/lib is empty.
 

bennor

Very Senior Member
Sorry but how do I edit cat /var/lib/misc/dnsmasq.leases when I browse on the share I created /var/lib is empty.
Not sure what you are attempting to do. When one connects to their router using SSH, they can issue the command: cat /var/lib/misc/dnsmasq.leases This will display or list the current client leases including the YazFi clients. Don't think one wants to "edit" that dnsmasq.leases file on their router.

If one wants to assign static IP addresses and assign names to the YazFi clients one can do so using the information I posted in the previous YazFi GitHub Wiki link, and at this previously posted link: https://www.snbforums.com/threads/y...inc-ssid-vpn-client.45924/page-32#post-473403

In my example at that link, "devicename" is the name one would give the YazFi guest (aka one's IoT) device. If one doesn't want to assign IP addresses but just add or change the name, it may be possible but one may/will have to learn more about dnsmasq (search the internet) for more information about how exactly to do so and how to properly structure the line of code.
 

Chewie420

Regular Contributor
I would like to update the hostnames that are being used. I could be wrong but it seems Yazfi uses it;'s own hostnames list and updating the names after doesn't seem to matter even if you uninstall Yazfi with data removal.

It shows names that I had previously but I have since updated the names and they don't show the new names.
I uninstalled Yazfi and re-installed many times but it still shows the old names.

I can get it to display the devices connected but just wanted to update the list with the new names I made.

I will show you a pic. So for this device I disabled Yazfil. Had the device show back up in the Networking map and renamed the device from August-Connect to August_Connect, but as you can see it shows as August-Connect in Yazfi no matter what I do.

Showing Old Name

New Bitmap Image.gif


Once I disable Yazfi and have device show up in Networking Map you can see the new name again.

New Bitmap Image.gif
 

Attachments

  • New Bitmap Image.gif
    New Bitmap Image.gif
    43.2 KB · Views: 74

Jack Yaz

Part of the Furniture
I would like to update the hostnames that are being used. I could be wrong but it seems Yazfi uses it;'s own hostnames list and updating the names after doesn't seem to matter even if you uninstall Yazfi with data removal.


It shows names that I had previously but I have since updated the names and they don't show the new names.
I uninstalled Yazfi and re-installed many times but it still shows the old names.

I can get it to display the devices connected but just wanted to update the list with the new names I made.

I will show you a pic. So for this device I disabled Yazfil. Had the device show back up in the Networking map and renamed the device from August-Connect to August_Connect, but as you can see it shows as August-Connect in Yazfi no matter what I do.

Showing Old Name

View attachment 37831

Once I disable Yazfi and have device show up in Networking Map you can see the new name again.

View attachment 37833
YazFi doesn't read names from network map, it reads them from a reverse lookup of the IP. You need to ensure the hostname is as desired on the device itself and/or on the LAN DHCP Server page.
 

Chewie420

Regular Contributor
om network map, it reads them from a reverse lookup of the IP. You need to ensure the hostname is as desired on the device itself and/or on the LAN DHCP Server page.
Hi Jack thanks for the reply, I am kind of confused I didn't think I could use DHCP for Yazfi IPs. The only way I can get it show up in DHCP is if I disable Yazfi and then I can add it into the DHCP list as static and it does show the new hostname that I changed it to.
 

Jack Yaz

Part of the Furniture
Hi Jack thanks for the reply, I am kind of confused I didn't think I could use DHCP for Yazfi IPs. The only way I can get it show up in DHCP is if I disable Yazfi and then I can add it into the DHCP list as static and it does show the new hostname that I changed it to.
It might be possible, I can't recall off the top of my head. Worst case, you can manually set hostnames via /jffs/configs/dnsmasq.conf.add by adding line(s) for your devices
 

Chewie420

Regular Contributor
It might be possible, I can't recall off the top of my head. Worst case, you can manually set hostnames via /jffs/configs/dnsmasq.conf.add by adding line(s) for your devices
would it be possible to have an option for yazfi to refresh this list when hostnames get updated or during a re-insatll of Yazfi
 

Chewie420

Regular Contributor
YazFi doesn't read names from network map, it reads them from a reverse lookup of the IP. You need to ensure the hostname is as desired on the device itself and/or on the LAN DHCP Server page.
if I delete /var/lib/misc/dnsmasq.lease will it get recreated again when if I reinstall Yazfi?
 

Jack Yaz

Part of the Furniture
if I delete /var/lib/misc/dnsmasq.lease will it get recreated again when if I reinstall Yazfi?
dnsmasq creates that file, its nothing to do with YazFi
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top