RT-AC66U AiMesh Node

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bright_today

New Around Here
Hello,

I am using 2x RT-AC66U B1 routers one as the main AiMesh router and the other one is an AiMesh Node. I have gigabit internet connection and when I connect my desktop PC to the main AiMesh route using ethernet I get ~ 700 Mbps Down speed tested with Speedtest.net. When I connect my PC to the AiMesh Node the speed drops to ~ 500 Mbps. I have set the AiMesh node Backhaul Connection Priority to 1G WAN first. What could be the reason for this drop in speed? Could it be fixed with changing any of the settings and if possible what settings should I change in order to maximise my Download/Upload speed for both LAN and Wireless? What is the maximum Wi-Fi speed on 5GHz I can get using RT-AC66U routers?

Thanks!
 
Last edited:

L&LD

Part of the Furniture
Welcome to the forums @bright_today.

Your post isn't too clear about how you have everything connected and how you are connected while testing.

The maximum theoretical speeds are about half the connection speeds listed in the link below for each band. And will be affected by other routers, non-Wi-Fi interference, and the client adaptor card and client device used to test with too. The 500/500 Mbps seems like you're hitting expected speeds to me if this is a wireless connection.

RT-AC66U B1 - Tech Specs|WiFi Routers|ASUS Canada

If all the tests you're doing are via wired connections...

Do you have QoS enabled? What firmware are you running on each router? Is HW acceleration enabled?

Have you tried using different Ethernet cables? (Pro tip: if you don't have extra cables to test with, try reversing the cable you have as a test).
 

bright_today

New Around Here
Sorry, I may have missed some important details.

I have a main AiMesh router connected to my ISP modem and a second AiMesh Node router connected to the main AiMesh router via ethernet cable. Both RT-AC66U B1 routers are running the latest stock Asus Firmware 3.0.0.4.386_43129-g60defb2.

I did a couple of tests:
Using wired ethernet connection:
- PC to main AiMesh router - ~ 700 Mbps
- PC to AiMesh node - ~ 500 Mbps
Using wireless connection (5GHz):
- Laptop to AiMesh node - ~ 350 Mbps

The QoS setting is disabled and I could not find HW acceleration in the settings.
I tested a different ethernet cable and different port on the AiMesh node and the results are the same
 
Last edited:

Tech9

Part of the Furniture
What is the maximum Wi-Fi speed on 5GHz I can get using RT-AC66U routers?

It depends on the client. Most common clients have 2-stream radios, the maximum link speed is 866Mbps. Real life expected throughput is about 1/2 the link speed close to the router. Theoretical maximum is a bit higher, but I usually get 380-480Mbps throughput on my 2-stream clients, depending on how busy the Wi-Fi environment is. I use different equipment, but the tech specs and capabilities are similar.
 

bbunge

Part of the Furniture
AS I see your setup you have the router and node Ethernet connected. Your first speed test is from a wired desktop connected to the router. The second speed test is from a WIFI client.
The AC66U_B1 has 3x3 radios on both 2.4 and 5 GHz bands. Your true bandwidth will depend upon the client WIFI which may only have 2x2 radios.
A 500 Mbps bandwidth is nothing to sneeze at and you should be happy with it. As L&LD says it seems you are hitting expected speed.
The AC66U_B1 is a great router for the money. I still have one under the desk waiting for a home or use when I decide to test AiMesh again.

Edit: there is a Beta firmware for the AC68U, which will run on the AC66U_B1, that has some improvements. Also think it has DNS over TLS.
 

L&LD

Part of the Furniture
@bright_today, thanks for clarifying.

Can you try testing with different speed tests before doing the suggestions below? Such as fast.com or any other test you can search for (maybe your ISP's).

Also, can you test via the built-in speed test of the router? You can find that in the Adaptive QoS section.

With both tests being run over Ethernet cable, there is an issue here. I would first try removing the node from the main router's GUI. This will/should reset the router to factory defaults. After that, I would also do a WPS Button reset as recommended for your router in the link below. Then, you can add the node back and see if the speeds are as they should be. Be sure to remove the Ethernet cable from the WAN port after you have removed it from the GUI.

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global


If all the above still fail to give expected results, I would do a full reset of all the routers/network. You really should be getting closer to 940Mbps or higher with your 1Gbps ISP connection on a wired computer.


Fully Reset Router and Network

Fully Reset / Best Practice Setup / More
 

bright_today

New Around Here
I did reset both routers using the WPS button method but unfortunately the speed is still the same when connected to the AiMesh node ~500Mbps down. The speed result is the same for speedtest.net and fast.com. What is strange is that the built-in speed test of the router reaches ~350 Mbps down.
 

Tech9

Part of the Furniture
RT-AC66U B1 is kind of slow for Gigabit ISP, but without Trend Micro should be able to reach full speed. The lower speed on the node is weird. I would try with a new cable and with the second router in AP mode. It's WAN-LAN on the first router and then again WAN-LAN as a switch on the second router. The speed should be the same, unless there is some AiMesh limitation we don't know about.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top