RT-AC88U 1Gb Fiber WAN - Router Bandwidth Throttling

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

HawkInOz

Regular Contributor
Our home fiber circuit was recently upgraded from 250Mb to 1Gb, and I’m now seeing a large discrepancy between speeds before the router and after the router.

Before/In front of the router – WAN link plugged directly into my laptop:

upload_2019-3-7_9-52-17.png


After/Behind the router – with the same laptop plugged directly into the router (way short):

upload_2019-3-7_9-55-58.png


Are there any changes to my WAN settings that you would recommend? I have tried connecting to the DNS Server automatically, but saw no change, and disabling UPnP - with the same lack of results.

upload_2019-3-7_10-10-8.png


Disabling QoS and all AiProtection features provided a 50Mb increase to 325Mb after the router, but that still falls well short of the full circuit bandwidth. I also confirmed all my WAN Settings with the ISP, including the WAN MTU of 1500. They suggested contacting the manufacturer for assistance.

upload_2019-3-7_9-48-28.png


I have also confirmed that NAT Acceleration is Enabled (Auto). I'm not really sure exactly what "NAT traffic is processed by the CPU" really means, or what other messages might be present with it on Auto.

upload_2019-3-7_9-57-23.png


I have Spanning-Tree Protocol enabled because I have another 8-port switch in use. I did try disabling STP, but that didn't make any difference on the internal speeds I'm seeing.

I tried a full electrical reboot of the router (pulling power and powering the unit off and on several times, waiting 30 minutes and then restoring power).

Any other suggestions on how to get the full bandwidth available on the internal side of the RT-AC88U? When I upgraded the firmware to 384.8_2, I did a factory reset and manual reconfiguration. Granted, that was a couple months before the circuit upgrade, but I hate to do it again if I don't need to.

I have also been considering an upgrade to the RT-AX88U for a while now, but I'm concerned that that model might have similar throttling issues...

Thank you in advance for any assistance you can provide.
 

skeal

Part of the Furniture
It looks like one of your custom settings is stopping Nat-Acceleration from working. The model of router you have would need that enabled to get the full bandwidth you want. The proper indication would be CTF enabled, stands for "cut through forwarding"
 

skeal

Part of the Furniture
Making any changes requires a reboot.
 

L&LD

Part of the Furniture
Do you need the Bonding/Link aggregation enabled? What speedtest are you using?

What does fast.com, dslreports.com/speedtest or other good speedtests indicate?

I'm assuming the RT-N66U is used as an AP? Can you take it and the switch out of the equation for testing?

When you have nothing else connected or even turned on (just the ONT, the RT-AC88U and a single wired computer), do the speeds show the same? If they do, I would be resetting to factory defaults followed by a minimal and manual config.

Are you doing anything custom on the router? If not and the symtoms persist, reset it. Remove the USB drive. Do all the following methods at one go; via the gui, via the WPS button, format the jffs at boot and then reboot at least three times.

For good measure; flash the firmware you want to use twice. Yes, even if its the same version you're on now.
 

skeal

Part of the Furniture
That page should look like this:ASUS Wireless Router RT AC3100   Switch Control.png
 

HawkInOz

Regular Contributor
Do you need the Bonding/Link aggregation enabled? What speedtest are you using?

What does fast.com, dslreports.com/speedtest or other good speedtests indicate?

I'm assuming the RT-N66U is used as an AP? Can you take it and the switch out of the equation for testing?

When you have nothing else connected or even turned on (just the ONT, the RT-AC88U and a single wired computer), do the speeds show the same? If they do, I would be resetting to factory defaults followed by a minimal and manual config.

Are you doing anything custom on the router? If not and the symtoms persist, reset it. Remove the USB drive. Do all the following methods at one go; via the gui, via the WPS button, format the jffs at boot and then reboot at least three times.

For good measure; flash the firmware you want to use twice. Yes, even if its the same version you're on now.

I'm using Link Aggregation to my NAS where I'm running my DLNA/UPnP Media Server - and nightly backups of all my computers. Seems reasonable to enable it for these purposes. FWIW, I did try disabling it to no noticeable effect.

I'm using the SpeedTest app for Windows (64-bit) https://www.speedtest.net/apps/windows, but get nearly identical results from the online speedtest.net version. Fast.com reports much lower results at 110Mbps (???), while dslreports.com reports slightly higher results at 392Mbps.

The RT-N66U was previously being used as a Repeater, but has actually been offline for a few months now. It is a non-factor. I still own it and keep the firmware updated, but it isn't powered on at all.

I haven't tried removing everything except for the one computer, but I'm pretty sure the few devices online wouldn't be responsible for the lost 600Mbps... I can give it a try tonight, but don't expect any real change in doing so.

I'm really not doing anything custom, other than having installed Diversion and amtm. Currently, Diversion has also been disabled to eliminate it as a possible culprit here. Disabling it had no noticeable effect, but it remains disabled for the moment while I try to figure this out. I do have two OpenVPN servers set up, which I use only for personal remote access when/if needed. The majority of the time, they are enabled but idle.

I can certainly try re-flashing the firmware tonight as well, and see if it makes any difference. Thanks.
 

HawkInOz

Regular Contributor
It looks like one of your custom settings is stopping Nat-Acceleration from working. The model of router you have would need that enabled to get the full bandwidth you want. The proper indication would be CTF enabled, stands for "cut through forwarding"

Can you be more specific at to what possible "custom settings" would cause NAT Acceleration to not be working as it should? I don't think I have any custom settings really, but would certainly like to know where to look to be certain. Is there a complete list of things that would affect this? Thanks.
 

EmeraldDeer

Very Senior Member
  • To simplify the focus on a goal which would allow for over 800 Mbps WAN throughput, you want Tools > Sysinfo > Network > HW Acceleration to be "Runner: Enabled - Flow Cache: Enabled" EDIT: RT-AC88U maybe Cut Through Forwarding and Flow Accelerator instead
  • I doubt that LAN link aggregation impacts WAN throughput. However, that message you are seeing should have gone away once you enabled link aggregation on the NAS side.
  • I have seen lists of options which impact Runner and Flow Cache (or their predecessors). However, as newer models come out, less options disable them. For example AiProtection and Spanning Tree disabled them on my RT-AC3200 but do not on my RT-AX88U. QoS does disable them even on my RT-AX88U. You might be in a trial and error situation unless another RT-AC88U owner knows.
 
Last edited:

john9527

Part of the Furniture
Per IP traffic monitoring and having a USB modem attached I'm pretty sure will also disable HW acceleration. Running on a forwarded port or thru a VPN connection I think also disables HW acceleration for those connections.
 

HawkInOz

Regular Contributor
@EmeraldDeer & @john9527 :

THANK YOU THANK YOU THANK YOU!!!

EmeraldDeer got me looking in the right place to see what exactly was interfering with NAT/HW Acceleration, where i saw this: "HW acceleration: Disabled - incompatible with: IPTraffic" (like John said).
I found the setting on the neighboring "Other Settings" tab, and promptly disabled it:

upload_2019-3-7_14-18-6.png


It didn't immediately clear the compatibility issue with HW acceleration showing on the Sysinfo tab (which now left the field blank as to what was disabling it), so I rebooted the router. Afterwards, the Sysinfo tab displayed that HW acceleration was Enabled (Yay!):

upload_2019-3-7_14-19-55.png


And the LAN > Switch Control tab concurred (Yay!):

upload_2019-3-7_14-21-26.png


And a quick run of the Speedtest.net speed test (while connected via OpenVPN, no less - using another computer on the home network) now reports (Double-Yay!!):

upload_2019-3-7_14-24-43.png


You guys just saved me $350 for a router upgrade I didn't need at this time... THANKS AGAIN!! Love this forum!!!
 

L&LD

Part of the Furniture
I also learned something here too. CPU processed traffic is not the same as CTF.

Duly noted!

Glad you didn't go down the rabbit hole I was pointing to. Even if it may have fixed the issue in a roundabout way. ;)
 

HawkInOz

Regular Contributor
Glad you didn't go down the rabbit hole I was pointing to. Even if it may have fixed the issue in a roundabout way. ;)

I'm glad you and @skeal were both willing to jump into the fray and start making suggestions and asking questions to get everyone thinking... and ultimately to finding the solution. Way better than sitting around alone beating one's head against the proverbial brick wall and getting nowhere! o_O
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top