What's new

RT AX82U Firmware Does Not Update

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

doozylol

New Around Here
Hello, I've had issues with my AX82U for several weeks now. My internet drops every 5-10 minutes over ethernet and I've tried hard resetting my router/modem and reinstalled ethernet drivers on my computer. I've used the mobile app and the web browser to update the router firmware from 3.0.0.4.384_9948 to 3.0.0.4.388_23285 but it does not go through and reverts back to the old version. I've also tried using Firmware Restoration tool but that does not work either. Any suggestions would be appreciated.
 
Firmware 3.0.0.4.386.50289 is the last one containing single image. Try updating to it first manually.

1694752601664.png


After this firmware the files contain two images for RT-AX82U and RT-AX82U V2. Perhaps this is the reason you can't update from 3.0.0.4.384_9948.
 
I tried updating to 3.0.0.4.386.50289 firmware manually but it did not go through either. Am I on the wrong version?
1694753353516.png
 
if it's stuck on the 384 code base I would start by uploading to the 3.0.0.4.384.10177 which is the last before the 386 jump, and then try the first version of the 386 (3.0.0.4.386.41700). Then try the jump to the 388. Eventually, try the latest 386 version available before going to 388.
 
3.0.0.4.384.10177 did not go through either :( also side note, I found that 3/4 ethernet ports on the back of the router does not work, could it be a wire/port issue?
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top