What's new

RT-AX86U Pro Firmware update fails

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello everyone,
I cant install the latest Merlin Firmware on my Asus.
I have stock on it.
Everytime when I try to flash Merlin RT-AX86U_PRO_3004_388.4_0_nand_squashfs.pkgtb I get a error message.
They just told me that flashing was interupted.
Perhaps someone could help me?
How are you flashing, over WiFi or over Ethernet? Generally its wise to flash the router from a wired Ethernet connection directly connected between the router and PC. Have you tried a different web browser? As a troubleshooting step temporarily disable any anti virus or security programs along with any browser add-ons. Have you tried rebooting the router and re-flashing? And if you have a USB drive attached to the router, disconnect it before performing a firmware update.

As another troubleshooting step you may need to perform a hard factory reset on the router running stock Asus firmware, do a basic configuration to get into the GUI, then perform a firmware update to the Asus-Merlin firmware.

The Asus-Merlin Wiki has some additional suggestions for installation:

RT-AX86 Pro user here and didn't have a problem flashing from Asus stock firmware to Merlin (and back and forth repeatedly for some testing).
i already tried a hard factory reset, dont have a usb device, and a other browser (Firefox and Edge), I dont have a lan port in my desktop so i tried using WLAN!
Thank you for your answer.
Try using the English language for the router. Download the correct firmware for it, verify its hashes, reboot the router, and then flash it.
Your AC86U can not use firmware for AX models.
Really? What Firmware is the right then? Now I have RT-AX86U_PRO_3004_388.4_0.zip! Just can find a AC86U version...

Yes. Really. They are two totally different routers released years apart. The pro version has a bunch of new features that you can't just add by applying firmware, it requires the new hardware (plus they wouldn't want you getting those features without paying for them).

While the firmware does have a safety built in to prevent people from bricking their routers (which is what you were trying to do), you can't rely on that, be very careful in the future to download the firmware for your exact model. If you can't find it, don't just grab some other one that looks kinda like it. You may end up with a doorstop.

Just go here and use "find" to find your model

Your AC86U can not use firmware for AX models.

I think they meant they could only find AC86U and not AX86U on the downloads. The screenshots do show the AX86U.
I think they meant they could only find AC86U and not AX86U on the downloads. The screenshots do show the AX86U.
Ah, yes. Had to open up the "big" PC as the tablet did not show the "ghost" of the AX86U in the screen shot. The OP had just done a fumble finger.
Thats it - now everything is working but the seller said its a pro. Time to talk with him :-(
Last edited:
Last edited:
Yes, as your last screenshot shows, you don't have the 'pro'.

As mentioned in post 5, you didn't download the correct version.

Glad you got it now.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!