1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Virgin Media Hub 3 , RT-AC68U Speed Loss

Discussion in 'Asuswrt-Merlin' started by linkmaster, Jan 20, 2019.

  1. linkmaster

    linkmaster Regular Contributor

    Joined:
    Feb 15, 2013
    Messages:
    89
    My setup


    Virgin Media Hub 3 in modem only mode, Line is maxed at 352 Mbs

    RT-AC68U running Merlin 384.8_2

    PC running ethernet connection directly to the RT-AC68U

    My issue (I'm hoping someone may have had this issue and know a setting I can change)

    IF I run through the Router , the max speed I get is 195-204Mbs

    IF I run directly connected to the Hub, using the same cable from my PC , I max out at 350-360Mbs.

    Does anyone know of a setting in the firmware I can tweak to get my full speed going through the RT-AC68U?

    The difference in speed is a huge drop.
     
  2. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,508
    turn on nat acceleration or turn off QoS and TrendMicro
     
  3. MarkyPancake

    MarkyPancake Senior Member

    Joined:
    Dec 17, 2013
    Messages:
    215
    As a side note, check in the Virgin Community forums to see if your SH3 has the firmware version that tries to reduce the impact of the Puma chipset issue that affects your connection. Particularly if you play online games.
     
    muffintastic likes this.
  4. linkmaster

    linkmaster Regular Contributor

    Joined:
    Feb 15, 2013
    Messages:
    89
    Turned Nat acceleration to Auto and Trend Micro and QoS were already off , unfortunately no change.
     
  5. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,508
    just for testing/comparing, change your modem from bridge to router mode, reset 68U and configure in router-mode too (double NAT), in another test with AP mode.
     
  6. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    7,548
    Location:
    UK
    Power cycle the router to make sure to change is effective. Then check the state of HW acceleration on the Tools page.
     
  7. linkmaster

    linkmaster Regular Contributor

    Joined:
    Feb 15, 2013
    Messages:
    89
    Turns out HW acceleration was being auto-toggled off because I had Per IP logging toggled on, switching it off and a re-boot did the trick..many thanks.