Why multicasting is so poor on WiFi?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

gjf

Senior Member
Asus RT-AC68U with Merlin 386.1_2.

The provider broadcasts IPTV via multicast.
The router has the following simple settings for IPTV:
Безымянный.png

I have two mediaplayers in this network: one connected by cable and one - by WiFi. Both are the same in the meaning of model, firmware and settings.
Both shows a good connection (in meaning by speed) and good video playing (for online cinemas)
Cable connection works like a charm for IPTV.
WiFi connection shows freezes after 20-30 seconds of playing IPTV.

Taking into account all circumstances I think the problem is in router.

I've tried to disable multicast routing at all and to enable UDP Proxy. But in this case IPTV is a nightmare at all - I think router has no resources to work in proxy mode.

Any other advices?

I'm attaching Wireless settings just in case:
Бмянный.png
Беый.png
 

Wade Coxon

Senior Member
I take it the problematic media player is on 2.4GHz then?

Turn off Explicit Beamforming, and set the multicast rate to Auto.
Any reason you are limiting the modulation scheme to 802.11n?
And drop your channel width to 20MHz. 40MHz in the 2.4GHz is asking for trouble.
 

gjf

Senior Member
802.11n shows better performance on other WiFi clients. So that's why it was set.
Although I've tried your advices as well as setting modulation scheme to auto.
It doesn't help either.
And yes: problematic media player works on 2.4 GHz only - that's why I didn't post 5 GHz settings.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top