What's new

Wireless 5GHz takes 10 minutes to be ready

RobW

New Around Here
Hi,

I have a RT-AC88U, running 384.18

When I reboot the router, it takes around 10 minutes for the 5GHz channel to be available.
When I go to the wireless log I can see: DFS State: PRE-ISM Channel availability Check (CAC)
This stays for around 10 minutes, until the channel is cleared for radar and the dfs state changed to In-Service Monitoring.

This happens when all settings are on auto. But also when I specify channel bandwith and the control channel.

What is causing this and what can I do to speed things up ?
It didn't happen with 384.17.
I did a factory reset, but that didn't really help.
 

Freddi

Occasional Visitor
Definitely not normal. Two routes possible, IMHO:

1) You have a hardware failure, or pending hardware failure, probably with the radio. (not my guess)

2) You have a software problem, that you could spend A LOT of time trying to narrow down. You say you did a factory reset...Clearing NVRam and all, and manually putting in all the settings manually? (not using a backup of settings?) If not, start there, with a fresh reload of firmware. Then, put in the bare minimum configuration, and see if the problem still exists. If it does, refer to item 1.

Good luck, report back!
 

john9527

Part of the Furniture
Specify channel and bandwidth NOT using a DFS channel (Channels 50 through 144 are DFS - available channels vary by region)
 

FTC

Senior Member
Hi, It is absolutely normal. Basically the router is 'scanning' for radars before using a given 5Ghz channel, and this is mandatory by the specification. Not all channels require the 10 minute wait. some do require 10 minutes, anothers only 1 minute and others (non DFS ones) do not require waiting. It can also vary by country. Take into account that channel width plays a role also, so if your channel width is 80, then you are using 4 channels of width 20 so as long as any of these 4 is a DFS channel the router will wait its specified time.
 
Last edited:

RobW

New Around Here
@Freddi

1)
Let's hope not :)

2)
I checked, factory reset and rebooted. Then I also removed the power for a while. I didn't use a backup script to restore. And before this I also flashed back the old firmware and then again the new one.
After this 2.4 GHz came up after 1 minute and 45 seconds. Also saw 5 GHz coming up after 2 minutes and 45 seconds. That's how it always was. Then with mini steps and rebooting after each step I checked the coming up time. After facory reset I did some minimum changes (SSID name & password, turning off WPS and assigning some static IP's). After booting up became slow again, I undid the last step, but the booting up wasn't fast again.

@john9527
I changed the 5GHz to channel 44 and it was booting fast!
When I can't solve it, I can keep using this to avoid the problem. Just don't like avoiding things in stead of solving them :-(
 

ColinTaylor

Part of the Furniture
To be able to use the 5GHz DFS channels the router must wait for at least 60 seconds to ensure the channel is clear (which is why you saw your 5GHz SSID appear 60 seconds after the 2.4GHz SSID). If you want to use channels 120 to 128 which are used by weather radar the router must wait for 10 minutes. So select a fixed channel and avoid channels 120 to 128.
 

john9527

Part of the Furniture
I changed the 5GHz to channel 44 and it was booting fast!
When I can't solve it, I can keep using this to avoid the problem. Just don't like avoiding things in stead of solving them :-(
As @ColinTaylor and @FTC explained, there is nothing to solve. Things are working as spec'd in order to ensure that your wireless signal is not going to cause problems with nearby radar systems.
 

CaptnDanLKW

Regular Contributor
IIRC, on my RTA86U and 384.17 with SmartConnect Disabled, when Channel was set to auto, there would also be a checkbox next to the drop-down that you could enable that said "Also use DFS channels".
On 384.18, I don't see that checkbox anymore and I don't think I'm mis-remembering that option.

I know the OP has different hardware and that the problem is solved by selecting a non DFS fixed channel, but just pointing out an observation.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top