2.4Ghz wireless mode "auto": defaulting to Ch. 14; can I disable 12-14?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

anoukaimee

Occasional Visitor
I am using HGG's 380.59.1 fork on my RT-ACU. We are getting a range extender, but for the time being, have a very weak signal downstairs. Trying to optimize it but still get all of my devices to connect.

The problem device is my Brother HL-L2380DW, which runs on the N standard, but it only runs on 2.4Ghz. It works when I have mixed mode enabled, but not if I choose "auto" channel. It seems to default to channel 14 (which I didn't even know that my modem supported). Also, I have an old Roku 3, an N device, and I can't get decent bandwidth on any channel except for 161 (which was suggested by Roku C/S).

Picking a fixed channel wouldn't be a problem for me at all, except that we are in an apartment building where it appears that all of our neighbors are set to "auto" channel. Meaning that if I set 1, 6, or 11, every other day my devices (all of which but the Brother and my Roku 3 are AC), searching for a strong signal on the 2.4Ghz band optimized for distance, get a very degraded signal because all of my neighbors are on the same one and they therefore run unworkably slow. If I pick "auto," everything perks up, but I'm back on 14 again, and this seems, from troubleshooting, to be the problem with the printer connecting with the network.

Is there a way I can disable these higher channels? Alternatively, is there an optimal mode that will work for both my Roku and my printer, without forcing me to set it to a fixed channel?

I do see something under WAN > DDNS that implies that there is another way to configure a client to connect. I know nothing about this. Is this possible?

I'm attaching shots of the 2.4 and 5ghz screens as set for a good connection, my client list (which shows the Brother printer isn't connected), and in case I'm using the wrong terminology, the shot of the DDNS screen to which I refer.

Thank you!
24ghz.PNG
5ghz.PNG
24ghz.PNG
5ghz.PNG
clients.PNG
ddns.PNG
 

evh909

Regular Contributor
try unchecking the b/g protection option. also, does the wlan report show anything useful about the printer?
 
Last edited:

anoukaimee

Occasional Visitor
Ok; I unchecked b/g, and both my printer and Roku are working! The GUI shows both clients and I was able to use both wirelessly.

Thank you! Just curious, what did this do?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top