AdGuardHome Adguard setup

Shadowflake

Occasional Visitor
I'm trying to switch from diversion to addguard. I have disabled diversion and installed adguard. I can login local on the adguard settings Page.

Adguard has the following adressen:
  • 127.0.0.1
  • 127.0.1.1
  • 192.168.50.1
  • 109.132.175.160
So the configuration is running.
In the lan section of the router the following has been set.
Dchp server:
DNS server 1: 192.168.50.1
DNS server 2: 127.0.1.1

Why are there still a lot off adds on webpages? Do it need to setup something else?

Thanks for the feedback.
 
Last edited:

Shadowflake

Occasional Visitor
I have added some extra information:
* ipconfig all
* adguard dashboard
* adguard installation info
* Asus Lan setup
* Asus wan setup

Hopefully this helps to put me in the right direction to make it work.

Thanks in advance.
 

Attachments

  • Adguard dashboard.png
    Adguard dashboard.png
    137.1 KB · Views: 104
  • adguard installatiegids.png
    adguard installatiegids.png
    36.7 KB · Views: 113
  • asus lan DCHP.png
    asus lan DCHP.png
    106.2 KB · Views: 108
  • Asus Wan.png
    Asus Wan.png
    204 KB · Views: 108
  • IPconfig all.png
    IPconfig all.png
    28.8 KB · Views: 107

grogi

Occasional Visitor
Few tips, which should not affect effectiveness of blocking - but will imporove seciruty and performance.
  • Remove the DNS server 2: 127.0.1.1. Any address that starts with 127 is local loopback - hosts will try to ask themselves for the addresses.
  • Disable the AdGuard on the WAN interface as well.

Otherwise it seems hosts are using your AdGuard to exectue DNS queries. But nothing gets filtered out. In Adguard UI, go to Settings/Filters and see if you have any rules defined.
 

SomeWhereOverTheRainBow

Part of the Furniture
Lan DHCP DNS on DHCP pages should be blank if AdGuardHome is being used on the router himself. It appears the problem is caused by improperly self configured router settings. You should have left these as default, since the adguardhome installer sets the router up as if it was left "default" settings wise. Wan DNS should be set to automatic, Lan DNS should be blank. Viola it should all work from there. This is why it is critical to read the first couple of forum threads here:

 
Last edited:

SomeWhereOverTheRainBow

Part of the Furniture
Few tips, which should not affect effectiveness of blocking - but will imporove seciruty and performance.
  • Remove the DNS server 2: 127.0.1.1. Any address that starts with 127 is local loopback - hosts will try to ask themselves for the addresses.
  • Disable the AdGuard on the WAN interface as well.

Otherwise it seems hosts are using your AdGuard to exectue DNS queries. But nothing gets filtered out. In Adguard UI, go to Settings/Filters and see if you have any rules defined.
He really doesnt have to change the loopback address, especially if he is using local resolver on his router. this would break the routers local DNS since dnsmasq is moved to a different port other than 53. The wan interface can be ignored, since this should be blocked by the default firewall. ( and default security options of adguardhome itself).

Essentially adguardhome is configured to listen on

0.0.0.0:53

The same as dnsmasq would have been if it had been left on port 53.

Those addresses don't actually get used unless a request is made on them. For the instance of the WAN IP, that would be blocked by the firewall unless the request is made from within the lan itself. As for the loopback address, that would only be used if a DNS request was made on the router himself.
 
Last edited:

SomeWhereOverTheRainBow

Part of the Furniture
I have added some extra information:
* ipconfig all
* adguard dashboard
* adguard installation info
* Asus Lan setup
* Asus wan setup

Hopefully this helps to put me in the right direction to make it work.

Thanks in advance.
Here is my corrections to your setup.

1664374992612.png

1664375296777.png


1664375454213.png
 

Attachments

  • 1664375095914.png
    1664375095914.png
    253.7 KB · Views: 56
Last edited:

Shadowflake

Occasional Visitor
Few tips, which should not affect effectiveness of blocking - but will imporove seciruty and performance.
  • Remove the DNS server 2: 127.0.1.1. Any address that starts with 127 is local loopback - hosts will try to ask themselves for the addresses.
  • Disable the AdGuard on the WAN interface as well.

Otherwise it seems hosts are using your AdGuard to exectue DNS queries. But nothing gets filtered out. In Adguard UI, go to Settings/Filters and see if you have any rules defined.
The following is set in the filter. (see attachement)
I don't know how to disable adquard in the WAN interface :(.
dns blocking list.png

All these corrections are made.
Adguard is still not blocking any adds.
 

Shadowflake

Occasional Visitor
Also, if you are using a DUAL WAN configuration, Make sure you have the correct WAN interface turned on. Sometimes DUAL WAN configurations creates an UNKNOWN environment in regards to which DNS is actually being used.

View attachment 44448
Dual Wan is disabled.
Dual wan.png

My suggestion is to go to your DNS filter page.

Make sure you have dns filter custom 1 set to your routers LAN IP. Then set the global setting to use Custom slot 1.
Take a look at the screenshot do you mean like this?
I don't understand the following: then set global setting to use custom slot 1. Where can i configure this?
DNS filter page.png
 

SomeWhereOverTheRainBow

Part of the Furniture
Dual Wan is disabled.View attachment 44449

Take a look at the screenshot do you mean like this?
I don't understand the following: then set global setting to use custom slot 1. Where can i configure this?View attachment 44450
Yes that is the right ip address in custom 1. Next you need to change the the "global filter mode" to "custom 1" and delete that client list rule and click apply.

If you do my last requests listed here, then your clients will be using ADGuardhome for dns instead of being directed to use a different dns server.

Adguard Adblock is not the same as Adguardhome and you are currently forcing your clients to bypass Adguardhome by using the Adguard Adblock in global mode.

Change this entry to "custom 1":
Screenshot_20220928_124308.jpg


You can also delete whatever you have in "custom 2" and "custom 3" those would not be necessary.

Delete these entries(including the rule on the client list):

Screenshot_20220928_124554.jpg


Then apply the changes.
 
Last edited:

Shadowflake

Occasional Visitor
Yes that is the right ip address in custom 1. Next you need to change the the "global filter mode" to "custom 1" and delete that client list rule and click apply.

If you do my last requests listed here, then your clients will be using ADGuardhome for dns instead of being directed to use a different dns server.

Adguard Adblock is not the same as Adguardhome and you are currently forcing your clients to bypass Adguardhome by using the Adguard Adblock in global mode.

Change this entry to "custom 1":
View attachment 44454

You can also delete whatever you have in "custom 2" and "custom 3" those would not be necessary.

Delete these entries(including the rule on the client list):

View attachment 44455

Then apply the changes.
I did the following see screenshot.
Still getting adds :( .
Global filtering custom 1.png
Bah 2.png
Bah 1.png
 

Shadowflake

Occasional Visitor
Below a summary of all the settings and still adds comming through :(.
 

Attachments

  • Addguard dns.png
    Addguard dns.png
    141.4 KB · Views: 38
  • Addguard installation.png
    Addguard installation.png
    166.6 KB · Views: 34
  • Addguard.png
    Addguard.png
    116.9 KB · Views: 37
  • General.png
    General.png
    186.8 KB · Views: 40
  • LAN DHCP server.png
    LAN DHCP server.png
    163.5 KB · Views: 37

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top