DSL-AC68U cant boot fully

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

manman

New Around Here
after 3 days reading internet and hard try , I decided to discuss the problem here.
I received a bad DSL-AC68U modem ,only power LED lightet but i can see CFE consol in recovery mode. i can upgrade various firmware without any problem .
but modem can not boot .both wifi led ist off , ip address 192.168.1.1 dont working . and i dont access Asus page .
i used TTL serial converter with PuTTY software and i tried this command "nvram erase" and after it "reboot" but isnt successfull .
my guess is that the firmware does not boot completely.
anybody has any solution ?
i attached a process in PuTTY software, maybe help
 

Attachments

  • teeeeext.txt
    31.8 KB · Views: 73

manman

New Around Here
in Boot process ,It always stays in this line .like that boot partition is smaller than program
 

Attachments

  • boot.png
    boot.png
    36.7 KB · Views: 44

GNUton

Senior Member
after 3 days reading internet and hard try , I decided to discuss the problem here.
I received a bad DSL-AC68U modem ,only power LED lightet but i can see CFE consol in recovery mode. i can upgrade various firmware without any problem .
but modem can not boot .both wifi led ist off , ip address 192.168.1.1 dont working . and i dont access Asus page .
i used TTL serial converter with PuTTY software and i tried this command "nvram erase" and after it "reboot" but isnt successfull .
my guess is that the firmware does not boot completely.
anybody has any solution ?
i attached a process in PuTTY software, maybe help
Hi,
When the TFTP server is listening. please flash the firmware.
Then wait for a few mins for it to apply the changes. \
When done, please reboot ad see if it works.

if it doesn't send connect the serial port and send us the logs of the failing boot.
When you boot the device DO NOT PRESS any reset button.
 

manman

New Around Here
in PuTTY software with this command " flash -noheader : nflash1.trx " , i dont access to TFTP protocol. have fault
Code:
CFE> flash -noheader : nflash1.trx
Reading ::
TFTP Server.
..tftp retry wait 0
Failed.: Timeout occured
*** command status = -21
i can only flash firmware with Asus mini web and by Tptpd64 (Jounin).
after flash i can see "go load" command and very very text but all time it stop in this line :
hotplug net INTERFACE=br0 ACTION=add SEQNUM=277
and can not finish this process . Is this a normal ending?
Is there a way I can make sure that NAND chip is healthy OR RAM chip?
Can I reconfigure all partitions?
I attached a text file for my modem, Is this a normal process ?
 
Last edited:

manman

New Around Here
Also i see this CRC fault in NAND :
is normal ?
Also i have Bad eraseblock ,
Code:
Scanning device for bad blocks
Bad eraseblock 793 at 0x000006320000

Code:
1: set_action 0

"brcmnand" successfully unlocked.

JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.

Empty flash at 0x0060325c ends at 0x00603800

Empty flash at 0x00604194 ends at 0x00604800

Empty flash at 0x00609808 ends at 0x0060a000

jffs2_scan_eraseblock(): Node at 0x009357fc {0x1985, 0xe002, 0xe0011985) has invalid CRC 0x00000039 (calculated 0xfce039b8)

Empty flash at 0x010e7068 ends at 0x010e7800

Empty flash at 0x02526acc ends at 0x02527000

Empty flash at 0x0252b380 ends at 0x0252b800

jffs2_scan_inode_node(): CRC failed on node at 0x0252ffe0: Read 0xffffffff, calculated 0xd26c43cd

Empty flash at 0x02530024 ends at 0x02530800

jffs2_scan_inode_node(): CRC failed on node at 0x025357e0: Read 0xffffffff, calculated 0x25195a9d

Empty flash at 0x02535824 ends at 0x02536000

Empty flash at 0x0253a3b8 ends at 0x0253a800

Empty flash at 0x0253b1a0 ends at 0x0253b800

Empty flash at 0x0253c30c ends at 0x0253c800

Empty flash at 0x0258a034 ends at 0x0258a800

Empty flash at 0x03180860 ends at 0x03181000

Empty flash at 0x03181990 ends at 0x03182000

Empty flash at 0x031829a0 ends at 0x03183000

Empty flash at 0x03187398 ends at 0x03187800

Empty flash at 0x0318bad8 ends at 0x0318c000

Empty flash at 0x0318cbb4 ends at 0x0318d000

Empty flash at 0x0318d974 ends at 0x0318e000

Empty flash at 0x0318e96c ends at 0x0318f000

jffs2_scan_inode_node(): CRC failed on node at 0x031937d8: Read 0xffffffff, calculated 0xc68626c0

Empty flash at 0x03193c00 ends at 0x03194000

Empty flash at 0x031953e0 ends at 0x03195800

jffs2_scan_inode_node(): CRC failed on node at 0x031987cc: Read 0xffffffff, calculated 0x22e7efc7

Empty flash at 0x03198810 ends at 0x03199000

Empty flash at 0x0319d180 ends at 0x0319d800

Clean /jffs/*
 
Last edited:

manman

New Around Here
in Boot process ,It always stays in this line .like that boot partition is smaller than program

i tried with many firmware but all firmware stop exactly in this line .
maybe NAND have bad sector or another ?
what informations is on NAND chip ? there is also a chip similar bios chip (8Pin flash chip).
anyone know where the CFE program is dumped ?
 

Attachments

  • Untitled.png
    Untitled.png
    334.9 KB · Views: 27

manman

New Around Here
Would it be possible for somebody with a working DSL-AC68U to post the output of CFE's nvram show and reboot command?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top