What's new

Solved RT-AC68U: no WAN, no Wifi

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Need some expert opinion on my RT-AC68U situation.
Had the router for around 7 years, been running Merlin on it.
Was on 386.11.
It was the master of a mesh with 2 Lyra Trios.

It started with wifi going down.
I switch off and on the router, wifi back.

When I came back next day I was told the wifi went down for the day.
Switching off and on don't work anymore.

I went to the WebUI.
Changed all the channel settings to Auto to try.
No go.

Messed around some more.
Forgot what i did.
Ultimately settle on factory reset.

Unidentified network.
I lost access to the WebUI.

Recovery mode.
I tried to upload 386.11 via the CFE page.
Got back to WebUI.
Went through the quick setup.
No wifi, WAN says disconnected but the cable is in.
It does detect when the cable is out but when plugged it just says "internet status: disconnected".
Wifi settings page, the channels are at 0, channel drop downs only have one option "Auto".
At system info page, wireless driver version are two "None".
The time is stuck from 5th May as theres no way to sync time.

Once I log out I cannot log back in.
Tried the password I set in quick setup, tried old password, tried admin/admin.
No go.

Needed to go back to the Recovery CFE page to erase NVram and reboot, go through quick setup to get back in to WebUI.
Yes, still no WiFi and WAN everytime.
And also everytime I log out I can't log in.
So I erased NVram quite a few times as I try stuff.

Tried to upload latest official firmware through WebUI.
It go through the motion but didn't do anything, still at 386.11.

I tried using the Firmware Restore tool.
Restore to the latest official firmware failed.
Read a thread here to try an older smaller firmware.
Restore to was successful.

But even with the official firmware its the same.
No wifi, no wan, can't log in once logged out.

Now leaving the 2 Lyra Trios to run the show.
Have no ideas left so I came here to seek help.
Can the RT-AC68U be saved?

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!