Release [Fork] Asuswrt-Merlin 374.43 LTS releases (V44EA)

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

atkinsom

Regular Contributor
@atkinsom Do you have any VPNs active when you're testing this? In your Filezilla setup what are you using in the "Host" field, an IP address or DDNS name?
@ColinTaylor I do not have active VPN Clients running on the router. I do have 2 VPN servers configured on the router with different settings using different ports but there are no active connections used at this time. I'm using the DDNS name. Just as an FYI I tested TLS connections to 2 different FTP servers on my internal network via outside connections and they both connected with out issues. One is going to my PC on the internal network and the other is going to my NAS. Again both those servers have port forwarding rules setup on the router for passive connections. Thanks again for your help.
 

atkinsom

Regular Contributor
The firmware should already have done this for you. You can check it by issuing these commands:
Code:
# nvram get ftp_pasvport
57530

# iptables-save | grep 57530
-A INPUT -p tcp -m tcp --dport 57530:57560 -j ACCEPT
EDIT: Are you port forwarding for another FTP server on your LAN? (port 21)
Yes I'm forwarding to Port 21 to one of the FTP servers but the internal router is using port 2021 from the outside
Also ran your commands and they are exactly the same as yours...now I'm really confused
 
Last edited:

ColinTaylor

Part of the Furniture
Yes I'm forwarding to Port 21 to one of the FTP servers but the internal router is using port 2021 from the outside
This sounds like the problem. AFAICT the router's ftp server is hard-coded to use port 21. If you're doing something like port forwarding external port 2021 to internal port 21 that would explain why it isn't working.
 

atkinsom

Regular Contributor
This sounds like the problem. AFAICT the router's ftp server is hard-coded to use port 21. If you're doing something like port forwarding external port 2021 to internal port 21 that would explain why it isn't working.
OK thanks Colin...I'm going to attack this from a different angle. See my screenshot below re: external FTP port for the router where you can decide what port to use for external connections

upload_2020-3-23_11-8-46.png
 

ColinTaylor

Part of the Furniture
OK thanks Colin...I'm going to attack this from a different angle. See my screenshot below re: external FTP port for the router where you can decide what port to use for external connections

View attachment 22139
Ah, OK. It now becomes clear.

Using that option creates a DNAT rule for the incoming ftp connection, as follows:
Code:
-A VSERVER -p tcp -m tcp --dport 2021 -j DNAT --to-destination 192.168.1.1:21
or something like this if you specify a source IP
Code:
-A VSERVER -s 123.123.123.123/32 -p tcp -m tcp --dport 2021 -j DNAT --to-destination 192.168.1.1:21
Unfortunately this breaks TLS* PASV connections.

You can do this to fix it. [Since V42E7 this is not necessary as the firmware automatically creates the rule]
Untitled.png

* The reason why this additional rule is not required when using non-TLS FTP is because the router has a ftp helper which reads the PORT and PASV commands and dynamically NATs the appropriate data port. With a TLS connection the commands are encrypted and therefore cannot be read.
 
Last edited:

atkinsom

Regular Contributor
@ColinTaylor ....You are bang on. I was heading that way but dismissed it since the rule was auto created as per your command you showed me above. Your explanation is perfect and I'm sure this will help others in a similar situation. Thanks very much
 

mark76

Occasional Visitor
I upgraded my RT-AC66U a few days ago from 39E3 to 42D5 and it is running smoothly, no issues detected, even without resetting the router after upgrade. I'm using a small set of features: DoT, DHCP, DNSFilter, Parental Control.
Great work! Thank you John! And thanks for the Community for good support.
 

jrmwvu04

Very Senior Member
Thanks for your suggestions .
I did install the fresh firmware and then reset to default by using the restore button in settings and also by pressing WPS button during start and it was completely reset . ( not sure how to do NvRam reset in Forks firmware).
The results were same.

I then tried manually all the channels which could give me good results , one important thing which i observed was 20 Mhz was giving me highest MB 20-30 Mpbs but after sometime again that would come to 6-8 Mbps.
I have even tried router reboot and checked if this helped , but no its the same result .
Attached screenshot of my router settings for 2Ghz .

Let me know if i am missing something or if there are any other suggestions .
Are you using b or g clients? If you aren’t, I would set the 2.4 radio to N only. Beyond that, what you describe still sounds to me like either hardware failure or interference. I don’t know why else it would work for a while and then start to bog down. Do you live in a crowded space? I know that sometimes there is a prohibitively difficult situation, but it could be worthwhile looking to migrate as many things as you can to 5ghz and drop 2.4 altogether. I did that some years ago because I lived in an apartment complex and had problems not unlike yours. A neighbor who runs their microwave constantly can cause you more problems than you might guess.
 

Markmaster

Regular Contributor
Unfortunately, mu AC68U dead. I go to Ubiquity and have some issues I don't have on the Asus router. On the Asus, while I mount SMB, and start copying files on it, I can switch on TunnelBear or NordVPN анd local network was untouched by this. Everything was good. Now, when I SMB to my local NAS, and switch on NordVPN or TunnelBear - connection to my local network stops. I remember, that Asus has some sort of option "VPN passthrough" or sort of. Is this a thing I am looking for?
cc: @john9527 @RMerlin
 

Jack Yaz

Part of the Furniture
I have purchased an AC56U, but due to COVID-19 the seller can't get to the post office to post it. I'm afraid WebUI goodies for John's fork will have to wait a bit longer :(

Sorry!
 

sbailey4

Senior Member
Yes, thanks, I will, but first I need to know exactly what this was on Asus. After that I can continue my investigation.
Probably what you are looking for are the various options in below screenshot:

upload_2020-3-27_18-50-31.png
 

john9527

Part of the Furniture
A new formal release has been posted for those still using this fork after all this time :) Please see the first post and review the Changelog for the updates.
Special thanks to @ColinTaylor for his testing and feedback/suggestions.

LATEST RELEASE: Update-42E7
26-March-2020
Merlin fork 374.43_42E7j9527
Download http://bit.ly/1YdgUcP
============================

SHA256
Code:
(Default Build - All supported routers)
3137f3b555d203610dceba6b6d545252c8e83c0536daad63c7437b65b32ee0d0  RT-N16_374.43_42E7j9527.trx
e9fc048afa5f3fc6393217d0cde17ba437697823823b94b7cd3eb60bc36c263a  RT-AC66U_374.43_42E7j9527.trx
720e88e6fde47d34faba8955f93047b69aad5b8b5c98199d53c34c5d79bc98f4  RT-N66U_374.43_42E7j9527.trx
41e25937614fe2404b96fadc1b62a1579714f1f47fdda93d489163b87b5ba1c4  RT-AC68U_374.43_42E7j9527.trx
e4feb4b04fc7895ef8b095b58d779a00175a8ea3c0cc30152fb6d04708d98766  RT-AC56U_374.43_42E7j9527.trx
As for my absence from the forum....
Some of you may remember that my father passed away last year. Without going into a lot of detail, let's just say that having to deal with his estate has been a challenge, both from a logistics/work-to-do and personal point of view. As a result, I needed to limit some of my activities. While things are still far from complete (and now complicated by the pandemic), I'm going to start easing back into my 'fun' pass times....participating in this forum being one of them.

Thanks to everyone that stepped up and provided support as well as for your understanding.
 

L&LD

Part of the Furniture
@john9527, so glad to have you back. This is truly a good day. :)
 

atkinsom

Regular Contributor
Great to have you back John. I've been using your Dev builds and have been more than thankful for your behind the scenes support during your difficult times. I guess I'll post the first question on the new build. In the change-log you mention Support for FTP/TLS mode, including automatic rule generation when another FTP server is present on the network.
Does this mean we don't have to do below in the GUI in order for the ASUS FTP/TLS server to work with multiple FTP servers in the same environment? The rule will be created automatically? Thanks again for your great firmware.

upload_2020-3-28_14-32-19.png

upload_2020-3-28_14-33-11.png
 

Attachments

  • Like
Reactions: il2

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top