Release [Fork] Asuswrt-Merlin 374.43 LTS releases (V44EA)

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

john9527

Part of the Furniture
Good to see you back John.

I just put 42E7 on my old RT-N66U, h/w B1, and I am running in AP mode. I gave it static ip.

The router will not update time. I read some things here about the issue with Merlin fw, but not sure if it's the same with this one.

Will leaving the ip dynamic, or putting in a dns solve the issue or any other work arounds? Thanks
Been a while since I set up an AP. I can pull my N66 and try it and refresh my memory....

First, did you do a factory reset after the switch?
Next...if you set the static ip on the AP itself (vs the parent router), it should force you to also set the DNS. I'd doulble check the LAN settings on the AP.

EDIT: Here's a screenshot you should have seen during the AP setup. If you enter a static IP here, the auto DNS setting changes to No and you need to put in an address. You can use your parent router address if you want.
AP-LAN.png
 
Last edited:

anotherengineer

Regular Contributor
Been a while since I set up an AP. I can pull my N66 and try it and refresh my memory....

First, did you do a factory reset after the switch?
Next...if you set the static ip on the AP itself (vs the parent router), it should force you to also set the DNS. I'd doulble check the LAN settings on the AP.

EDIT: Here's a screenshot you should have seen during the AP setup. If you enter a static IP here, the auto DNS setting changes to No and you need to put in an address. You can use your parent router address if you want.
View attachment 22413
Thanks

Yep, did a factory reset, including a jffs format, and a software reboot and a power cycle :)

Yes your screenshot, same as what I see, I did try putting in a DNS server (opendns) like the parent router (AC68U - Merlin) and then it ask me for a default gateway ip, which I have no clue which it should be?

Would it be better leaving the ip to dynamic instead of static?

Also, I could not click on yes to DNS, and while default is no, it is left blank like your screenshot.

I will try again, and let you know.

Thanks

Edit - ok went in through the setup like your s.s. (I think I was originally in the LAN tab) and entered the DNS and went through and saved/applied, then logged on, cleared log and rebooted.
and
Dec 31 19:02:16 ntp: NTP update failed after 5 attempts
also
Remind: The System time zone is different from your locale setting.

I set it to eastern cause that's where I am, but it wants to pull Atlantic, I am assuming that's cause thinks its December and dst isn't picked up

Also under LAN default gateway is 0.0.0.0.

Cheers
 
Last edited:

ColinTaylor

Part of the Furniture
@anotherengineer You need a default gateway, which will be your main router's IP address. Probably simpler just to leave the AP set as DHCP (look on the main router to find it's new IP address).
 

john9527

Part of the Furniture
@anotherengineer
'0.0.0.0' should work as the default gateway. Put your routers address in as the DNS address.

But, I would set the AP to DHCP....and it you want to assign it an address, do so from the parent router LAN/DHCP server.
 

john9527

Part of the Furniture
:confused: What gateway address does that create?
To be honest, I'm not sure how that works....although I know I've seen it used before. In fact, I'm logged in thru my N66 set up as an access point right now with these settings.
AP-LAN2.png

But, I really don't like this setup. Since it's static, you don't get a lease on the parent router showing the AP has connected or have an indication of it's address.
 
Last edited:

ColinTaylor

Part of the Furniture
To be honest, I'm not sure how that works....although I know I've seen it used before. In fact, I'm logged in thru my N66 set up as an access point right now with these settings.
View attachment 22416

But, I really don't like this setup. Since it's static, you don't get a lease on the parent router showing the AP has connected or have an indication of it's address.
Strange. Does it create a default route at all (System Log - Routing Table)? I've seen people try to use an Asus in router mode as an access point (with the WAN disconnected). That works, but without a default route any non-local IP addresses are unreachable (by the AP itself).

I guess that apart from NTP an access point has no need to access anything outside of the local subnet. So apart from the time being wrong it's not an issue.
 
Last edited:

john9527

Part of the Furniture
Strange. Does it create a default route at all (System Log - Routing Table)? I've seen people try to use an Asus in router mode as an access point (with the WAN disconnected). That works, but without a default route any non-local IP addresses are unreachable (by the AP itself).

I guess that apart from NTP an access point has no need to access anything outside of the local subnet. So apart from the time being wrong it's not an issue.
That's exactly it. I recreated the time not being set with gateway 0.0.0.0.....as soon as it's set to the router, everything works. Clients have access either way.
I'll put it on my todo list to not allow the default when you are setting up the access point with a static address.
 

mike7143

Occasional Visitor
Hello everyone, a quick question for you. It seems that VLANs are possible but I think that'd require more expensive VLAN-capable switches? Is it possible to configure two of the four ports for LAN1 and the other two ports for LAN2 where LAN1 and LAN2 don't connect/talk, both just share access with the WAN? Or will I need to look into setting up a pfSense box?
I want to put all my sketchy IoT crap on a separate network than my home/safe devices. Currently using an RT-N66U with 374.43_38E4j9527.
Thanks,
Mike
 

L&LD

Part of the Furniture
@mike7143 you may want to consider upgrading to the latest 42.E7 firmware for your model and then see if YazFi helps on your platform. :)
 

anotherengineer

Regular Contributor
@anotherengineer
'0.0.0.0' should work as the default gateway. Put your routers address in as the DNS address.

But, I would set the AP to DHCP....and it you want to assign it an address, do so from the parent router LAN/DHCP server.
Thanks John. If I set the N66 AP to DHCP, do I still have to put in the 68U router ip into the n66 DNS address?

(mech eng, not software eng :)
 

anotherengineer

Regular Contributor
Either that or set the radio button above 'Connect to DNS server automatically' to Yes
Thanks. Just set the Get LAN IP to Auto/Dynamic and it rebooted and picked up date/time. Forgot to change DNS, it was still on NO and BLANK, but time and date was picking up. Default gateway picked up routers IP.

Should I leave connect to DNS automatically on NO and Blank, or put something in, or change to yes?
 

Ryu Connor

Occasional Visitor
:confused: What gateway address does that create?
That address is a reserved address known as the route of last resort.

You should technically define the IP address of your Internet connected router or leave it blank, but based on what John is saying I guess the Linux networking stack will accept that reserved address as the default gateway.

Best practice would have the route of last resort only be leveraged on a routing table.

https://www.ietf.org/rfc/rfc1812.txt
 

ColinTaylor

Part of the Furniture
That address is a reserved address known as the route of last resort.
I know what a default route is but in this case that isn't what we're talking about. A default route has a network address of 0.0.0.0, the field we're talking about is the gateway address.
 
Last edited:

dave14305

Part of the Furniture
@john9527 As part of the new Addons API which you backported, I'd like to lobby to include Base64.js from Merlin to allow safe storage of long, multi-line custom settings that might include newline characters, etc.

Thoughts? :D
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top