Need help - Can't SSH into my router - acces denied

AndrewW

New Around Here
Hi all, thank you for reading.

I have a Asus RT-AC5300 with Asuswrt-Merlin, firmware version 386.3.2
I want to use Diversion add blocker on my router, and i need an ssh connection to it in order to run the scripts

I have JFFS custom scripts and configs enabled.
Under the Administration, system tab, i have SSH enabled .


1638698281900.png




I have used WINSCP and Putty to set up a SSH connection but i keep getting acces denied when setting up a connection.
I am 100% positive i am using the correct username and password.

Did some googling but cannot find anything specific other then changing the username to ROOT.

I also rebooted my router after enabling the settings just to be sure.

Anyone have any suggestions why i am not able to acces my router using SSH?
 

DanNuke86

Regular Contributor
Only problem I’ve had before (I’m on MacOS using terminal) is where the security key doesn’t match and I have to clear the cache before it allows me.

does the IP address inputted match that of your router? Command should read something like SSH 192.168.0.1?
 

AndrewW

New Around Here
Hi Dan thank you for your reply.

Its making connection with the router and [email protected] but keeps saying acces denied.

Im gonna save my router config and try it again with a factory default router firmware and try to find out if there is anything in the settings that prevents me from accesing.
 

bennor

Senior Member
Couple of suggestions.
  • Make sure you are using the right IP address for the router as the host name in WinSCP or Putty.
  • Make sure to use port 22 in both programs.
  • In Putty make sure SSH is selected for the Connection Type.
  • For File Protocol in WinSCP use SCP.
  • If you have changed the router login name from "admin" to something else you would use that new name, not "admin", as the user name.
  • Passwords are case sensitive.
  • If you have used any special characters in the router password in the Merlin interface perhaps remove them, save the password and use the new password without special characters to log in via SSH as a troubleshooting step.
  • If using any firewall/security software/anti virus on the computer, temporarily disable it. Possible that software is blocking WinSCP/Putty from accessing the router.
 

AndrewW

New Around Here
Couple of suggestions.
  • Make sure you are using the right IP address for the router as the host name in WinSCP or Putty.
  • Make sure to use port 22 in both programs.
  • In Putty make sure SSH is selected for the Connection Type.
  • For File Protocol in WinSCP use SCP.
  • If you have changed the router login name from "admin" to something else you would use that new name, not "admin", as the user name.
  • Passwords are case sensitive.
  • If you have used any special characters in the router password in the Merlin interface perhaps remove them, save the password and use the new password without special characters to log in via SSH as a troubleshooting step.
  • If using any firewall/security software/anti virus on the computer, temporarily disable it. Possible that software is blocking WinSCP/Putty from accessing the router.

Thank you so much! Special character in the pw was giving me the troubles!

:D
 

Patrick9876

Regular Contributor
To help others of us headaches, what special characters were causing problems? I've had problems with special characters in host names but don't recall hearing of them causing problems in passwords.

Searching the web I found inconsistant statements. A couple posts said there are no restrictions for Linux passwords - anything you can type. (But those posts did not mention SSH.) A couple posts mentions a list of unusable characters
Code:
(  )  + ?  ,  <  >  {  }  [  ]  |  ;  "  '
but those posts didn't mention the environment.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top