Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

AB-Solution - The Ad Blocking Solution (v3.9.2)

Discussion in 'Asuswrt-Merlin' started by thelonelycoder, Feb 15, 2017.

  1. Beherit

    Beherit Regular Contributor

    Joined:
    Sep 19, 2016
    Messages:
    64
    Try disabling Google's phishing and malware protection in the privacy settings.

    If it doesn't help and you have more time to spare, try exporting the pixelserv certificate and importing it to your Android phone.

    Instructions on how to export it: https://github.com/kvic-z/pixelserv-tls
    And the easiest way I found to import it to Android devices: http://cadroid.bitfire.at
     
  2. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    The top search results usually are affiliated links, using a redirect url that goes through one of the blocked domains.
    Not clicking them but the real site links below those works in 99% of the cases.
     
  3. GoNz0

    GoNz0 Very Senior Member

    Joined:
    Jul 14, 2013
    Messages:
    543
    Thanks but no dice :(
    Yes those are the problems, trouble is my wife isn't that technical so getting her to ignore certain links doesn't go down well.
     
  4. GoNz0

    GoNz0 Very Senior Member

    Joined:
    Jul 14, 2013
    Messages:
    543
    Giving up now thanks, it breaks more things than it fixes for me. I will give a browser based one a go.

    Sent from my SM-G920F using Tapatalk
     
  5. apokrif

    apokrif Occasional Visitor

    Joined:
    Dec 15, 2016
    Messages:
    13
    Agreed, except the former is less hassle, IMO of course.

    It’s no different with either approach.
    Anyway, it’s your program. All I want is to throw a suggestion. Let’s close this subject?

    Got, thanks!
     
    Last edited: Jun 3, 2017
  6. elorimer

    elorimer Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    322
    I'm a little puzzled. I have a domain blacklisted as it serves ads to a page I visit. As long as I have been following this dnsmasq method, the banner ads at the top of the page are blank. Recently, though, they remain blank in IE and Firefox, but appear in Chrome. I've flushed the windows dns cache, and flushed the Chrome cache repeatedly, and they still appear. Any ideas? It almost seems as if Chrome has started using its own DNS resolver.
     
  7. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    That would be a candidate for f option 4! Follow the instructions to the dot. See what AB finds...
     
  8. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    I just tested f option 4 with Chrome and Firefox.
    It works in Firefox, but Chrome seems to do it's own thing. It only worked the second time I tried, with Firefox first and on Chrome reloading the page.
     
  9. elorimer

    elorimer Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    322
    Thanks, found it. It is an artifact of enabling Chrome's data saver plug in. All http requests are sent to proxy.googlezip.net then, bypassing all of the blocked domains. When I removed the plug in, things returned to normal.
     
    thelonelycoder likes this.
  10. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    AB-Solution website migration under way.

    Starting now, the ab-solution.info website is being migrated to a new server.
    This is an ongoing process and will take about 24 hours to propagate worldwide.

    I expect to no longer experience any website downtime after the migration.
    The current website runs on IP 80.74.145.2, the new server IP is: 80.74.156.155.
    Both servers are located in a Data-center in Zurich, Switzerland.

    This migration is not noticeable in any way except for the IP address change.
    All services will be up on both servers until worldwide Name-server propagation is over.

    Edit: Website is now running on the new Server, Name-Servers have been changed.
    For Europe/Switzerland this means the website will be served from the new server within 2 hours, 24 hours worldwide.
     
    Last edited: Jun 3, 2017
  11. apokrif

    apokrif Occasional Visitor

    Joined:
    Dec 15, 2016
    Messages:
    13
  12. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    Makaveli likes this.
  13. quant88

    quant88 Occasional Visitor

    Joined:
    Jan 20, 2017
    Messages:
    11
    Today I was trying to upgrade to pixelserv-tls version v35.HZ12.Kj with PS + 6 option. However, http://IP/servstats cannot be found. Next, I select option 7 to reset pixelserv settings and purge certificates. This time http://IP/servstats shows up so I believe it's working.
     
  14. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    Important, please read:
    Updating / upgrading pixelserv-tls to the latest version Kj


    The Entware package repository now offers the latest version of pixelserv-tls v35.HZ12.Kj for both MIPS and ARM routers.
    This update or upgrade replaces the start file /opt/etc/init.d/S80pixelserv-tls with a standard version that will not work in AB-Solution.
    The solution is as simple as turning ad-blocking (a) off and back on after the update. This writes a new compatible start file and pixelserv-tls will work again. Then purge the old certificates.

    Steps to successfully update pixelserv-tls from Ki to Kj:
    1. in the ps menu select '6. Manage Entware packages'
    2. use either option '4. update and upgrade pixelserv' or '6. update and upgrade installed packages' to update/upgrade the Entware package(s)
    3. turn off and back on ad-blocking, using the a option
    4. in the ps menu, select '4. Purge generated pixelserv certificates' and confirm to purge the old certificates
    5. Step 4 is mandatory if you updated to pixelserv.tls version Kj!
    6. check if all went well by looking at the stats page: http://pixelservip/servstats where pixelserv ip is the ip address that pixelserv is listening on

    It will report: pixelserv-tls version: v35.HZ12.Kj
    Then log into your router's WebUI and look at the Syslog while browsing some websites. The log should contain entries for creation of new pixelserv certs for https domains.

    Happy ad-blocking!

    Note: This is what happened to @quant88 in the post above this post. Do not follow his way, there is no need to reinstall everything, just turn ad-blocking off and back on, then purge the old certificates.

    FYI, this is what a working /opt/etc/init.d/S80pixelserv-tls file looks like, <pixelserv IP> being your real IP:
    Code:
    #!/bin/sh
    
    # DO NOT EDIT this part of the file #
    # generated by AB-Solution 3.8
    export TZ=$(cat /etc/TZ)
    ENABLED=yes
    PROCS=pixelserv-tls
    ARGS="<pixelserv IP> "
    PREARGS=""
    PRECMD="ulimit -s 64"
    DESC="$PROCS (AB-Solution)"
    PATH=/opt/sbin:/opt/bin:/opt/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    . /opt/etc/init.d/rc.func
    # end of DO NOT EDIT #
    To view the file, go into the AB sub menu and use the sf option.
     
    Last edited: Jun 4, 2017
  15. elorimer

    elorimer Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    322
    1. Did this, worked fine, going from the earlier dynamic build of .kj to the entware build.
    2. I'm now reporting a pixelserv build date of May 30 (had been May 26), but not May 31.
    3. What changed in the S80 file from the .ki version--didn't see it?
     
  16. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    It's just the build date, I removed this part in the original post. The Kj is important.
    Nothing changed. The problem is that the update/upgrade replaces the AB file with a standard S80pixelserv-tls file.
    Standard S80pixelserv-tls is this, a bare bone minimum compared to the AB file posted in my original post:
    Code:
    #!/bin/sh
    
    ENABLED=yes
    PROCS=pixelserv-tls
    ARGS=""
    PREARGS=""
    DESC=$PROCS
    PATH=/opt/sbin:/opt/bin:/opt/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    
    . /opt/etc/init.d/rc.func
    AB uses optimizations and directs to only use the reserved IP. Without the IP part pixelserv wants to listen on every IP with *80 which fails and therefore pixelserv won't start.
    AB overwrites this file every time a change is required to it. Switching ad-blocking off and on is one of the reasons. It rewrites the ENABLED=yes to ENABLED=no.
     
  17. Xentrk

    Xentrk Very Senior Member

    Joined:
    Jul 21, 2016
    Messages:
    1,009
    Location:
    Chiang Mai, Thailand
    Thank you for the very clear instructions. For step 2, I selected option '6. update and upgrade installed packages' to update/upgrade the Entware package(s): I also got May 30 instead of May 31. 3 routers updated with the following line at the top of pixelservip/servstats:
    Code:
    pixelserv-tls version: v35.HZ12.Kj compiled: May 30 2017 22:33:13 options: pixelservip
    
     
    Last edited: Jun 4, 2017
    thelonelycoder likes this.
  18. thelonelycoder

    thelonelycoder Part of the Furniture

    Joined:
    Jan 23, 2014
    Messages:
    3,349
    Location:
    Switzerland
    I copied that line from a MIPS router, @kvic must have compiled it on the 31st, while the ARM version was done a day before.
     
  19. Makaveli

    Makaveli Regular Contributor

    Joined:
    Nov 4, 2016
    Messages:
    178
    Location:
    Canada
    Thanks for the quick guide that worked for me.

    Went from april build to new one now.

    pixelserv-tls version: v35.HZ12.Kj compiled: May 30 2017
     
    thelonelycoder likes this.
  20. Xentrk

    Xentrk Very Senior Member

    Joined:
    Jul 21, 2016
    Messages:
    1,009
    Location:
    Chiang Mai, Thailand
    What script is generating this message in system log?
    Code:
    Jun  4 21:07:14 admin: Started pixelserv-tls (AB-Solution) from .
    Should there be some text after the "from"? Danke.
     

Share This Page