What's new

GT-AX6000_388.2_2_rog issues with web GUI (menus not fully loading, dashboard not rendering, NaN values)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I have updated to 388.2.2 and the web GUI is doing really strange stuff.

Dashboard menu doesn't always load;
- Sometimes only partial icons / menu's load
- Missing graphics, displaying broken image links
- Sometimes not loading at all (white screen)
- Reloading any config page works intermittently (1 out of 5 times)
- This is irrespective of using www.asusrouter.com or to access the device menu.
- There are no other devices using, RTT pings across wifi are ~3ms.
- Network traffic on the dashboard says "NaN bytes". I assume this is not a client side computation and there is a memory issue?

Settings in menu functions don't always work. I assume this is because there is a content loading issue for some of the settings to work.

There are no definitive errors in the system log that would point to an issue with filesystem errors (or anything else for that matter). The config is pretty vanilla.

I have rolled back to 388.2.0 (with a factory reset) and the problem persisted.
I have factory reset the device on 388.2.2 both by holding down the reset button and powering on (ASUS factory reset procedure) AND also tried using the GUI factory reset feature (including checking the box to Initialise all the settings, and clear all the data log for AiProtection, Traffic Analyzer, and Web History.).

I am not using previous saved settings or configs.

On setup, I am selecting "Wireless Router" and specifying the static IP config for my DSL modem (one IP, subnet, GW and DNS) and specifying Wifi SSID / password. The menu feels a bit sluggish.

Wifi config works without issue. Internet speeds are as expected. Network topology has no other devices than the AX6000 connected to a FritzBox.

It feels like there is some issue with the filesystem or a persistent cache or setting somewhere that is not being cleared. I have tried accessing the web GUI using two different workstations in the event that it was a local machine issue or content filter.

Next steps are to go back to stock ASUS firmware and then back to 388.2.2 again and see if that makes any difference but I would REALLY love some other ideas in the meantime.



  • Screenshot 2023-06-24 at 9.45.02 AM.png
    Screenshot 2023-06-24 at 9.45.02 AM.png
    357 KB · Views: 33
I moved back to stock ASUS firmware, performed another factory reset and then re-installed 388.2.2 and the problem is fixed. Menu's work, no missing icons.

I have no idea WTF was going on.

After flashing the firmware you want to use, perform a full reset. Resetting before flashing the firmware you want to use, is not the same thing.

Do not use a saved backup config file. Particularly not one from another router (same model, or otherwise).

Do not insert a USB drive previously used by amtm/scripts. Be sure to format it first on a PC to NTFS format before inserting it to a fully reset router.

Do not toggle settings on/off past their defaults. This is not the same as leaving them at their defaults in the first place.

After ~15 minutes of the router running new firmware, reboot both the router and the computer used to set it up. (Sometimes, just clearing the browser's cache may work too).

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!