What's new

RT-AC5300 - Failing to Link either of IFTTT / Alexa

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Greetings! I'm am trying to enable both Alexa and IFTTT on my RT-AC5300 - It is failing to perform the link for Alexa & for IFTTT.

My setup is a Virgin Hub 3.0 in modem mode, and the RT-AC5300 is behind that.
I have enabled DDNS & web access, and these are functioning as expected - ie I can access the router from the internet.

Whatever Ive tried, I always get this error when attempting to link:

I have tried on different browsers. Ive disabled WEB/DDNS, rebooted, re-enabled .. Power cycled. etc
I also tried the linking procedure from a totally different computer on a different internet connection (logged into router, amazon, ifttt) rather than any part of it bieng on the LAN.
Nothing has helped. 😭

Might be worth mentioning that when attempting to link, it will take several seconds before failing (with the ever-helpful msg as shown above)

I thought perhaps this might be related to https - as I get that cert warning when attempting to connect to the router via the web. Could this have something to do with it?
I tried to sort out the certificate thing - but my Asus MEnus differ from thos ein the docs, so Im not sure I was able to do this successfully. ANyway there is no mention of having to address this ib the ifttt/alexa linking docs.

Please advise - as I am totally out of Ideas here. Many thanks! 🙏

oops! I guess I shoulda posted this under wifi5 board (?) Noooo! not trying to bump my thread at all. no-sir!
Do we have all the information? Such as is the Virgin modem/router now in full bridge mode?
Considering this question is a continuation of an earlier post, confirming that the VM modem/router is indeed in true modem-only mode is, I believe a valid question!
Even if it is though, the OP is not going to be able to access the router via HTTPS and the WAN port as the certificate is issued to and not the DDNS registered name!
100% True modem mode - yessiree! So do the combination of words in @Crimliar 's post above indicate that this is not going to work ? 😭

I'm able to connect to my router from t'tinternet - but indeed not via HTTPS at the moment.

any suggestions that may allow me to get this feature running as intended ¯\_(ツ)_/¯

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!