[384.16_Alpha Builds] Testing all variants

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

RMerlin

Asuswrt-Merlin dev
Merlin, quick question on alpha2 and RT-AX58U. It appears the /opt/var directory is missing. I seemed to recall that you had corrected a Broadcom script that created the /opt structure - and that you had added /opt/var. Is that in this release?
Did you try setting up Entware through amtm? I remember specifically addressing this during development, unless the commit got lost when I migrated it from the private into the public code repo.
 

JGrana

Senior Member
Did you try setting up Entware through amtm? I remember specifically addressing this during development, unless the commit got lost when I migrated it from the private into the public code repo.
Nevermind, it's there...sorry.
 

JWoo

Senior Member
I have say that the triple core CPU on the RT-AX58U runs really cool, less than 60 degrees C and the wireless chips run at less than 50 degrees C. Pretty impressive actually.
 

swejuggalo

Regular Contributor
What is 1.2gpm?

Is that the connected rate to the router? a speedtest number? please eloborate.



So you are talking about the connection rate to the router at 866.

On my Galaxy S10 in wifi 6 mode my connection rate is usually close to 900 i'm still on 384.15 though not on alpha.

Here is a speedtest at my normal connection rate.

Yeah, beyond 866 on wifes S10+ too (seen peaks above 900). But with the second build of the alpha for AX88U the speeds are different on both her and my device. Havn't tried the first alpha build.
 

JWoo

Senior Member
Looks like Asus just posted it. That is a good release! Thank you @Adamm !
 

DonnyJohnny

Very Senior Member
@Merlin are you planning to add this ( Security Fix: CVE-2019-15126 ) to your next AX58 build ?
Looks like Asus just posted it. That is a good release! Thank you @Adamm !
FYI, Merlin would need Asus source code to be released before he able to merge it to asuswrt-merlin. Before he merge it, he would still need some time to resolve any issue/error occured during the merging.

So mean everything takes time. We have to wait for Asus to release source code of that particular GPL (not the normal firmware we can used to flash) and Merlin needs time to merge it.

Please chase Asus instead to release source code quickly and not chase Merlin. Lol...

U can see whether the source code is release as per pic attached.

 

det721

Part of the Furniture
That source code is the older firmware released in January 384.8137 The CVE-2019-15126 fix is in the 384.8563 firmware and that GPL is not released yet as far as i can see.
 

RMerlin

Asuswrt-Merlin dev
Kr00k has a security ranking of 3.1 out of 10 on the NVD. It's nothing to lose sleep over.
 

JWoo

Senior Member
Kr00k has a security ranking of 3.1 out of 10 on the NVD. It's nothing to lose sleep over.
Rmerlin you have a sense of humor! We should lose more sleep over crooks than Kr00k (or Kevin Bacon).
 

laracroftonline

Regular Contributor
Can we get the latest curl in this version?
 

det721

Part of the Furniture
For now went back to stock. The log spam every second non stop was killing me. The, kernel: _blog_emit, blogp = 0x660 . Never had this in stock firmware and its nasty every second non stop. Makes the sys log useless. I know it's Alpha so i will hold off for now with the AX58U.
 

RMerlin

Asuswrt-Merlin dev

RMerlin

Asuswrt-Merlin dev
For now went back to stock. The log spam every second non stop was killing me. The, kernel: _blog_emit, blogp = 0x660 . Never had this in stock firmware and its nasty every second non stop. Makes the sys log useless. I know it's Alpha so i will hold off for now with the AX58U.
Just change your logging priority then. Asus left this debugging output in there, with a priority of Notice instead of Debug as it should have been, I already changed it on my end, but you can tell your router not to log them just by adjusting priority.
 

Makaveli

Very Senior Member
Just change your logging priority then. Asus left this debugging output in there, with a priority of Notice instead of Debug as it should have been, I already changed it on my end, but you can tell your router not to log them just by adjusting priority.
Or just use your router and stop eyeballing the log :)
 

det721

Part of the Furniture
Just change your logging priority
The apply tab does not work for changing the log level with 16 Alpha AX58. If I SSH in and set the log level to =5 then i get nothing in the log at all.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top