XT8 Mesh - great signal strength but slow internet speed

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

DWH

Occasional Visitor
My XT8 setup (router + 1 node) is providing great signal strength everywhere in my home, the node shows "GREAT" connection, but I can barely get 100mps on the 2.4 & 5_1 bands even though I have solid gigabit service. I have confirmed internet speeds ranging from 800-900+ at all of the ethernet ports of the main router. If I connect to the 5_2 band I can get 150 and occasionally as high as 200 but that's it. I have reset both routers several times and tried separate SSID's for all 3 bands and I am currently using Dual-Band Smart connect but it doesn't make much difference. I don't expect to get gigabit speeds but everything I have read about the XT8 says I should expect much higher speeds. Does anyone have any suggestions on settings etc?

Thanks!
 

L&LD

Part of the Furniture
Have you tried with a new SSID?
 

L&LD

Part of the Furniture
See my signature for the link.
 

DWH

Occasional Visitor
Using different SSIDs allowed me to assign 2.4 to some low priority stuff and 5 to others. Using the Dual-Band Smart connect feature means there is only one SSID for both bands and the router decides which band to use for each device. With a strong signal, always better that -60 to -35, I would definitely expect faster speeds than 100 on the 5-1 band and even faster on the 5_2 band. So there must be something I have setup wrong.
 

DWH

Occasional Visitor
Thanks, I was wondering about that, I've read good and bad about Smart Connect and I'm having issues with some smart bulbs and switches not connecting so I'm going to turn it off. Do you recommend any settings that might help the Internet speed?
 

wase in az

Occasional Visitor
get your system setup so that all your devices connect properly first, then I would work on internet speeds..

only fix one issue at a time, then move on to the next..reboot your system after turning off smart connect
 

DWH

Occasional Visitor
I've turned off Smart Connect and everything is finally connected using a different ssid for all 3 bands. The fastest consistent speed I get on any device is about 160, with an occasional jump to about 200 but nothing faster. What should I check next?
 

KingBravery

Regular Contributor
do you enable QOS or bandwith limiter?
 

thiggins

Mr. Easy
Staff member
What device are you testing with?

Make sure you start by connecting your device to the root node (the one with Ethernet connection).
 

DWH

Occasional Visitor
What device are you testing with?

Make sure you start by connecting your device to the root node (the one with Ethernet connection).
SInce it's mesh I can't see a way to force a device to connect to the root node. I have laptops with AC1200 and AC1900 network adapters and it doesn't matter where I place them I get the same approximate speeds, roughly between 150-200 on the 5ghz band and around 50 on the 2.4 band. I have hit 300 with my Galaxy S10e which has wifi6.
 

thiggins

Mr. Easy
Staff member
Temporarily power off the other mesh points to test. Also make sure all other devices are idle or off when you test.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top