change wireless band to 5Ghz

mocnak

Occasional Visitor
Hi all,
I have Asuswrt-Merlin 386.4 on RT-AC86U. I changed my WIFI settings with:

enable smart connect OFF
Band 5Ghz
Hide SSID Yes
Wireless mode N/AC mixed

however, on my phone (Xiaomi Poco X3 Pro, Android 11) I am still connected with 2.4GHz. On W10 laptop I got 5Ghz. Am I missing something, why doesn't my phone connect with 5Ghz band ? I tried restarting router and also forgetting network on Android and connecting again, still uses 2.4Ghz.
Does router fallback to 2.4Ghz band if for any reason 5Ghz doesn't work for specific device ?
 

ColinTaylor

Part of the Furniture
Are you using different SSIDs for each of the bands?
 

ColinTaylor

Part of the Furniture
no, only one
That's why. Your phone sees the 2.4GHz signal as the strongest so that's what it's connecting to. This is a client issue and nothing to do with the router.
 

Viktor Jaep

Senior Member
however, on my phone (Xiaomi Poco X3 Pro, Android 11) I am still connected with 2.4GHz. On W10 laptop I got 5Ghz. Am I missing something, why doesn't my phone connect with 5Ghz band ? I tried restarting router and also forgetting network on Android and connecting again, still uses 2.4Ghz.
Does router fallback to 2.4Ghz band if for any reason 5Ghz doesn't work for specific device ?
Instead of it letting it pick an automatic channel, try picking a different channel. Perhaps your phone just doesn't like whatever it's currently sitting at? Also, try turning your 2.4GHz off for now, just to help with the troubleshooting process, and see if that forces your phone to choose the 5GHz range?
 

Smokey613

Very Senior Member
Hi all,
I have Asuswrt-Merlin 386.4 on RT-AC86U. I changed my WIFI settings with:

enable smart connect OFF
Band 5Ghz
Hide SSID Yes
Wireless mode N/AC mixed

however, on my phone (Xiaomi Poco X3 Pro, Android 11) I am still connected with 2.4GHz. On W10 laptop I got 5Ghz. Am I missing something, why doesn't my phone connect with 5Ghz band ? I tried restarting router and also forgetting network on Android and connecting again, still uses 2.4Ghz.
Does router fallback to 2.4Ghz band if for any reason 5Ghz doesn't work for specific device ?
Why are you hiding the SSID?
 

mocnak

Occasional Visitor
So I followed ColinTaylor's hint and set different name for 5Ghz network (link for this second network was not that intuitive for me), phone was complaining about poor signal and reconnecting.
So enabled again Smart Connect, however with smart connect I never get 5Ghz, even when I am in the same room as router. Thanks for support everyone
 

ColinTaylor

Part of the Furniture
So I followed ColinTaylor's hint and set different name for 5Ghz network (link for this second network was not that intuitive for me), phone was complaining about poor signal and reconnecting.
So enabled again Smart Connect, however with smart connect I never get 5Ghz, even when I am in the same room as router. Thanks for support everyone
Try manually selecting the 5GHz channel. Different channels groups (36-48, 52-64, 100-144, 149-165) have different signal strengths.
 

bbunge

Part of the Furniture
If you are using DFS channels on the 5 GHz some of your older clients may not be able to connect. I recommend using Dual Band SmartConnect with both 2.4 and 5 GHz on Auto channel to start. You may want to set the 2.4 GHz to 20 MHz and the 5 GHz to 80 MHz. Trust the router to work out the best channels to start with. Do not mess with the settings in the professional area and if you have changed WIFI settings and do not remember how to change them back a router factory reset and manual configure may be in order. I know setting the router up again is a pain but it will be worth it. If you are having issues with Merlin 386.4 going back to Asus firmware may help. I have an AC86U that has been up on Asus firmware for something like 58 days with no issues and with the settings I recommended.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top