RT-AC86u upgrade to 3.0.0.4.386 re-IPd my Guest Networks

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

brentil

Occasional Visitor
I have a RT-AC86u on stock Asus firmware just the single router, no mesh. I have several "Guest Networks" setup for things like IoT devices and actual guests which all of those have Access Intranet = Disabled for isolation. Every device on my network has a DHCP static lease so that every item exists on the same IP always. LAN -> DHCP Server -> Manually Assigned IP around the DHCP list. After the upgrade to 3.0.0.4.386 a week ago everything was working fine until I rebooted recently when I added in a new DHCP static lease. As my guest systems started hitting back in again they all started changing their IP Class C IP space.

Original IP space = 192.168.29.
New Guest Network IP Space = 192.168.101. and 192.168.102.

It's also ignoring all of my DHCP Static leases for these devices now which was IPs in the main IP space. I haven't tried giving them DHCP Static leases in the new IP space yet though.

I haven't been able to find anywhere in the admin interface to control this behavior.

1603989996687.png
 

OzarkEdge

Part of the Furniture
I haven't tried giving them DHCP Static leases in the new IP space yet though.
Maybe try that, but I'm doubtful. Also confirm this behavior on the second and third index guest WLANs... they still do not sync to AiMesh nodes.

The new guest IPs are by design to better isolate guest clients on guest WLANs across all AiMesh nodes.

OE
 

brentil

Occasional Visitor
Maybe try that, but I'm doubtful. Also confirm this behavior on the second and third index guest WLANs... they still do not sync to AiMesh nodes.

The new guest IPs are by design to better isolate guest clients on guest WLANs across all AiMesh nodes.

OE
I found it very odd that it wasn't doing this then started. Making a change to the DHCP area must have cleared something out that was preventing it from doing it before.

I noticed I have .101 and .102 and checked the .101 is Guest Network 1 and .102 is Guest Network 2.

I'll test making a static lease in the new range they now exist in and see if that works.
 

bbunge

Very Senior Member
Looks like you can not reserve an IP address in the guest WIFI. I set up a guest in the 2.4 GHZ band and the router assigned an ip address of 192.168.101.214. I tried to enable MAC and IP Address Binding and I got an error of not a valid IP address. Did not try to enable any other guest WIFI and I have no node to sync to. But I am pleased with this function as I have a guest network to deploy on a couple of AC68U's whenever Asus decides to release the firmware.
 

brentil

Occasional Visitor
Like bbunge said the interface won't let me telling me the IP is invalid even though it pre-populated the IP address field with the current IP of the device... Well this completely breaks all of my static assignments and DNS entries for them and any firewall allowances I had. Frustrating to say the least.

1603996049804.png
 

OzarkEdge

Part of the Furniture
As an aside, I wonder if the setting to allow guest intranet access has any affect on guest IP assignment. I doubt it.

OE
 

bbunge

Very Senior Member
Like bbunge said the interface won't let me telling me the IP is invalid even though it pre-populated the IP address field with the current IP of the device... Well this completely breaks all of my static assignments and DNS entries for them and any firewall allowances I had. Frustrating to say the least.

View attachment 27276
So, what does it matter what IP address devices in the guest network are assigned? Use the address the guest DHCP gives out or do a static for each device in the 192.168.101.0/24 subnet. Note: static IP addresses are set in the device manually not via DHCP.
 

brentil

Occasional Visitor
So, what does it matter what IP address devices in the guest network are assigned? Use the address the guest DHCP gives out or do a static for each device in the 192.168.101.0/24 subnet. Note: static IP addresses are set in the device manually not via DHCP.
Because one guest network is IoT devices and I want them to always exist in the same location for firewall rules and DNS lookups.

You can set the static lease in the DHCP menu I mentioned above, it's been the primary place for Asus devices for over a decade before they added the direct device pages.

Either way it doesn't work there either.

1604006419155.png
 

brentil

Occasional Visitor
So I thought I had tested the 2nd Guest Network but I guess I hadn't. The 2nd guest network is on the main IP space, seriously what gives? I went checking the settings again and the only thing I noticed that was different is that the 1st guest network has a "Sync to AiMesh Node" option which is set to Router Only by default. Guest network 2 and 3 don't have that option. I'm not sure if that has anything to do with this. Almost makes me wonder if I move my IoT network to GN3 if it'll let me start using static leases again?

GN 1 options
1604363163022.png


GN 2 & 3 options
1604363188191.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top